When sending reply to mail with inline image attachment incorrect image is attached

RESOLVED INCOMPLETE

Status

MailNews Core
Composition
RESOLVED INCOMPLETE
3 years ago
a year ago

People

(Reporter: richard, Unassigned)

Tracking

x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

Replied to mail with inline image attachement.


Actual results:

In my reply the incorrect file (a non-inline image file attachement from a previous e-mail thread) was substituted for the image in the original mail. 


Expected results:

The correct inline image should have been sent or no inline image at all.

Comment 1

3 years ago
Please provide a specific testcase (and note that this is a public bugtracker so please replace any confidential information beforehand)...
Flags: needinfo?(richard)
(Reporter)

Comment 2

3 years ago
(In reply to Andre Klapper from comment #1)
> Please provide a specific testcase (and note that this is a public
> bugtracker so please replace any confidential information beforehand)...

Hi Andre - I have a problem here in that the only time I have observed this bug it contained confidential information and I have been unable to reproduce it under controlled conditions - i.e. by sending myself and replying to mails with inline attachments.

I originally filed this as side-effect to bug 532395 (where the sending of a reply/forward hangs) and it has been further linked to:
Bug 766495 for swapped images
Bug 799450 for swapped text
Bug 854798 Compacting changes msg key

Apparently the underlying cause is being addressed in a forthcoming release of TB38.

The only thing I can add is that when this issue occured an interim (autosaved) copy of the e-mail I sent in reply subsequently appeared in drafts - despite the fact that the reply had been successfully sent.

I shall keep trying to reproduce the problem but remain hopeful that the underlying cause has already been addressed.
Flags: needinfo?(richard)

Comment 3

2 years ago
richard,
do you still see this when using version 45?
Flags: needinfo?(richard)
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #3)
> richard,
> do you still see this when using version 45?

Or 52.

No reply, so far, so => incomplete
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Component: Untriaged → Composition
Flags: needinfo?(richard)
Product: Thunderbird → MailNews Core
Resolution: --- → INCOMPLETE
Version: 31 Branch → 31
You need to log in before you can comment on or make changes to this bug.