Closed Bug 1143395 Opened 7 years ago Closed 6 years ago

Right click on Flash object with accessibility active crashes the plugin process

Categories

(Core :: Disability Access APIs, defect)

32 Branch
x86_64
Windows 8.1
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1133351

People

(Reporter: u534134, Unassigned)

Details

(Keywords: crash, regression)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

Windows 8.1 64 bit, desktop PC, when i go on a flash object and right click browser is froozen and after a while flash Crash


Actual results:

Right click on flash and flash Crash


Expected results:

Rigth menù
Severity: normal → major
Plugin crashes.

Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=32d85748426d&tochange=69f12c694630

Regressed by: Bug 1014673


WORKAROUND:
Setting accessibility.force_disabled = 1 helps.
Blocks: 1014673
Severity: major → critical
Status: UNCONFIRMED → NEW
Component: Untriaged → Disability Access APIs
Ever confirmed: true
Flags: needinfo?(jmathies)
Keywords: crash, regression
Product: Firefox → Core
Version: 36 Branch → 32 Branch
When this will be resolved please let me know, i will download the last Firefox edition, for now i can only use ESR who is not affected. If i use last version i can lost all my work if i right click accidentally with mouse so waiting. Thanks for work to fix this issue.
Summary: Flash Crash when rigth click → Flash Crash when right click
Flags: needinfo?(jmathies)
Summary: Flash Crash when right click → Right click on Flash object with accessibility active crashes the plugin process
(In reply to Jim Mathies [:jimm] from comment #5)
> Windows 8.1 only, very high crash rates.
> 
> https://crash-stats.mozilla.com/report/
> list?product=Firefox&signature=hang+|+ntdll.dll%400x3cbec

Well, I take that back. 7K over 7 days would be quite high for Nightly, but not for all 6-week releases combined.
wow now is 12.093 crashes
only 146 comment and people unhappy with this crash on Firefox.

I hope really to can be able to use last Firefox edition soon :(
As the discussion here: https://bugzilla.mozilla.org/show_bug.cgi?id=1151794 seems problem is fixed in Firefox Nightly 40
How can i be informed about time to can update from my ESR version to the last Firefox edition with the Flash Crash issue resolved? Some times i try to install the last edition and check but issue continue to be so i come back to ESR version!? Thanks.

This is very bad issue, stressful for Firefox user.
The only acctually version not affected is ESR, Nightly is only for test only.

Hope will be fixed in all official relased soon!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151794
Duplicate of bug: 1133351
You need to log in before you can comment on or make changes to this bug.