Closed Bug 1143411 Opened 5 years ago Closed 5 years ago

Build failure with next freetype version/current git master

Categories

(Core :: GFX: Color Management, defect)

36 Branch
x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox39 --- fixed
firefox-esr38 --- fixed
thunderbird_esr38 --- fixed

People

(Reporter: ninuje, Assigned: ninuje)

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150315132254

Steps to reproduce:

Trying to build firefox 36.0.1 against current freetype master.


Actual results:

Build failure (undefined reference to FT_Get_X11_Font_Format) when linking libxul.


Expected results:

A successful build ;).

----

In the same vein as #944454, this is caused by an upstream change touching the headers (ftxf86.h moved to ftfntfmt.h, cf. http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=0633995b558975fabe3082f50836b93d5077a03e && http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=f4d1c11faa116daad655b50828a434babbdaed2a).

The fix is as simple as adding ftfntfmt.h to the list of freetype headers in config/system-headers :).
QA Whiteboard: [bugday-20150316]
Component: Untriaged → GFX: Color Management
Product: Firefox → Core
Thanks for the report and analysis!

> The fix is as simple as adding ftfntfmt.h to the list of freetype headers in
> config/system-headers :).

Are you interested in writing a patch that does this simple fix?
Here goes :).
Comment on attachment 8578264 [details] [diff] [review]
firefox-36.0.1-buildfix-ft-master.patch

Thanks! Requesting review from :glandium.
Attachment #8578264 - Flags: review?(mh+mozilla)
Attachment #8578264 - Flags: review?(mh+mozilla) → review+
Reformatted patch as per guidelines.
Attachment #8578264 - Attachment is obsolete: true
Added "r=glandium" to commit message and landed:

https://hg.mozilla.org/integration/mozilla-inbound/rev/afd840d66e6a

Thanks, NiLuJe!
Assignee: nobody → ninuje
https://hg.mozilla.org/mozilla-central/rev/afd840d66e6a
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Is it possible you are using the internal headers even when linking against system freetype?
Comment on attachment 8578529 [details] [diff] [review]
mozilla-central-buildfix-ft-master.patch

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
User impact if declined: Users with a newer Linux configuration will not be able to build.
Fix Landed on Version: 39
Risk to taking this patch (and alternatives if risky): Unknown, but probably minimal
String or UUID changes made by this patch: None

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.
Attachment #8578529 - Flags: approval-mozilla-esr38?
If this is what the included header looks like, it should be perfectly safe:
http://fossies.org/dox/freetype-2.6.1/ftfntfmt_8h_source.html
Comment on attachment 8578529 [details] [diff] [review]
mozilla-central-buildfix-ft-master.patch

No impact on the final product, taking it to help packagers and developers.
Attachment #8578529 - Flags: approval-mozilla-esr38? → approval-mozilla-esr38+
You need to log in before you can comment on or make changes to this bug.