hang closing 2 tabs with spotty Internet connection (unresponsive script - tabbrowser.xml:2089, Windows, Firefox 36.0)

RESOLVED DUPLICATE of bug 1078280

Status

()

RESOLVED DUPLICATE of bug 1078280
4 years ago
4 years ago

People

(Reporter: ligidium, Unassigned)

Tracking

36 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

Pages wouldn't load at all or wouldn't load completely due to my problem of a spotty internet connection (spotty internet connection is not because of Firefox), tried to close one or two tabs that didn't load properly.


Actual results:

Firefox froze, chrome://browser/content/tabbrowser.xml:2089 was unresponsive. Other Firefox windows seem unaffected when I have it stop the script.


Expected results:

The tabs should have closed so I can open a new tab and try to load the page again.

Comment 1

4 years ago
Have you seen this again?

If you haven't upgraded since then, could you post the source code corresponding to that line number? (see instructions in bug 1041788 comment 7.) We don't have an easy way to see what source code that line # corresponds to in your version of Firefox.
Component: Untriaged → Tabbed Browser
Flags: needinfo?(ligidium)
Summary: tabbrowser.xml unresponsive when closing tabs with spotty Internet connection → hang closing 2 tabs with spotty Internet connection (unresponsive script - tabbrowser.xml:2089, Windows, Firefox 36.0)
(Reporter)

Comment 2

4 years ago
I've seen this again even after updating to 37.0.2, except now it tells me 2153.

The line is
             if (!aTab || !aTab._endRemoveArgs)
Flags: needinfo?(ligidium)

Comment 3

4 years ago
Thanks! This is the same code as bug 1078280:
https://hg.mozilla.org/releases/mozilla-release/annotate/a7ee2c1f2cba/browser/base/content/tabbrowser.xml#l2153
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1078280
You need to log in before you can comment on or make changes to this bug.