Intermittent test_cache_add.html | application crashed [@ nsTArray_Impl<mozilla::dom::cache::StreamList::Entry,nsTArrayInfallibleAllocator>::AppendElements(unsigned int)]

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
4 years ago
2 months ago

People

(Reporter: cbook, Assigned: bkelly)

Tracking

({crash, intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

4 years ago
Windows 7 32-bit mozilla-inbound debug test mochitest-1

https://treeherder.mozilla.org/logviewer.html#?job_id=7632480&repo=mozilla-inbound

17:38:31 WARNING - PROCESS-CRASH | dom/cache/test/mochitest/test_cache_add.html | application crashed [@ nsTArray_Impl<mozilla::dom::cache::StreamList::Entry,nsTArrayInfallibleAllocator>::AppendElements(unsigned int)]
17:38:31 INFO - Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpuqyjq0.mozrunner\minidumps\910a9b41-9d00-4842-9216-21d20f003253.dmp
17:38:31 INFO - Operating system: Windows NT
17:38:31 INFO - 6.1.7601 Service Pack 1
17:38:31 INFO - CPU: x86
17:38:31 INFO - GenuineIntel family 6 model 30 stepping 5
17:38:31 INFO - 8 CPUs
17:38:31 INFO - Crash reason: EXCEPTION_ACCESS_VIOLATION_READ
17:38:31 INFO - Crash address: 0x0
17:38:31 INFO - Thread 69 (crashed)
17:38:31 INFO - 0 xul.dll!nsTArray_Impl<mozilla::dom::cache::StreamList::Entry,nsTArrayInfallibleAllocator>::AppendElements(unsigned int) [nsTArray.h:fc99ddeac1ce : 1369 + 0xa]
17:38:31 INFO - eip = 0x64a416c4 esp = 0x2bbcfc34 ebp = 0x2bbcfc44 ebx = 0x1454e434
17:38:31 INFO - esi = 0x00000001 edi = 0x66db407c eax = 0x00000000 ecx = 0x66db407c
17:38:31 INFO - edx = 0x0db6fc00 efl = 0x00010202
17:38:31 INFO - Found by: given as instruction pointer in context
17:38:31 INFO - 1 xul.dll!mozilla::dom::cache::StreamList::Add(nsID const &,nsIInputStream *) [StreamList.cpp:fc99ddeac1ce : 79 + 0x9]
17:38:31 INFO - eip = 0x64a4124b esp = 0x2bbcfc4c ebp = 0x2bbcfc58
17:38:31 INFO - Found by: call frame info
17:38:31 INFO - 2 xul.dll!mozilla::dom::cache::Manager::CacheMatchAllAction::RunSyncWithDBOnTarget(mozilla::dom::cache::QuotaInfo const &,nsIFile *,mozIStorageConnection *) [Manager.cpp:fc99ddeac1ce : 589 + 0x25]
17:38:31 INFO - eip = 0x64a4702a esp = 0x2bbcfc60 ebp = 0x2bbcfc80
17:38:31 INFO - Found by: call frame info
17:38:31 INFO - 3 xul.dll!mozilla::dom::cache::SyncDBAction::RunWithDBOnTarget(mozilla::dom::cache::Action::Resolver *,mozilla::dom::cache::QuotaInfo const &,nsIFile *,mozIStorageConnection *) [DBAction.cpp:fc99ddeac1ce : 194 + 0xf]
17:38:31 INFO - eip = 0x64a3d033 esp = 0x2bbcfc88 ebp = 0x2bbcfc9c
17:38:31 INFO - Found by: call frame info
17:38:31 INFO - 4 xul.dll!mozilla::dom::cache::DBAction::RunOnTarget(mozilla::dom::cache::Action::Resolver *,mozilla::dom::cache::QuotaInfo const &) [DBAction.cpp:fc99ddeac1ce : 69 + 0xe]
17:38:31 INFO - eip = 0x64a3cf83 esp = 0x2bbcfca4 ebp = 0x2bbcfcdc
17:38:31 INFO - Found by: call frame info
17:38:31 INFO - 5 xul.dll!mozilla::dom::cache::Context::ActionRunnable::Run() [Context.cpp:fc99ddeac1ce : 461 + 0x1c]
17:38:31 INFO - eip = 0x64a3c984 esp = 0x2bbcfce4 ebp = 0x2bbcfcf4
17:38:31 INFO - Found by: call frame info
17:38:31 INFO - 6 xul.dll!nsThread::ProcessNextEvent(bool,bool *) [nsThread.cpp:fc99ddeac1ce : 855 + 0xd]
17:38:31 INFO - eip = 0x63981299 esp = 0x2bbcfcfc ebp = 0x2bbcfdd0
17:38:31 INFO - Found by: call frame info
17:38:31 INFO - 7 xul.dll!NS_ProcessNextEvent(nsIThread *,bool) [nsThreadUtils.cpp:fc99ddeac1ce : 265 + 0xc]
17:38:31 INFO - eip = 0x639aae5e esp = 0x2bbcfdd8 ebp = 0x2bbcfde4
17:38:31 INFO - Found by: call frame info
17:38:31 INFO - 8 xul.dll!mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate *) [MessagePump.cpp:fc99ddeac1ce : 368 + 0x9]
17:38:31 INFO - eip = 0x63bf9ca0 esp = 0x2bbcfdec ebp = 0x2bbcfe10
17:38:31 INFO - Found by: call frame info
17:38:31 INFO - 9 xul.dll!MessageLoop::RunInternal() [message_loop.cc:fc99ddeac1ce : 233 + 0xe]
17:38:31 INFO - eip = 0x63bcc39b esp = 0x2bbcfe18 ebp = 0x2bbcfe30
17:38:31 INFO - Found by: call frame info
17:38:31 INFO - 10 xul.dll!MessageLoop::RunHandler() [message_loop.cc:fc99ddeac1ce : 226 + 0x4]
17:38:31 INFO - eip = 0x63bcc353 esp = 0x2bbcfe38 ebp = 0x2bbcfe64
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
Comment hidden (Legacy TBPL/Treeherder Robot)
I'd like to see if this reproduces after bug 1143223 lands.
See Also: → 1143223
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment 4 is not the same as the original report here.  This is a timeout caused by the ServiceWorker not starting.  It is not a crash.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.