Clearing Fennec history doesn't clear history in search activity

RESOLVED DUPLICATE of bug 1124884

Status

()

Firefox for Android
Search Activity
RESOLVED DUPLICATE of bug 1124884
3 years ago
a year ago

People

(Reporter: callahad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Per https://www.sccs.swarthmore.edu/org/SwatDigitalFreedom/google-search.html and discussion at https://news.ycombinator.com/item?id=9210149

1. User launched search activity and searched for "foo".

2. User cleared all Firefox data.

3. User launched the search activity and noticed that "foo" was still present.

Ancillary to this: the user mistakenly placed the blame on Google, and was unaware of Fennec's search intent, where it came from, what it was, or why it was installed.

Comment 1

3 years ago
I could reproduce that also on Android 4.4.4 with Firefox 36.0.1 
Discussion in german forum: http://www.camp-firefox.de/forum/viewtopic.php?f=20&t=112104
Steps to reproduce in animated gif:  http://mozhelp.dynvpn.de/dateien/forum/ff-36-android-datenschutz-widget.gif

Comment 2

3 years ago
Have you tried with Firefox 37 beta? This sounds like a dupe of bug 1124884, which will ship in Firefox 37.

Updated

3 years ago
Flags: needinfo?(dan.callahan)
(Reporter)

Comment 3

3 years ago
Clearing needinfo; I'm not the original reporter, just cross-posted from the Hacker News thread when it hit the front page.

I'm a jerk and am unwilling to test nuking my history -- I have a *lot* of history that I find useful and don't want to wipe out. And I don't have a second device on hand to test with. :) Sorry!
Flags: needinfo?(dan.callahan)
(Reporter)

Comment 4

3 years ago
That said, this *does* look like a dupe of bug 1124884; apologies for not searching more thoroughly.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124884
You need to log in before you can comment on or make changes to this bug.