[RTL][Contacts] Device does not show the ellipsis of too long string in the correct location.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Contacts
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Sue, Assigned: steveck)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8577939 [details]
contacts_details_view.png

[1.Description]:
[RTL][v2.2 & v3.0][Contacts] Device does not show the ellipsis of too long string in the correct location. It means that the ellipsis is at left side of srting.
See attachment:contacts_details_view.png

[2.Testing Steps]: 
1. Set system language as Arabic.
2. Create a contact with a long phone number, long company name and long street name in LTR language.
3. Tap the contact to check details.

[3.Expected Result]: 
3. The ellipsis should be at right side of the phone number, company, street.

[4.Actual Result]: 
3. The ellipsis is at left side of phone number, company, street.

[5.Reproduction build]: 
Flame 2.2 build: affected
Build ID               20150315162500
Gaia Revision          a6b2d3f8478ec250beb49950fecbb8a16465ff6f
Gaia Date              2015-03-15 14:33:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/18619f8f6c5c
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150315.195030
Firmware Date          Sun Mar 15 19:50:42 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: affected
Build ID               20150315160203
Gaia Revision          d4177902b04b8fedcb7df9a30ae6e9677e03d2d4
Gaia Date              2015-03-13 15:58:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/af68c9c0e903
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150315.192711
Firmware Date          Sun Mar 15 19:27:22 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
I think this would be covered under bug 1143594, duping.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1143594
(Reporter)

Comment 2

3 years ago
Created attachment 8584252 [details]
contacts_details.png

Hi Dylan,
Bug 1143594 had been verified successfully on Flame 2.2/3.0, but this bug 1143599 is not fixed, I have uploaded the screenshot, could you help with it? Thanks!
See attachment:contacts_details.png
Rate:5/5

Device: Flame 2.2 (affected)
Build ID               20150326002504
Gaia Revision          e59ac067a1d22b7a72cbebc892ec652723f2a557
Gaia Date              2015-03-26 00:02:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/04b4b9d1faae
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.042521
Firmware Date          Thu Mar 26 04:25:30 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150326160206
Gaia Revision          525c341254e08f07f90da57a4d1cd5971a3cc668
Gaia Date              2015-03-26 16:34:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/59554288b4eb
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.193247
Firmware Date          Thu Mar 26 19:32:58 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(doliver)
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Status: RESOLVED → REOPENED
blocking-b2g: --- → 2.2?
Flags: needinfo?(doliver)
Priority: -- → P2
Resolution: DUPLICATE → ---
Reopening and nominating since bug 1143594 did not cover this case.
triage: major issue on RTL
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

3 years ago
Assignee: nobody → schung
Created attachment 8586583 [details] [review]
[gaia] steveck-chung:contact-rtl-fix > mozilla-b2g:master
(Assignee)

Comment 6

3 years ago
Comment on attachment 8586583 [details] [review]
[gaia] steveck-chung:contact-rtl-fix > mozilla-b2g:master

Hey Francisco, this patch applied 2 different solution for ellipsis issue since I think it's better to keep the original dom structure to org title and address field  instead of adding more bdi element. The number field case is different but we can reuse the existing block bdi element workaround.
Attachment #8586583 - Flags: review?(francisco)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15396/
Flags: in-moztrap+
(Assignee)

Comment 8

3 years ago
Hi Jose, could you please help review this patch?
Flags: needinfo?(jmcf)

Comment 9

3 years ago
(In reply to Steve Chung [:steveck](OOO until 4/6) from comment #8)
> Hi Jose, could you please help review this patch?

Oh, sorry I can't. Please see my announcement on FxOS Contacts mailing list.

thanks!
Flags: needinfo?(jmcf)
(Assignee)

Comment 10

3 years ago
(In reply to Jose Manuel Cantera from comment #9)
> (In reply to Steve Chung [:steveck](OOO until 4/6) from comment #8)
> > Hi Jose, could you please help review this patch?
> 
> Oh, sorry I can't. Please see my announcement on FxOS Contacts mailing list.
> 
> thanks!

It's fine, thanks for all the contribution in this project :)

Comment 11

3 years ago
Hi Francisco, could you help to review this with higher priority since this is a 2.2 blocker? thank you!
Flags: needinfo?(francisco)
Comment on attachment 8586583 [details] [review]
[gaia] steveck-chung:contact-rtl-fix > mozilla-b2g:master

LGTM, thanks Steve!
Flags: needinfo?(francisco)
Attachment #8586583 - Flags: review?(francisco) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/bd768b0a8af4998405357fbba7502a2846657ee0
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Comment on attachment 8586583 [details] [review]
[gaia] steveck-chung:contact-rtl-fix > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
RTL issue
[User impact] if declined:
Bad user experience
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
Low
[String changes made]:
Attachment #8586583 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8586583 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/ddfc0e32ec2dd1ef4818cc2c27099e82ab1e566f
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S10 (17apr)
(Reporter)

Comment 16

3 years ago
Created attachment 8590588 [details]
correct_details_view.png

This issue has been verified successfully on latest build of Flame 3.0 with the same steps in comment 0. The ellipsis is shown at right side of long phone number, long company name and long street name.
See attachment:correct_details_view.png
Rate:0/5

Device: Flame 3.0 (pass)
Build ID               20150409160204
Gaia Revision          eaf69e651e19b98c096f8e63b9829fb31df50927
Gaia Date              2015-04-09 12:43:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd32e3ff3717
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.193255
Firmware Date          Thu Apr  9 19:33:06 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

3 years ago
status-b2g-master: fixed → verified
(Reporter)

Comment 17

3 years ago
Created attachment 8591440 [details]
v2.2_contacts_details.png

This issue has been verified successfully on latest build of Flame 2.2 with the same steps in comment 0. The ellipsis is shown at right side of long phone number, long company name and long street name.
See attachment:v2.2_contacts_details.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150412002502
Gaia Revision          cec00d643f517ffd96cde559cd3bbd43ab85816c
Gaia Date              2015-04-10 21:41:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5005522fd68e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.040730
Firmware Date          Sun Apr 12 04:07:41 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.