Closed Bug 1143708 Opened 8 years ago Closed 8 years ago

Page should not be loaded in Reader Mode after the pref was disabled

Categories

(Toolkit :: Reader Mode, defect)

39 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: cornel_ionce, Unassigned)

Details

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Mozilla/5.0 (X11; Linux i686; rv:39.0) Gecko/20100101 Firefox/39.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:39.0) Gecko/20100101 Firefox/39.0

Steps to reproduce:
1. Open Nightly;
2. Go to about:preferences and disable e10s (un-tick the "Enable E10S" option from the General Tab.)
2. Go to a page and enable Reader Mode (eg. https://www.mozilla.org/en-US/mission/);
3. Open a newtab and go to about:config;
4. Search for reader.parse-on-load.enabled and switch the pref to false (disable Reader Mode);
5. Switch back to the previous page and restart the browser.

Expected Results:
The page is normally loaded and the Reader Mode icon is no longer displayed.

Actual Results:
The page is still displayed in Reader Mode (even if the feature was disabled).

Notes:
This issue reproduces on latest Nightly, build ID: 20150316030202.
It affects Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.9.5.
Flipping "reader.parse-on-load.enabled" only disables the parse-on-load functionality, not about:reader.

There is currently no way to disable loading about:reader if the user chooses to load a URL with it.

As this is not intended to be a user-facing pref, we shouldn't need to worry about session restore for users, so I'm going to close this.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.