test_delete_call_log::test_delete_call_log() failed with AssertionError: 'Edit' != u''

RESOLVED FIXED

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: onelson, Assigned: martijn.martijn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

4 years ago
First failure in 8 runs:
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/89/testReport/junit/%28root%29/test_delete_call_log_py%20TestDeleteCallLog_test_delete_call_log/test_delete_call_log_py_TestDeleteCallLog_test_delete_call_log/

Jenkins Adhoc Repro: 1/10
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/722/HTML_Report/


Device firmware (base) 	L1TC100118D0
Device firmware (date) 	16 Mar 2015 01:38:26
Device firmware (incremental) 	eng.cltbld.20150316.043815
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	14 Mar 2015 11:50:17
Gaia revision 	4868c56c0a3b
Gecko build 	20150316010202
Gecko revision 	436686833af0
Gecko version 	39.0a1


Traceback (most recent call last):
  File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/.env/local/lib/python2.7/site-packages/marionette_client-0.9-py2.7.egg/marionette/marionette_test.py", line 290, in run
    testMethod()
  File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_delete_call_log.py", line 31, in test_delete_call_log
    self.assertEqual('Edit', call_log.header_text)

AssertionError: 'Edit' != u''


Could not reproduce manually.
Reporter

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Flags: needinfo?(gmealer)
Assignee

Comment 1

4 years ago
This is worksforme, locally, using:
Gaia-Rev        4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/436686833af0
Build-ID        20150316010202
Version         39.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150204.192122
FW-Date         Wed Feb  4 19:21:34 EST 2015
Bootloader      L1TC100118D0


Can you still reproduce in today's build, Oliver?
Flags: needinfo?(onelson)
Reporter

Comment 2

4 years ago
Locally run automation also saw 1/10 repro on the failure for myself:

Device firmware (base) 	L1TC100118D0
Device firmware (date) 	16 Mar 2015 01:38:26
Device firmware (incremental) 	eng.cltbld.20150316.043815
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	14 Mar 2015 11:50:17
Gaia revision 	4868c56c0a3b
Gecko build 	20150316010202
Gecko revision 	436686833af0
Gecko version 	39.0a1

Attached the HTML report from my findings.
Flags: needinfo?(onelson)
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Oliver, what info do you need from me?
Flags: needinfo?(onelson)
Assignee

Comment 4

4 years ago
Ok, the screenshot makes it look like the tap_edit_button() wasn't made. 
http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/apps/phone/regions/call_log.py#51
I might be able to fix that. The problem is that I can't reproduce this.
Assignee: nobody → martijn.martijn
Assignee

Comment 6

4 years ago
Comment on attachment 8578725 [details] [review]
[gaia] mwargers:test_delete_call_log > mozilla-b2g:master

Make sure the edit button is displayed before tapping on it.
Attachment #8578725 - Flags: review?(jlorenzo)
Attachment #8578725 - Flags: review?(jdorlus)
Assignee

Comment 7

4 years ago
This might fix the intermittent failure.
Oliver, perhaps you can test the pull request locally? (since you seem able to reproduce)

If this doesn't fix it, we might need to add a time.sleep(0.5), because the edit button is then not activated (but it is displayed) when this failure occurs. We had that situation more often with these kinds of dialogs.
Adding qawanted to check if this patch fixes the issue.
Keywords: qawanted
Using the attached gaia patch I was able to run the test_delete_call_log automated test 30 times with zero failures.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150317034728
Gaia: a1e86af1330ab46892848b238b77faa9bc05b4a0
Gecko: 008b3f65a7e0
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [QAnalyst-Triage+][fxosqa-auto-backlog?] → [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(onelson) → needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(ktucker)
Oliver, no need to mark me needinfo on test failure bugs, only on infrastructure bugs where you suspect a phone needs to be looked at or reset.
Flags: needinfo?(gmealer)
Something went wrong with the previous job: Here's another one: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/736/console
Comment on attachment 8578725 [details] [review]
[gaia] mwargers:test_delete_call_log > mozilla-b2g:master

Adhoc job is green after 51 tries and I don't see anything blocking in your code. r+ !
Attachment #8578725 - Flags: review?(jlorenzo) → review+
Attachment #8578725 - Flags: review?(jdorlus) → review+
This looks good to me.
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.