Closed Bug 1143734 Opened 7 years ago Closed 7 years ago

[Bluetooth] Notification Tray does not have a notification for current or completed file transfers.

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 unaffected, b2g-master affected)

RESOLVED DUPLICATE of bug 1143563
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: Marty, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files)

Description:
When sending a file, there is no longer a notification in the tray to indicate that a file is actively transferring, or has completed transferring.  The file recipient gets a transfer request, but is not informed when the file has finished transferring.

Note: The file does still transfer properly.

Repro Steps:
1) Update a Flame to 20150316010202
2) Open the Settings app and turn on Bluetooth
3) Pair the DUT with another phone or a laptop
4) Initiate a file transfer to the DUT
5) Accept the Transfer Request, then open the Notification Tray

Actual:
There is no progress indicator in the Notification Tray, and no notification when the file transfer is complete.

Expected:
The user sees a progress indicator in the Notification Tray, and receives a notification when the transfer is complete.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150316010202
Gaia: 4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gecko: 436686833af0
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
Link to failed test case: https://moztrap.mozilla.org/manage/case/6071/
See attached: logcat, video (URL)
[Blocking Requested - why for this release]:
Functional regression for a core feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Contact: jmercado
This issue does NOT occur on Flame 2.2
Device receives transfer progress and transfer complete notifications.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150316002502
Gaia: a6b2d3f8478ec250beb49950fecbb8a16465ff6f
Gecko: 18619f8f6c5c
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Bug 1141442 may have caused this issue.

Central Regression Window:

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150313125318
Gaia: 1b2f0a20ff4ada05b7d1f84a393bf15bda0e8406
Gecko: 977add19414a
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150313131121
Gaia: d4177902b04b8fedcb7df9a30ae6e9677e03d2d4
Gecko: 38154607d807
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 1b2f0a20ff4ada05b7d1f84a393bf15bda0e8406
Gecko: 38154607d807

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: d4177902b04b8fedcb7df9a30ae6e9677e03d2d4
Gecko: 977add19414a

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/1b2f0a20ff4ada05b7d1f84a393bf15bda0e8406...d4177902b04b8fedcb7df9a30ae6e9677e03d2d4
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Flags: needinfo?(ktucker)
Fred, can we please get the landing for bug 1141442 backed out? Looks like this might be the cause here.
Blocks: 1141442
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(gasolin)
Attached file PR to revert
Tested the PR.  Bluetooth notifications occur after the backout; also testing the unit tests to verify that the unit tests still all pass.
Sorry it's my bad. The issue should be resolved in a same day following patch.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(gasolin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1143563
Looks like the PR from Fred didn't make it to the nightly.  Will need to test.
Comment on attachment 8578165 [details] [review]
PR to revert

Based on Fred's comment, removing review.
Attachment #8578165 - Flags: review?(fabrice) → review-
Flags: needinfo?(pbylenga)
This issue does not reproduce using the latest gaia.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150315193621
Gaia: a1e2f2bdcafc814afdcba0c2258ca69f65b2a869
Gecko: 436686833af0
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
Set component to Gaia:System.
Component: Bluetooth → Gaia::System
blocking-b2g: 2.5? → 2.5+
Duplicate of another smoketest blocker.
blocking-b2g: 2.5+ → ---
Keywords: smoketest
You need to log in before you can comment on or make changes to this bug.