Rooms list appears empty when panel first opens

RESOLVED DUPLICATE of bug 1194622

Status

Hello (Loop)
Client
RESOLVED DUPLICATE of bug 1194622
3 years ago
3 years ago

People

(Reporter: abr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
When the Loop panel opens for the first time (e.g., upon browser restart), the list of rooms renders as if the user has no rooms. This persists until the server responds, which can take as little as 100ms (nearly imperceptible) to more than a second (user panic: "where did my rooms go?"). There is concern that this issue will get worse when Bug 1141105 lands.

Per an IRC discussion with Sevaan, we should add a spinner to the panel where the rooms are typically listed until the server responds with an initial room list.
(Reporter)

Comment 1

3 years ago
Tagging Sevaan to add a visual asset (spinner).
Flags: needinfo?(sfranks)
Mmaslaney, shorlander, what spinner should we use here?
Flags: needinfo?(shorlander)
Flags: needinfo?(sfranks)
Flags: needinfo?(mmaslaney)
(Reporter)

Comment 3

3 years ago
FWIW, we appear to use this as part of the marketplace app:

https://raw.githubusercontent.com/mozilla/spartacus/master/public/images/throbber-53.gif
This is being fixed in bug 1194622
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(shorlander)
Flags: needinfo?(mmaslaney)
Resolution: --- → DUPLICATE
Duplicate of bug: 1194622
You need to log in before you can comment on or make changes to this bug.