SHB: The Emergency Callback mode exit prompt dialog doesn't fit on the screen

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: anshulj, Assigned: sfoster)

Tracking

({verifyme})

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 808788][systemsfe])

Attachments

(3 attachments)

Reporter

Description

4 years ago
The buttons at the bottom of the screen are clipped. Please see the attached snapshot.
Reporter

Comment 1

4 years ago
Summary: The Emergency Callback mode exit prompt dialog doesn't fit on the screen → SHB: The Emergency Callback mode exit prompt dialog doesn't fit on the screen
How do you get to this screen?
Whiteboard: [systemsfe]
Component: Gaia → Gaia::System
blocking-b2g: 2.2? → 2.2+
Reporter

Comment 3

4 years ago
(In reply to Gregor Wagner [:gwagner] from comment #2)
> How do you get to this screen?

You need to dial emergency call on a network that supports emergency callback mode such as Verizon or simulate this in a test environment.
(In reply to Anshul from comment #3)
> (In reply to Gregor Wagner [:gwagner] from comment #2)
> > How do you get to this screen?
> 
> You need to dial emergency call on a network that supports emergency
> callback mode such as Verizon or simulate this in a test environment.

does QA have a test that triggers this dialog?
Flags: needinfo?(nhirata.bugzilla)
We have at least 11 manual tests in regards to getting into ECM:
https://moztrap.mozilla.org/manage/case/9453/
Having said that, I think our Taipei testers run these tests.

I don't see any gip tests, gij tests, nor unit tests for this area.  Maybe I might have missed something...
Flags: needinfo?(nhirata.bugzilla)
Assignee

Comment 6

4 years ago
I'll take a look at this. I'm not clear yet on how to get to this screen though. The MozTrap scripts seem to indicate I actually have to call emergency services and hang up on them - I don't think they are going to like that and at least in some regions will send someone to my address to investigate in case there is a problem I was trying to communicate (my son did this once when he was 2 - first we knew was police knocking on the door)

Meantime I'll look to see if I can mock some stuff in an integration test
Assignee: nobody → sfoster
Flags: needinfo?(nhirata.bugzilla)
Whiteboard: [systemsfe] → [CR 808788][systemsfe]
Whiteboard: [CR 808788][systemsfe] → [caf priority: p2][CR 808788][systemsfe]
There might be some procedure in regards to contacting the services to let them know you're doing a test.  You may want to see if there's something like that in your area.

From John Hammink : 
"You have to find out who handles 911 calls locally, and you can reach out to them, stating that you have a phone system on which you want to test emergency services.  

Took a bit of digging but in our case, it's these people:  http://www.mountainview.gov/safety/911.asp. 

When I call 911 for testing, i always do the following things:

1. Dial 911
2. Announce that it is not an emergency and that you are testing 911 services from a new phone system.
3. Have the 911 operator verify the phone number you are calling from to make sure they are seeing the correct CID info, and in our case, cell tower.  

The operator was very helpful and shared the information she saw on her screen."

Following his email, I found that there is a website for at least for the US : http://www.911.gov/State911Sites.html
Flags: needinfo?(nhirata.bugzilla)
Also you may want to look at mocking w/ unit tests?
Assignee

Comment 9

4 years ago
There is some basic unit testing for the emergency callback manager at: apps/system/test/unit/emergency_callback_icon_test.js, and a mock at apps/system/test/unit/mock_emergency_callback_manager.js

For the purposes of testing this, it looks like I just need to dispatch a "emergencycbmodechange" event with { active: true|false, timeoutMs: Nms } from window.navigator.mozMobileConnections[0].
It might also be helpful to note that the soft home button is enabled (which visible in the screenshot so forgive me if I'm stating the obvious).  Other Gaia popup dialogs do seem to respect this area though.

One way to turn this on:
$ adb shell setprop ro.moz.has_home_button 0
(In reply to Michael Vines [:m1] [:evilmachines] from comment #10)
> It might also be helpful to note that the soft home button is enabled (which
> visible in the screenshot so forgive me if I'm stating the obvious).  Other
> Gaia popup dialogs do seem to respect this area though.

Yeah I was able to reproduce this with the soft home button enabled. Working on a patch + test.
To manually test this patch, I'm enabling SHB in Settings > Developer. Then, in WebIDE I'm typing in the console: 

var evt = new CustomEvent('emergencycbmodechange')
evt.active = true;
evt.timeoutMs = 1000;
window.navigator.mozMobileConnections[0].dispatchEvent(evt);

That gives you the notification, which you can click to get the dialog in question.
Comment on attachment 8579705 [details] [review]
[gaia] sfoster:shb-emergency-callback-dialog-bug-1143788 > mozilla-b2g:master

Still trying to get a gaia-try run for this, with all the tree closures i've not had any luck yet. But maybe you can look it over in the meantime?
Attachment #8579705 - Flags: review?(kgrandon)
Comment on attachment 8579705 [details] [review]
[gaia] sfoster:shb-emergency-callback-dialog-bug-1143788 > mozilla-b2g:master

Looks good to me. Thanks for adding the test.
Attachment #8579705 - Flags: review?(kgrandon) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#QNnckDGPRfWWILWnA6-Bpg

The pull request failed to pass integration tests. It could not be landed, please try again.
(In reply to Autolander from comment #16)
> http://docs.taskcluster.net/tools/task-graph-inspector/#QNnckDGPRfWWILWnA6-
> Bpg
> 
> The pull request failed to pass integration tests. It could not be landed,
> please try again.

This seems like a taskcluster problem. I'm currently chatting with folks in #taskcluster about this.
I've updated autolander after some problems with the Gij test suite. Going to use your bug as a guinea pig if you don't mind.
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Could you please uplift to v2.2? Thanks. ;)
Keywords: verifyme
Comment on attachment 8579705 [details] [review]
[gaia] sfoster:shb-emergency-callback-dialog-bug-1143788 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #8579705 - Flags: approval-gaia-v2.2?
Comment on attachment 8579705 [details] [review]
[gaia] sfoster:shb-emergency-callback-dialog-bug-1143788 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Software Home Button 
[User impact] if declined: The Ok/Cancel buttons on the Emergency Callback Dialog are obscured and difficult to read/click when using the software home button
[Testing completed]: New integration test, tested on device
[Risk to taking this patch] (and alternatives if risky): Low risk, CSS-only patch for just this dialog
[String changes made]: None
Attachment #8579705 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Target Milestone: --- → 2.2 S8 (20mar)
Comment on attachment 8581870 [details] [review]
[gaia] sfoster:v2-2-shb-emergency-callback-dialog-bug-1143788 > mozilla-b2g:v2.2

My bad, sometime since we branched, the system test boilerplate changed and I was missing the ftu and lockscreen settings. 

Waiting for some Gaia-Try results before landing
Flags: needinfo?(sfoster)
Attachment #8581870 - Flags: review?(kgrandon)
Comment on attachment 8581870 [details] [review]
[gaia] sfoster:v2-2-shb-emergency-callback-dialog-bug-1143788 > mozilla-b2g:v2.2

Thanks for the quick fix.
Attachment #8581870 - Flags: review?(kgrandon) → review+
Norry, could you help verify this bug?
Flags: needinfo?(fan.luo)
It seems we cannot use flame to verify this bug which is CDMA only.
Anshul, could you please help verify it has been fixed?
Flags: needinfo?(anshulj)
Flags: needinfo?(fan.luo)
Reporter

Comment 31

4 years ago
The issue is resolved.
Flags: needinfo?(anshulj)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.