Flame: Video title text truncates even when it is not necessary

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: njpark, Assigned: yzen)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: fbimage)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
STR:
- Load the 3gp video file into the phone, with the name 'VID_IC_0001.3gp'
- Open Video app and find the file in the list

Expected:
- Title should show "VID IC 0001"
Actual:
- Title shows "VID IC 000..."

This change seem to happened earlier last week.

Version Info:
Gaia-Rev        4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/436686833af0
Build-ID        20150316010202
Version         39.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150316.043815
FW-Date         Mon Mar 16 04:38:26 EDT 2015
Bootloader      L1TC000118D0
(Reporter)

Comment 1

4 years ago
Posted image current_image
(Reporter)

Comment 2

4 years ago
(Reporter)

Comment 3

4 years ago
Video file is located at:

https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/resources/VID_IC_0001.3gp
Summary: Flame: Video title text truncate even when it is not necessary → Flame: Video title text truncates even when it is not necessary
Whiteboard: fbimage
(Reporter)

Updated

4 years ago
Simply placing the file on the phone did not reproduce this issue. I had to turn on USB storage and unplug/replug the phone a few times and then the truncation issue was observed.

Doing a branch check.
This issue occurs on the Flame 3.0 and 2.2

The video file name appears truncated.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150316010202
Gaia: 4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gecko: 436686833af0
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150317002504
Gaia: d0e09d5e6367e558824f9cbf691da99cedf63037
Gecko: 793d61bb0bd4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

--------------------------------------------

This issue does not occur on the Flame 2.1

No file names appeared truncated.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150317001200
Gaia: e53469fe3a5e563a9146d0fb028e544a423b7e96
Gecko: 32d1cae787e0
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

This is how I reproduced the issue.

STR:

1. Plug in the phone into the computer and place the attached video on the SD card of the phone.
2. Flash the phone and proceed through the FTU with the phone still plugged in.
3. Enable the developer menu and turn on ADB and DevTools.
4. Turn on USB storage.
5. Open the video app and when prompted to "Unplug the phone to watch videos", unplug the phone and observe the video file name while the files are being loaded.

Actual:
The video file name appears truncated.

Expected:
The video file name is not truncated.

-------------------------------------

Getting the regression window now.
QA Contact: ktucker
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame 3.0(Shallow Flash)(KK)(319mb)
BuildID: 20150309141353
Gaia: 6212252fc1541557d94bb34940c445153c93a762
Gecko: 05954cbb0b46
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame 3.0(Shallow Flash)(KK)(319mb)
BuildID: 20150309153354
Gaia: 2d3efff1544e49f05521495cebc3b8bcc0066380
Gecko: a75d14a0de35
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: 6212252fc1541557d94bb34940c445153c93a762
Gecko: a75d14a0de35

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: 2d3efff1544e49f05521495cebc3b8bcc0066380
Gecko: 05954cbb0b46

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/6212252fc1541557d94bb34940c445153c93a762...2d3efff1544e49f05521495cebc3b8bcc0066380

Caused by Bug 1132191
Yura, can you take a look at this please? This looks to be caused the work done on Bug 1132191.
Blocks: 1132191
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(yzenevich)
(Assignee)

Comment 8

4 years ago
The issue is because overflow ... text calculation depends on the title being not display: block; which it is after bug 1132191
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Flags: needinfo?(yzenevich)
(Assignee)

Comment 10

4 years ago
Comment on attachment 8580712 [details] [review]
[gaia] yzen:bug-1143862 > mozilla-b2g:master

There's also a fix for visibility of the app when in delete confirm dialog.
Attachment #8580712 - Flags: review?(rnicoletti)
Comment on attachment 8580712 [details] [review]
[gaia] yzen:bug-1143862 > mozilla-b2g:master

Yura,

I am giving r- for two reasons. 1) I don't want to address two different issues with a single PR. It complicates the review and having a single commit address two issues makes it impossible to cherry-pick the fix for one of the issues and not the other. Please create a separate bug for the "delete confirm dialog" issue you described and create two separate PRs; one for this bug and one for the "delete confirm dialog" bug. 2) I cannot reproduce the issue. Were you able to reproduce?

No-Jun and KTucker, I'm not able to reproduce this issue. I've tried enabling USB storage and following the STR in comment 4 and comment 5 but the title is not being truncated. 

How many videos do you have on the device? Are you both having to enable USB storage before reproducing?

I'm using the latest from master as of today (3/20).

Also, I’d like to be more sure of the regression window before implicating bug 1132191. 

There are 193 commits in between 4868c56c0a3b7a1e51d55b24457e44a7709ea1ae (the build indicated in comment 5 where the issue reproduces) and 2d3efff1544e49f05521495cebc3b8bcc0066380, the commit where bug 1132191 landed in master.

Similarly, in the 2.2 branch, there are 57 commits between d0e09d5e6367e558824f9cbf691da99cedf63037 (the build indicated in comment 5 where the issue reproduces) and the commit that landed in v2.2 for bug 1132191 (2ae86d204d68872b31492d5084c37ba2f0606dc0).
Flags: needinfo?(npark)
Flags: needinfo?(ktucker)
Attachment #8580712 - Flags: review?(rnicoletti) → review-
(Assignee)

Comment 12

4 years ago
(In reply to Russ Nicoletti [:russn] from comment #11)
> Comment on attachment 8580712 [details] [review]
> [gaia] yzen:bug-1143862 > mozilla-b2g:master
> 
> Yura,
> 
> I am giving r- for two reasons. 1) I don't want to address two different
> issues with a single PR. It complicates the review and having a single
> commit address two issues makes it impossible to cherry-pick the fix for one
> of the issues and not the other. Please create a separate bug for the
> "delete confirm dialog" issue you described and create two separate PRs; one
> for this bug and one for the "delete confirm dialog" bug. 

Sounds good I'll make another PR with a new bug.

> 2) I cannot
> reproduce the issue. Were you able to reproduce?

Yes. I managed to reproduce it with these instructions:
1. Plug in the phone into the computer and place the attached video on the SD card of the phone.
2. Turn on USB storage.
3. Open the video app and when prompted to "Unplug the phone to watch videos", unplug the phone and observe the video file name while the files are being loaded.

> 
> No-Jun and KTucker, I'm not able to reproduce this issue. I've tried
> enabling USB storage and following the STR in comment 4 and comment 5 but
> the title is not being truncated. 
> 
> How many videos do you have on the device? Are you both having to enable USB
> storage before reproducing?

I had to yes. One is enough, but it would show up with more than that for me.

> 
> I'm using the latest from master as of today (3/20).
> 
> Also, I’d like to be more sure of the regression window before implicating
> bug 1132191. 

I think it is indeed caused by the bug. Because of the following:
When title text is being updated https://github.com/mozilla-b2g/gaia/blob/master/apps/video/js/video_utils.js#L100 is called. It assumes that the title is in the DOM, where with my original PR, it's in the display: none; subtree and hence has all its geometrical properties at 0.

> 
> There are 193 commits in between 4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
> (the build indicated in comment 5 where the issue reproduces) and
> 2d3efff1544e49f05521495cebc3b8bcc0066380, the commit where bug 1132191
> landed in master.
> 
> Similarly, in the 2.2 branch, there are 57 commits between
> d0e09d5e6367e558824f9cbf691da99cedf63037 (the build indicated in comment 5
> where the issue reproduces) and the commit that landed in v2.2 for bug
> 1132191 (2ae86d204d68872b31492d5084c37ba2f0606dc0).
(Assignee)

Comment 13

4 years ago
Comment on attachment 8580712 [details] [review]
[gaia] yzen:bug-1143862 > mozilla-b2g:master

Updated to remove changes that belong to bug 1145746.
Attachment #8580712 - Flags: review- → review?(rnicoletti)
(Reporter)

Comment 14

4 years ago
(In reply to Russ Nicoletti [:russn] from comment #11)
> Comment on attachment 8580712 [details] [review]
> [gaia] yzen:bug-1143862 > mozilla-b2g:master
> 
> Yura,
> 
> No-Jun and KTucker, I'm not able to reproduce this issue. I've tried
> enabling USB storage and following the STR in comment 4 and comment 5 but
> the title is not being truncated. 
> 
> How many videos do you have on the device? Are you both having to enable USB
> storage before reproducing?
> 
> I'm using the latest from master as of today (3/20).
Also confirming Yura's comments that I was able to repro the issue on today's build. Initially it was caught with python marionette test harness where we use adb push to send the file, but when manually enabling usb storage also caused the issue as well.  I had cases where it reproed with only a single video file in the device, as well as having multiple files.

And since the bisection shows that it's a gaia issue, the gaia pushlog shows only two commits here: https://github.com/mozilla-b2g/gaia/compare/6212252fc1541557d94bb34940c445153c93a762...2d3efff1544e49f05521495cebc3b8bcc0066380 unless I'm assuming something wrong?
Flags: needinfo?(npark)
No-Jun is correct. This is happening when having only 1 video file as well as several. I personally had 5 video files on my device. 

USB storage should be enabled first before opening the video app.
Flags: needinfo?(ktucker)
Hey Russ, I'm a little confused.  Comment 6 states:
https://github.com/mozilla-b2g/gaia/compare/6212252fc1541557d94bb34940c445153c93a762...2d3efff1544e49f05521495cebc3b8bcc0066380

I think I'm missing something.  I apologize if I'm asking a dumb question; Why are we looking at : 
https://github.com/mozilla-b2g/gaia/compare/4868c56c0a3b7a1e51d55b24457e44a7709ea1ae...2d3efff1544e49f05521495cebc3b8bcc0066380 ?  I don't think they don't even compare...
Flags: needinfo?(rnicoletti)
Noaki, it is I who was confused. I didn't read comment 6 carefully. Thanks for clarifying.
Flags: needinfo?(rnicoletti)
s/Noaki/Naoki --> and I can't type today :)
Comment on attachment 8580712 [details] [review]
[gaia] yzen:bug-1143862 > mozilla-b2g:master

Thanks for clarifying the source of the problem.
Attachment #8580712 - Flags: review?(rnicoletti) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#aKVQ9fdwSTyM7Kr81BeMKA

The pull request failed to pass integration tests. It could not be landed, please try again.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 22

4 years ago
Comment on attachment 8580712 [details] [review]
[gaia] yzen:bug-1143862 > mozilla-b2g:master

[Approval Request Comment] Fixes regression with truncated video title
[Bug caused by] (feature/regressing bug #): bug 1132191
[User impact] if declined: title will remain truncated when not necessary
[Testing completed]: on device
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8580712 - Flags: approval-gaia-v2.2?
blocking-b2g: --- → 2.2+
Attachment #8580712 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame 3.0 and 2.2. Following STR at comment 5, video app does not show file names as truncated. Bug repro rate: 0/10.

Device: Flame 3.0
BuildID: 20150428010206
Gaia: 0636405f0844bf32451a375b2d61a2b16fe33348
Gecko: caf25344f73e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150428002500
Gaia: 9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gecko: e79c19bf19bf
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.