[RTL][Contacts]The contact name in contacts list, details view and edit box is shown inconsistently.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Contacts
P3
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Sue, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8578531 [details]
only_input_first_name.png

[1.Description]:
[RTL][v2.2 & v3.0][Contacts]The contact name shown in details view is inconsistent with that in contacts list and edit box. 
See attachment:only_input_first_name.png

[2.Testing Steps]: 
1. Set system language as Arabic.
2. Launch contacts app.
3. New a contact.
4. Only input the first name with input sequence "English + Arabic".
5. Tap done and observe the contacts in contacts list, and details view.

[3.Expected Result]: 
5.The contact name in contacts list and details view should be consistent.

[4.Actual Result]: 
5. The contact name shown in details view,  contacts list and edit box should is inconsistent.

[5.Reproduction build]: 
Flame 2.2 build: affected
Build ID               20150316162504
Gaia Revision          d0e09d5e6367e558824f9cbf691da99cedf63037
Gaia Date              2015-03-16 17:14:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/793d61bb0bd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.195035
Firmware Date          Mon Mar 16 19:50:48 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: affected
Build ID               20150316160204
Gaia Revision          daf32758b3ba8300d711235e8f0caad0801b6945
Gaia Date              2015-03-17 06:21:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/436686833af0
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.193248
Firmware Date          Mon Mar 16 19:32:58 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
P2 -- nominating since this is basically giving a wrong information to user
blocking-b2g: --- → 2.2?
Priority: -- → P2
(Reporter)

Comment 2

3 years ago
I'm wondering about this issue. Because I can't make sure which is the right way to display contacts name. In my opinion, the name in details view looks like more reasonable. Because I wrote the "Bbb" firstly and then wrote the Arabic character as it shown from right to left.
Anyone can help to confirm it? Thanks!
Flags: needinfo?
Triage: This edge case doesn't seem to be handled in the specs. NI Ahmed and FxOS UX to get the answer.
Flags: needinfo?(nefzaoui)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?

Comment 4

3 years ago
Ahmed is no longer working on this release. The specs cover the display of Arabic and LTR text together, but I don't understand the combination seen here. Which keyboard is being used? I have no idea what the input sequence "English + Arabic" is. What's the purpose of that for the user? Please advise.
Flags: needinfo?(nefzaoui)
Comms triage: Mixing latin and arabic characters in the same word sounds like a really boundary case. Clearing the nomination and the priority to make this bug triaged again by the RTL team.
blocking-b2g: 2.2? → ---
Priority: P2 → --
Triage: P3 as per comment 4 and 5
Priority: -- → P3

Comment 7

3 years ago
Clearing the ni? for me for now since triage has this. I still don't quite understand how this is happening, but thanks for bumping to triage. :)
Flags: needinfo?(firefoxos-ux-bugzilla)
(Reporter)

Comment 8

3 years ago
(In reply to Stephany Wilkes from comment #4)
> Which keyboard is being used? I have no idea what the input sequence
> "English + Arabic" is. What's the purpose of that for the user? Please
> advise.
Hi Stephany,
I used the Arabic keyboard here, and the input sequence "English + Arabic" means inputting a name which contains both English and Arabic. Using both English and Arabic, I just want to see whether the UI is correct or not.
(Reporter)

Comment 9

3 years ago
Created attachment 8613844 [details]
verify.png

This issue can not be reproduced on latest build of Flame 2.2/3.0 by STRs in comment 0. If anyone can repro it, reopen again.
Result: The contact name in contacts list and details view are consistent.
See attachment:verify.png
Rate:0/3

Device: Flame 2.2 (unaffected)
Build ID               20150601162503
Gaia Revision          a675e5472944a9d7a16e091ba8a59901e37df9e0
Gaia Date              2015-06-01 13:53:00
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c163c2a5b921
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150601.195121
Firmware Date          Mon Jun  1 19:51:33 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (unaffected)
Build ID               20150601160204
Gaia Revision          6d477a7884273886605049b20f60af5c1583a150
Gaia Date              2015-06-01 16:41:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/56241c1f8a3b
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150601.193935
Firmware Date          Mon Jun  1 19:39:44 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.