Closed Bug 1144052 Opened 5 years ago Closed 5 years ago

[Message] Video attachment in message cannot be played.

Categories

(Firefox OS Graveyard :: Gaia::Video, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S8 (20mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: huayu.li, Assigned: rnicoletti)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached file logcat3.txt
[1.Description]:
[Nexus 5 v2.2&3.0][Flame v2.2][Message] Video attachment in message cannot be played.
Found at:17:19
see attachments:logcat3.txt,video 2.3gp.

[2.Testing Steps]: 
1.Launch message and new a mesage.
2.Tap add attachment and add any video.
3.Tap this video in content box.
4.Send it and tap it in thread.
5.Receive a SMS with video.
6.Try to open this video.


[3.Expected Result]: 
3&4&6.The video should be played normally.

[4.Actual Result]: 
3&4&6. We can't play this video, there is a black page displayed.

[5.Reproduction build]: 

N5-2.2[affected]:
 Build ID               20150316002502
Gaia Revision          a6b2d3f8478ec250beb49950fecbb8a16465ff6f
Gaia Date              2015-03-15 14:33:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/18619f8f6c5c
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150316.042754
Firmware Date          Mon Mar 16 04:28:10 EDT 2015
Bootloader             HHZ12d

N5_3.0[affected]:
Build ID               20150316160204
Gaia Revision          4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gaia Date              2015-03-14 18:50:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/436686833af0
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150316.192850
Firmware Date          Mon Mar 16 19:29:05 EDT 2015
Bootloader             HHZ12d

Flame 2.2[afffected]:
Build ID               20150316162504
Gaia Revision          d0e09d5e6367e558824f9cbf691da99cedf63037
Gaia Date              2015-03-16 17:14:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/793d61bb0bd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.195035
Firmware Date          Mon Mar 16 19:50:48 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
6702
Attached video 2.3gp
I don't know if this is related, I see these errors in the logs:

03-17 17:06:10.094 E/Video   ( 4321): Content JS ERROR: Exception in captureFrame: [Exception... "Component is not available"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: app://video.gaiamobile.org/gaia_build_defer_index.js :: captureFrame :: line 894"  data: no] captureFrame@app://video.gaiamobile.org/gaia_build_defer_index.js:894:111

03-17 17:06:10.094 E/Video   ( 4321): getMetadata/createThumbnail/offscreenVideo.onseeked@app://video.gaiamobile.org/gaia_build_defer_index.js:890:29

03-17 17:06:10.094 E/Video   ( 4321):  

03-17 17:06:10.094 E/Video   ( 4321):     at captureFrame (app://video.gaiamobile.org/gaia_build_defer_index.js:895:9)

03-17 17:06:10.094 E/Video   ( 4321):     at getMetadata/createThumbnail/offscreenVideo.onseeked (app://video.gaiamobile.org/gaia_build_defer_index.js:890:29)

03-17 17:06:40.377 W/Video   ( 4321): [JavaScript Error: "TypeError: dom.timeSlider is undefined" {file: "app://video.gaiamobile.org/js/view.js" line: 179}]

03-17 17:07:31.942 W/Video   ( 4321): [JavaScript Error: "TypeError: Argument 1 of HTMLMediaElement.fastSeek is not a finite floating-point value." {file: "app://video.gaiamobile.org/js/view.js" line: 523}]


So this looks like an issue in the Video app. It could be that we're handing a bad Blob object though, but I'd like a first investigation by the Video team if it's possible.
blocking-b2g: --- → 2.2?
Component: Gaia::SMS → Gaia::Video
QA Contact: pcheng
Flags: needinfo?(rnicoletti)
Flags: needinfo?(dflanagan)
Thanks for finding those error messages Julien.  

Recent accessibility patches added code that references dom.timeSlider in view.js.  dom.timeSlider is defined in video.js, but we never define it in view.js. So it looks like these patches landed without anyone actually testing them! :-(

Russ: can you take this? The fix may be as simple as adding 'timeSlider' to the ids array at view.js:126
Flags: needinfo?(dflanagan)
Removing the regressionwindow-wanted flag. This is a regression caused by bug 1132191, which was uplifted to 2.2 last week.

This is obviously a blocker, but I'd guess that Russ will have a fix ready before a triage meeting can decide to actually set the 2.2+ flag.
Assignee: nobody → rnicoletti
Status: NEW → ASSIGNED
PR created for master.
Flags: needinfo?(rnicoletti)
Attachment #8579018 - Flags: review?(dflanagan)
Btw, I have verified the PR solves the problem in master and in v2.2
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8579018 [details] [review]
[gaia] russnicoletti:bug-1144052 > mozilla-b2g:master

Thanks for the quick patch, Russ. The patch that caused this regression didn't reference any other undefined elements, did it?
Attachment #8579018 - Flags: review?(dflanagan) → review+
(In reply to David Flanagan [:djf] from comment #8)
> Comment on attachment 8579018 [details] [review]
> [gaia] russnicoletti:bug-1144052 > mozilla-b2g:master
> 
> Thanks for the quick patch, Russ. The patch that caused this regression
> didn't reference any other undefined elements, did it?

No, the 'time-slider' was the only element introduced into view.js that was undefined. Also, I did test with my patch and the "view video" functionality works properly.
Master: https://github.com/mozilla-b2g/gaia/commit/c39e15f631de80c69467fda0d4ea0bcda9e194ca
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8579018 [details] [review]
[gaia] russnicoletti:bug-1144052 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):bug 1132191

[User impact] if declined: Unable to play video attachments

[Testing completed]: Unit and manual

[Risk to taking this patch] (and alternatives if risky): low (one liner in code specific to playing video attachments)

[String changes made]: none
Attachment #8579018 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8579018 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
It is a common issue, not Nexus 5 only. However, please verify both flame & nexus 5.
Keywords: verifyme
Summary: [Nexus 5][Message] Video attachment in message cannot be played. → [Message] Video attachment in message cannot be played.
Whiteboard: 2.2-nexus-5-l
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The video plays when viewed in the messages app on both recieved, sent, and in draft messages.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150323010204
Gaia: 9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gecko: e730012260a4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150323002504
Gaia: 7f367fc98ffdd183f21d2cdfe20556ab877ece34
Gecko: 3ea0eaeda353
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This issue is verified fixed on the latest Nexus5 3.0 and 2.2 builds
N5_2.2[Unaffected]:
Build ID               20150323002504
Gaia Revision          7f367fc98ffdd183f21d2cdfe20556ab877ece34
Gaia Date              2015-03-23 05:35:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3ea0eaeda353
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150323.040519
Firmware Date          Mon Mar 23 04:05:35 EDT 2015
Bootloader             HHZ12d

Nexus 5 3.0[Unaffected]:
Build ID               20150323160205
Gaia Revision          8eac260ee81a8aca05770d18c5736536d44ee7a7
Gaia Date              2015-03-23 02:41:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/bc85c479668a
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150323.193411
Firmware Date          Mon Mar 23 19:34:28 EDT 2015
Bootloader             HHZ12d
Duplicate of this bug: 1144579
You need to log in before you can comment on or make changes to this bug.