[RTL][Market Custom Framework]The URL is displayed incorrectly in the view of confirm install app in RTL language.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: tedders1)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[RTL][v2.2&v3.0][Market Custom Framework]The URL is displayed incorrectly in the view of confirm install app in RTL language.
See attachment:URL_error.png

[2.Testing Steps]: 
1.Set your phone language to Arabic.
2.Connect to network and launch Marketplace.
3.Select an app to download.
4.Observe the view of confirm install app view.

[3.Expected Result]: 
4.The URL should read from left to right and the ellipsis should be displayed at right side of the URL.

[4.Actual Result]: 
4.The URL is displayed incorrectly.

[5.Reproduction build]: 
Flame 2.2 build (affected):
Build ID               20150316162504
Gaia Revision          d0e09d5e6367e558824f9cbf691da99cedf63037
Gaia Date              2015-03-16 17:14:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/793d61bb0bd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.195035
Firmware Date          Mon Mar 16 19:50:48 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (affected):
Build ID               20150316160204
Gaia Revision          4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gaia Date              2015-03-14 18:50:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/436686833af0
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.193248
Firmware Date          Mon Mar 16 19:32:58 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Posted image URL_error.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
I think this is a dupe of Bug 1137021.
Please verify that this instance is fixed here once patch in Bug 1137021 lands on 2.2. thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1137021

Comment 3

4 years ago
Posted image fail_URL.png
Hi Josh,
Could you help with it? Thanks!
The patch in Bug 1137021 had landed on 2.2 and master, but this issue still exists on Flame 2.2 and 3.0, the ellipsis is displayed at left side of the URL.
See attachment:fail_URL.png
Rate:3/3

Flame 2.2 build: affected
Build ID               20150322002503
Gaia Revision          44c62060581fde8de1e12e94cf55e9673b401a47
Gaia Date              2015-03-20 19:05:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6140a32902a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.043216
Firmware Date          Sun Mar 22 04:32:27 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: affected
Build ID               20150322160204
Gaia Revision          9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gaia Date              2015-03-22 10:09:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e730012260a4
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.192413
Firmware Date          Sun Mar 22 19:24:22 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(jocheng)

Updated

4 years ago
Status: RESOLVED → REOPENED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Keywords: verifyme
Resolution: DUPLICATE → ---
Hi Delphine,
Could you help to confirm that this issue still exist after bug 1137021 fixed?
Thanks!
Flags: needinfo?(jocheng) → needinfo?(lebedel.delphine)
I confirm this still reproduces. 
Since this is a screen users will see every time they try to download a Marketplace app, assigning as P1 and blocking
blocking-b2g: --- → 2.2?
Flags: needinfo?(lebedel.delphine)
Priority: -- → P1
Ted, can you take a look here?
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(tclancy)
Whiteboard: [systemsfe]
(Assignee)

Comment 7

4 years ago
Okee doke.
Assignee: nobody → tclancy
Flags: needinfo?(tclancy)
(Assignee)

Updated

4 years ago
Attachment #8586408 - Flags: review?(kgrandon)
Comment on attachment 8586408 [details] [review]
[gaia] tedders1:bug-1144056-fix > mozilla-b2g:master

I'm not really a fan of the markup usage here. I left a comment on github. Please address and re-flag me.
Attachment #8586408 - Flags: review?(kgrandon)
(Assignee)

Updated

4 years ago
Attachment #8586408 - Flags: review?(kgrandon)
Comment on attachment 8586408 [details] [review]
[gaia] tedders1:bug-1144056-fix > mozilla-b2g:master

Seems fine to me, thanks!
Attachment #8586408 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

4 years ago
Comment on attachment 8586408 [details] [review]
[gaia] tedders1:bug-1144056-fix > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
system-rtl (Bug 1064539)

[User impact] if declined:
URLs will be truncated on the wrong side.

[Testing completed]:
Green try run.

[Risk to taking this patch] (and alternatives if risky):
None foreseen. It's a visual tweak to a single dialog box.

[String changes made]:
None.
Attachment #8586408 - Flags: approval-gaia-v2.2?
Attachment #8586408 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Reporter)

Comment 13

4 years ago
According to the comment 0, this issue has been verified pass on latest Flame 3.0 build.
See attachment:Verify1_Flame3.0_Pass.png.
Reproducing rate:0/10

Flame 3.0 build (Unaffected):
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0
Target Milestone: --- → 2.2 S9 (3apr)
(Reporter)

Comment 15

4 years ago
According to the comment 0, this issue has been verified pass on latest Flame 2.2 build.
See attachment:Verify2_Flame2.2_Pass.png
Reproducing rate:0/10

Flame 2.2 build:
Build ID               20150408002503
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/43041c78052b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150408.035152
Firmware Date          Wed Apr  8 03:52:04 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.