Closed Bug 1144395 Opened 6 years ago Closed 5 years ago

Some telemetry xpcshell tests crash on Android 4.3 emulator

Categories

(Firefox for Android :: Testing, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1136634

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

(Whiteboard: [test disabled on android 4.3])

Most xpcshell tests run reliably on the Android 4.3 emulator, but a few of the telemetry tests fail, typically by failing.

http://ftp.mozilla.org/pub/mozilla.org/mobile/try-builds/gbrown@mozilla.com-e80c0fdd1ef6/try-android-api-9/try_ubuntu64_vm_mobile_test-xpcshell-2-bm117-tests1-linux64-build26.txt.gz

18:02:13  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | xpcshell return code: 139
18:02:13     INFO -  TEST-INFO took 12489ms
18:02:13     INFO -  >>>>>>>
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | xpcw: cd /sdcard/tests/xpcshell/toolkit/components/telemetry/tests/unit
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | xpcw: xpcshell -r /sdcard/tests/xpcshell/c/httpd.manifest --greomni /data/local/xpcb/fennec-39.0a1.en-US.android-arm.apk -m -s -e const _HTTPD_JS_PATH = "/sdcard/tests/xpcshell/c/httpd.js"; -e const _HEAD_JS_PATH = "/sdcard/tests/xpcshell/head.js"; -e const _TESTING_MODULES_DIR = "/sdcard/tests/xpcshell/m"; -f /sdcard/tests/xpcshell/head.js -e const _SERVER_ADDR = "localhost" -e const _HEAD_FILES = ["/sdcard/tests/xpcshell/toolkit/components/telemetry/tests/unit/head.js"]; -e const _TAIL_FILES = []; -e const _JSDEBUGGER_PORT = 0; -e const _TEST_FILE = ["test_TelemetryEnvironment.js"]; -e const _TEST_NAME = "toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js" -e _execute_test(); quit(0);
18:02:13     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
18:02:13     INFO -  (xpcshell/head.js) | test pending (2)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | JavaScript strict warning: /sdcard/tests/xpcshell/toolkit/components/telemetry/tests/unit/head.js -> file:///storage/sdcard/tests/xpcshell/toolkit/mozapps/extensions/test/xpcshell/head_addons.js, line 1365: SyntaxError: in strict mode code, functions may be declared only at top level or immediately within another function
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121883359	addons.manager	DEBUG	Application has been upgraded
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884264	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/XPIProvider.jsm: ["XPIProvider"]
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884394	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/LightweightThemeManager.jsm: ["LightweightThemeManager"]
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884536	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/GMPProvider.jsm
18:02:13     INFO -  "Mock profileBeforeChange blocker for 'AddonManager: shutting down.'"
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884586	addons.manager	DEBUG	Starting provider: XPIProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884608	addons.xpi	DEBUG	startup
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884660	addons.xpi	DEBUG	checkForChanges
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884697	addons.xpi	DEBUG	Loaded add-on state from prefs: {}
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884727	addons.xpi	DEBUG	getInstallState changed: false, state: {}
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884751	addons.xpi	DEBUG	Empty XPI database, setting schema version preference to 16
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884783	addons.xpi	DEBUG	No changes found
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884829	addons.manager	DEBUG	Registering shutdown blocker for XPIProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884879	addons.manager	DEBUG	Provider finished startup: XPIProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884893	addons.manager	DEBUG	Starting provider: LightweightThemeManager
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884909	addons.manager	DEBUG	Registering shutdown blocker for LightweightThemeManager
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884950	addons.manager	DEBUG	Provider finished startup: LightweightThemeManager
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121884965	addons.manager	DEBUG	Starting provider: GMPProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121885086	addons.manager	DEBUG	Registering shutdown blocker for GMPProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121885118	addons.manager	DEBUG	Provider finished startup: GMPProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121885144	addons.manager	DEBUG	Completed startup sequence
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121885457	addons.xpi-utils	WARN	Synchronous load of XPI database due to getAddonsByType(theme)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121885473	addons.xpi-utils	DEBUG	Opening XPI database /sdcard/tests/xpcshell/p/extensions.json
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121885493	addons.xpi-utils	DEBUG	Rebuilding XPI database with no extensions
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (3)
18:02:13     INFO -  (xpcshell/head.js) | test MAIN run_test finished (3)
18:02:13     INFO -  running event loop
18:02:13     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "SyntaxError: in strict mode code, functions may be declared only at top level or immediately within another function" {file: "/sdcard/tests/xpcshell/toolkit/components/telemetry/tests/unit/head.js -> file:///storage/sdcard/tests/xpcshell/toolkit/mozapps/extensions/test/xpcshell/head_addons.js" line: 1365 column: 11 source: "  function MockWindowsRegKey() {
18:02:13     INFO -  "}]"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121883359	addons.manager	DEBUG	Application has been upgraded"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884264	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/XPIProvider.jsm: ["XPIProvider"]"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884394	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/LightweightThemeManager.jsm: ["LightweightThemeManager"]"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884536	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/GMPProvider.jsm"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884586	addons.manager	DEBUG	Starting provider: XPIProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884608	addons.xpi	DEBUG	startup"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884660	addons.xpi	DEBUG	checkForChanges"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884697	addons.xpi	DEBUG	Loaded add-on state from prefs: {}"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884727	addons.xpi	DEBUG	getInstallState changed: false, state: {}"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884751	addons.xpi	DEBUG	Empty XPI database, setting schema version preference to 16"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884783	addons.xpi	DEBUG	No changes found"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884829	addons.manager	DEBUG	Registering shutdown blocker for XPIProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884879	addons.manager	DEBUG	Provider finished startup: XPIProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884893	addons.manager	DEBUG	Starting provider: LightweightThemeManager"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884909	addons.manager	DEBUG	Registering shutdown blocker for LightweightThemeManager"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884950	addons.manager	DEBUG	Provider finished startup: LightweightThemeManager"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121884965	addons.manager	DEBUG	Starting provider: GMPProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121885086	addons.manager	DEBUG	Registering shutdown blocker for GMPProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121885118	addons.manager	DEBUG	Provider finished startup: GMPProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121885144	addons.manager	DEBUG	Completed startup sequence"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121885457	addons.xpi-utils	WARN	Synchronous load of XPI database due to getAddonsByType(theme)"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121885473	addons.xpi-utils	DEBUG	Opening XPI database /sdcard/tests/xpcshell/p/extensions.json"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121885493	addons.xpi-utils	DEBUG	Rebuilding XPI database with no extensions"
18:02:13     INFO -  toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | Starting asyncSetup
18:02:13     INFO -  (xpcshell/head.js) | test asyncSetup pending (3)
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (3)
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 1 pending (3)
18:02:13     INFO -  (xpcshell/head.js) | test asyncSetup finished (3)
18:02:13     INFO -  toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | Starting test_initAndShutdown
18:02:13     INFO -  (xpcshell/head.js) | test test_initAndShutdown pending (3)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887119	Toolkit.Telemetry	TRACE	TelemetryEnvironment::init
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887126	Toolkit.Telemetry	TRACE	TelemetryEnvironment::_startWatchingPrefs - null
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887204	Toolkit.Telemetry	TRACE	TelemetryEnvironment::shutdown
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887212	Toolkit.Telemetry	TRACE	TelemetryEnvironment::_stopWatchingPrefs
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 1 finished (3)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887275	Toolkit.Telemetry	TRACE	TelemetryEnvironment::init
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887288	Toolkit.Telemetry	TRACE	TelemetryEnvironment::_startWatchingPrefs - null
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887358	Toolkit.Telemetry	TRACE	TelemetryEnvironment::shutdown
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887371	Toolkit.Telemetry	TRACE	TelemetryEnvironment::_stopWatchingPrefs
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887389	Toolkit.Telemetry	TRACE	TelemetryEnvironment::init
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887405	Toolkit.Telemetry	TRACE	TelemetryEnvironment::_startWatchingPrefs - null
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887443	Toolkit.Telemetry	ERROR	TelemetryEnvironment::init - Already initialized
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887458	Toolkit.Telemetry	TRACE	TelemetryEnvironment::getEnvironmentData
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 1426121887471	Toolkit.Telemetry	TRACE	TelemetryEnvironment::getEnvironmentData
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | Segmentation fault
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | 13
18:02:13     INFO -  <<<<<<<
18:02:13     INFO -  mozcrash Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/gbrown@mozilla.com-e80c0fdd1ef6/try-android-api-11/fennec-39.0a1.en-US.android-arm.crashreporter-symbols.zip
18:02:13     INFO -  mozcrash Saved minidump as /builds/slave/test/build/blobber_upload_dir/208feea7-843c-43a0-4e0fb738-64d57c22.dmp
18:02:13     INFO -  mozcrash Saved app info as /builds/slave/test/build/blobber_upload_dir/208feea7-843c-43a0-4e0fb738-64d57c22.extra
18:02:13  WARNING -  PROCESS-CRASH | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | application crashed [@ libc.so + 0x1e524]
18:02:13     INFO -  Crash dump filename: /tmp/tmpFuFI7V/208feea7-843c-43a0-4e0fb738-64d57c22.dmp
18:02:13     INFO -  Operating system: Android
18:02:13     INFO -                    0.0.0 Linux 2.6.29-gea477bb #1 Wed Sep 26 11:04:45 PDT 2012 armv7l generic/sdk/generic:4.3.1/JLS36I/eng.gbrown.20150308.182649:eng/test-keys
18:02:13     INFO -  CPU: arm
18:02:13     INFO -       0 CPUs
18:02:13     INFO -  
18:02:13     INFO -  Crash reason:  SIGSEGV
18:02:13     INFO -  Crash address: 0xdeadbaad
18:02:13     INFO -  
18:02:13     INFO -  Thread 0 (crashed)
18:02:13     INFO -   0  libc.so + 0x1e524
18:02:13     INFO -       r4 = 0x00000000    r5 = 0xbe8f6e3c    r6 = 0x00010080    r7 = 0x00010060
18:02:13     INFO -       r8 = 0x421406dc    r9 = 0x000000af   r10 = 0x42395c70    fp = 0x41f98f48
18:02:13     INFO -       sp = 0xbe8f6e38    lr = 0x40039fcb    pc = 0x40037524
18:02:13     INFO -      Found by: given as instruction pointer in context
18:02:13     INFO -   1  libEGL.so + 0x39a31
18:02:13     INFO -       sp = 0xbe8f6e3c    pc = 0x42124a33
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   2  libcutils.so + 0x87af
18:02:13     INFO -       sp = 0xbe8f6e48    pc = 0x420be7b1
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   3  libEGL.so + 0x39a31
18:02:13     INFO -       sp = 0xbe8f6e58    pc = 0x42124a33
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   4  libc.so + 0x1c4e6
18:02:13     INFO -       sp = 0xbe8f6e60    pc = 0x400354e8
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   5  libcutils.so + 0x8477
18:02:13     INFO -       sp = 0xbe8f6e64    pc = 0x420be479
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   6  libcutils.so + 0x888d
18:02:13     INFO -       sp = 0xbe8f6e68    pc = 0x420be88f
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   7  fennec-39.0a1.en-US.android-arm.apk + 0x20268fe
18:02:13     INFO -       sp = 0xbe8f6ea0    pc = 0x47626900
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   8  linker + 0x646c
18:02:13     INFO -       sp = 0xbe8f6eb8    pc = 0x4000646e
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   9  libmozglue.so!arena_avail_comp [arena.c:e80c0fdd1ef6 : 70 + 0x5]
18:02:13     INFO -       sp = 0xbe8f6ec8    pc = 0x40207451
18:02:13     INFO -      Found by: stack scanning



18:02:13  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | xpcshell return code: 139
18:02:13     INFO -  TEST-INFO took 16007ms
18:02:13     INFO -  >>>>>>>
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | xpcw: cd /sdcard/tests/xpcshell/toolkit/components/telemetry/tests/unit
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | xpcw: xpcshell -r /sdcard/tests/xpcshell/c/httpd.manifest --greomni /data/local/xpcb/fennec-39.0a1.en-US.android-arm.apk -m -s -e const _HTTPD_JS_PATH = "/sdcard/tests/xpcshell/c/httpd.js"; -e const _HEAD_JS_PATH = "/sdcard/tests/xpcshell/head.js"; -e const _TESTING_MODULES_DIR = "/sdcard/tests/xpcshell/m"; -f /sdcard/tests/xpcshell/head.js -e const _SERVER_ADDR = "localhost" -e const _HEAD_FILES = ["/sdcard/tests/xpcshell/toolkit/components/telemetry/tests/unit/head.js"]; -e const _TAIL_FILES = []; -e const _JSDEBUGGER_PORT = 0; -e const _TEST_FILE = ["test_TelemetryPing.js"]; -e const _TEST_NAME = "toolkit/components/telemetry/tests/unit/test_TelemetryPing.js" -e _execute_test(); quit(0);
18:02:13     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
18:02:13     INFO -  (xpcshell/head.js) | test pending (2)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | JavaScript strict warning: /sdcard/tests/xpcshell/toolkit/components/telemetry/tests/unit/head.js -> file:///storage/sdcard/tests/xpcshell/toolkit/mozapps/extensions/test/xpcshell/head_addons.js, line 1365: SyntaxError: in strict mode code, functions may be declared only at top level or immediately within another function
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121951644	addons.manager	DEBUG	Application has been upgraded
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121952565	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/XPIProvider.jsm: ["XPIProvider"]
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121952704	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/LightweightThemeManager.jsm: ["LightweightThemeManager"]
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121952851	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/GMPProvider.jsm
18:02:13     INFO -  "Mock profileBeforeChange blocker for 'AddonManager: shutting down.'"
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121952903	addons.manager	DEBUG	Starting provider: XPIProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121952924	addons.xpi	DEBUG	startup
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121952978	addons.xpi	DEBUG	checkForChanges
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953015	addons.xpi	DEBUG	Loaded add-on state from prefs: {}
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953047	addons.xpi	DEBUG	getInstallState changed: false, state: {}
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953069	addons.xpi	DEBUG	Empty XPI database, setting schema version preference to 16
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953100	addons.xpi	DEBUG	No changes found
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953144	addons.manager	DEBUG	Registering shutdown blocker for XPIProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953192	addons.manager	DEBUG	Provider finished startup: XPIProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953206	addons.manager	DEBUG	Starting provider: LightweightThemeManager
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953221	addons.manager	DEBUG	Registering shutdown blocker for LightweightThemeManager
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953262	addons.manager	DEBUG	Provider finished startup: LightweightThemeManager
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953274	addons.manager	DEBUG	Starting provider: GMPProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953340	addons.manager	DEBUG	Registering shutdown blocker for GMPProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953374	addons.manager	DEBUG	Provider finished startup: GMPProvider
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953400	addons.manager	DEBUG	Completed startup sequence
18:02:13     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
18:02:13     INFO -  running event loop
18:02:13     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "SyntaxError: in strict mode code, functions may be declared only at top level or immediately within another function" {file: "/sdcard/tests/xpcshell/toolkit/components/telemetry/tests/unit/head.js -> file:///storage/sdcard/tests/xpcshell/toolkit/mozapps/extensions/test/xpcshell/head_addons.js" line: 1365 column: 11 source: "  function MockWindowsRegKey() {
18:02:13     INFO -  "}]"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121951644	addons.manager	DEBUG	Application has been upgraded"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121952565	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/XPIProvider.jsm: ["XPIProvider"]"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121952704	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/LightweightThemeManager.jsm: ["LightweightThemeManager"]"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121952851	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/GMPProvider.jsm"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121952903	addons.manager	DEBUG	Starting provider: XPIProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121952924	addons.xpi	DEBUG	startup"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121952978	addons.xpi	DEBUG	checkForChanges"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953015	addons.xpi	DEBUG	Loaded add-on state from prefs: {}"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953047	addons.xpi	DEBUG	getInstallState changed: false, state: {}"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953069	addons.xpi	DEBUG	Empty XPI database, setting schema version preference to 16"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953100	addons.xpi	DEBUG	No changes found"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953144	addons.manager	DEBUG	Registering shutdown blocker for XPIProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953192	addons.manager	DEBUG	Provider finished startup: XPIProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953206	addons.manager	DEBUG	Starting provider: LightweightThemeManager"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953221	addons.manager	DEBUG	Registering shutdown blocker for LightweightThemeManager"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953262	addons.manager	DEBUG	Provider finished startup: LightweightThemeManager"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953274	addons.manager	DEBUG	Starting provider: GMPProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953340	addons.manager	DEBUG	Registering shutdown blocker for GMPProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953374	addons.manager	DEBUG	Provider finished startup: GMPProvider"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953400	addons.manager	DEBUG	Completed startup sequence"
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
18:02:13     INFO -  toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | Starting asyncSetup
18:02:13     INFO -  (xpcshell/head.js) | test asyncSetup pending (3)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121953768	Toolkit.Telemetry	TRACE	TelemetryPing::setupTelemetry
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (3)
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121953768	Toolkit.Telemetry	TRACE	TelemetryPing::setupTelemetry"
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121954169	Toolkit.Telemetry	TRACE	TelemetryEnvironment::init
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121954181	Toolkit.Telemetry	TRACE	TelemetryEnvironment::_startWatchingPrefs - null
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121954169	Toolkit.Telemetry	TRACE	TelemetryEnvironment::init"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121954181	Toolkit.Telemetry	TRACE	TelemetryEnvironment::_startWatchingPrefs - null"
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 1 pending (3)
18:02:13     INFO -  (xpcshell/head.js) | test asyncSetup finished (3)
18:02:13     INFO -  toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | Starting test_overwritePing
18:02:13     INFO -  (xpcshell/head.js) | test test_overwritePing pending (3)
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 1 finished (3)
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 2 pending (3)
18:02:13     INFO -  (xpcshell/head.js) | test test_overwritePing finished (3)
18:02:13     INFO -  toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | Starting test_noServerPing
18:02:13     INFO -  (xpcshell/head.js) | test test_noServerPing pending (3)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121956369	Toolkit.Telemetry	TRACE	TelemetryPing::send - Type test-ping-type, Server http://doesnotexist, aOptions {"addClientId":false,"addEnvironment":false,"retentionDays":180}
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121956378	Toolkit.Telemetry	TRACE	TelemetryPing::assemblePing - Type test-ping-type, Server http://doesnotexist, aOptions {"addClientId":false,"addEnvironment":false,"retentionDays":180}
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 2 finished (3)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121956466	Toolkit.Telemetry	TRACE	TelemetryPing::doPing - Server http://doesnotexist, Persisted false
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121957122	Toolkit.Telemetry	TRACE	TelemetryPing::sendPersistedPings
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121957141	Toolkit.Telemetry	TRACE	TelemetryPing::popPayloads
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121956369	Toolkit.Telemetry	TRACE	TelemetryPing::send - Type test-ping-type, Server http://doesnotexist, aOptions {"addClientId":false,"addEnvironment":false,"retentionDays":180}"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121956378	Toolkit.Telemetry	TRACE	TelemetryPing::assemblePing - Type test-ping-type, Server http://doesnotexist, aOptions {"addClientId":false,"addEnvironment":false,"retentionDays":180}"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121956466	Toolkit.Telemetry	TRACE	TelemetryPing::doPing - Server http://doesnotexist, Persisted false"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121957122	Toolkit.Telemetry	TRACE	TelemetryPing::sendPersistedPings"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121957141	Toolkit.Telemetry	TRACE	TelemetryPing::popPayloads"
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121957264	Toolkit.Telemetry	TRACE	TelemetryPing::finishPingRequest - Success false, Persisted false
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121957264	Toolkit.Telemetry	TRACE	TelemetryPing::finishPingRequest - Success false, Persisted false"
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 3 pending (3)
18:02:13     INFO -  (xpcshell/head.js) | test test_noServerPing finished (3)
18:02:13     INFO -  toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | Starting test_simplePing
18:02:13     INFO -  (xpcshell/head.js) | test test_simplePing pending (3)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121957506	Toolkit.Telemetry	TRACE	TelemetryPing::send - Type test-ping-type, Server http://localhost:55763, aOptions {"addClientId":false,"addEnvironment":false,"retentionDays":180}
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121957517	Toolkit.Telemetry	TRACE	TelemetryPing::assemblePing - Type test-ping-type, Server http://localhost:55763, aOptions {"addClientId":false,"addEnvironment":false,"retentionDays":180}
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 3 finished (3)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121957551	Toolkit.Telemetry	TRACE	TelemetryPing::doPing - Server http://localhost:55763, Persisted false
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121957604	Toolkit.Telemetry	TRACE	TelemetryPing::sendPersistedPings
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121957636	Toolkit.Telemetry	TRACE	TelemetryPing::popPayloads
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121957506	Toolkit.Telemetry	TRACE	TelemetryPing::send - Type test-ping-type, Server http://localhost:55763, aOptions {"addClientId":false,"addEnvironment":false,"retentionDays":180}"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121957517	Toolkit.Telemetry	TRACE	TelemetryPing::assemblePing - Type test-ping-type, Server http://localhost:55763, aOptions {"addClientId":false,"addEnvironment":false,"retentionDays":180}"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121957551	Toolkit.Telemetry	TRACE	TelemetryPing::doPing - Server http://localhost:55763, Persisted false"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121957604	Toolkit.Telemetry	TRACE	TelemetryPing::sendPersistedPings"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121957636	Toolkit.Telemetry	TRACE	TelemetryPing::popPayloads"
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121957982	Toolkit.Telemetry	TRACE	TelemetryPing::finishPingRequest - Success true, Persisted false
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 225] "v=4" != ""
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 229] "v=4" == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 137] type must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 137] id must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 137] creationDate must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 137] version must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 137] application must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 137] payload must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 140] The ping must have the correct type. - "test-ping-type" == "test-ping-type"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 141] The ping must have the correct version. - 4 == 4
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 145] buildId must have the correct value. - "2007010101" == "2007010101"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 145] name must have the correct value. - "XPCShell" == "XPCShell"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 145] version must have the correct value. - "1" == "1"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 145] vendor must have the correct value. - "Mozilla" == "Mozilla"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 145] platformVersion must have the correct value. - "1.9.2" == "1.9.2"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 145] xpcomAbi must have the correct value. - "noarch-spidermonkey" == "noarch-spidermonkey"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 151] The application section must have an architecture field. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 153] The application section must have a channel field. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 157] false == false
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_simplePing - [test_simplePing : 158] false == false
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 4 pending (3)
18:02:13     INFO -  (xpcshell/head.js) | test test_simplePing finished (3)
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121957982	Toolkit.Telemetry	TRACE	TelemetryPing::finishPingRequest - Success true, Persisted false"
18:02:13     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "nsIJSON.decode is deprecated.  Please use JSON.parse instead." {file: "test_TelemetryPing.js" line: 113}]"
18:02:13     INFO -  toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | Starting test_pingHasClientId
18:02:13     INFO -  (xpcshell/head.js) | test test_pingHasClientId pending (3)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121958807	Toolkit.Telemetry	TRACE	TelemetryPing::send - Type test-ping-type, Server http://localhost:55763, aOptions {"addClientId":true,"addEnvironment":false,"retentionDays":180}
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121958819	Toolkit.Telemetry	TRACE	TelemetryPing::assemblePing - Type test-ping-type, Server http://localhost:55763, aOptions {"addClientId":true,"addEnvironment":false,"retentionDays":180}
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 4 finished (3)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121958882	Toolkit.Telemetry	TRACE	TelemetryPing::doPing - Server http://localhost:55763, Persisted false
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121958947	Toolkit.Telemetry	TRACE	TelemetryPing::sendPersistedPings
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121958967	Toolkit.Telemetry	TRACE	TelemetryPing::popPayloads
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121958807	Toolkit.Telemetry	TRACE	TelemetryPing::send - Type test-ping-type, Server http://localhost:55763, aOptions {"addClientId":true,"addEnvironment":false,"retentionDays":180}"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121958819	Toolkit.Telemetry	TRACE	TelemetryPing::assemblePing - Type test-ping-type, Server http://localhost:55763, aOptions {"addClientId":true,"addEnvironment":false,"retentionDays":180}"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121958882	Toolkit.Telemetry	TRACE	TelemetryPing::doPing - Server http://localhost:55763, Persisted false"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121958947	Toolkit.Telemetry	TRACE	TelemetryPing::sendPersistedPings"
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121958967	Toolkit.Telemetry	TRACE	TelemetryPing::popPayloads"
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121959262	Toolkit.Telemetry	TRACE	TelemetryPing::finishPingRequest - Success true, Persisted false
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 137] type must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 137] id must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 137] creationDate must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 137] version must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 137] application must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 137] payload must be available. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 140] The ping must have the correct type. - "test-ping-type" == "test-ping-type"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 141] The ping must have the correct version. - 4 == 4
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 145] buildId must have the correct value. - "2007010101" == "2007010101"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 145] name must have the correct value. - "XPCShell" == "XPCShell"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 145] version must have the correct value. - "1" == "1"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 145] vendor must have the correct value. - "Mozilla" == "Mozilla"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 145] platformVersion must have the correct value. - "1.9.2" == "1.9.2"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 145] xpcomAbi must have the correct value. - "noarch-spidermonkey" == "noarch-spidermonkey"
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 151] The application section must have an architecture field. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 153] The application section must have a channel field. - true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 157] true == true
18:02:13     INFO -  TEST-PASS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | test_pingHasClientId - [test_pingHasClientId : 158] false == false
18:02:13     INFO -  (xpcshell/head.js) | test run_next_test 5 pending (3)
18:02:13     INFO -  (xpcshell/head.js) | test test_pingHasClientId finished (3)
18:02:13     INFO -  "CONSOLE_MESSAGE: (info) 1426121959262	Toolkit.Telemetry	TRACE	TelemetryPing::finishPingRequest - Success true, Persisted false"
18:02:13     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "nsIJSON.decode is deprecated.  Please use JSON.parse instead." {file: "test_TelemetryPing.js" line: 113}]"
18:02:13     INFO -  toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | Starting test_pingHasEnvironment
18:02:13     INFO -  (xpcshell/head.js) | test test_pingHasEnvironment pending (3)
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121959963	Toolkit.Telemetry	TRACE	TelemetryPing::send - Type test-ping-type, Server http://localhost:55763, aOptions {"addClientId":false,"addEnvironment":true,"retentionDays":180}
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121959977	Toolkit.Telemetry	TRACE	TelemetryPing::assemblePing - Type test-ping-type, Server http://localhost:55763, aOptions {"addClientId":false,"addEnvironment":true,"retentionDays":180}
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121960013	Toolkit.Telemetry	TRACE	TelemetryEnvironment::getEnvironmentData
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 1426121960034	Toolkit.Telemetry	TRACE	TelemetryEnvironment::getEnvironmentData
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | Segmentation fault
18:02:13     INFO -  PROCESS | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | 13
18:02:13     INFO -  <<<<<<<
18:02:13     INFO -  mozcrash Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/gbrown@mozilla.com-e80c0fdd1ef6/try-android-api-11/fennec-39.0a1.en-US.android-arm.crashreporter-symbols.zip
18:02:13     INFO -  mozcrash Saved minidump as /builds/slave/test/build/blobber_upload_dir/444814c6-996f-1c57-6ca86723-10898531.dmp
18:02:13     INFO -  mozcrash Saved app info as /builds/slave/test/build/blobber_upload_dir/444814c6-996f-1c57-6ca86723-10898531.extra
18:02:13  WARNING -  PROCESS-CRASH | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | application crashed [@ libc.so + 0x1e524]
18:02:13     INFO -  Crash dump filename: /tmp/tmpjw4gHI/444814c6-996f-1c57-6ca86723-10898531.dmp
18:02:13     INFO -  Operating system: Android
18:02:13     INFO -                    0.0.0 Linux 2.6.29-gea477bb #1 Wed Sep 26 11:04:45 PDT 2012 armv7l generic/sdk/generic:4.3.1/JLS36I/eng.gbrown.20150308.182649:eng/test-keys
18:02:13     INFO -  CPU: arm
18:02:13     INFO -       0 CPUs
18:02:13     INFO -  
18:02:13     INFO -  Crash reason:  SIGSEGV
18:02:13     INFO -  Crash address: 0xdeadbaad
18:02:13     INFO -  
18:02:13     INFO -  Thread 0 (crashed)
18:02:13     INFO -   0  libc.so + 0x1e524
18:02:13     INFO -       r4 = 0x00000000    r5 = 0xbec1577c    r6 = 0x00010080    r7 = 0x00010060
18:02:13     INFO -       r8 = 0x421406dc    r9 = 0x000000af   r10 = 0x42395c70    fp = 0x41f98f48
18:02:13     INFO -       sp = 0xbec15778    lr = 0x40039fcb    pc = 0x40037524
18:02:13     INFO -      Found by: given as instruction pointer in context
18:02:13     INFO -   1  libEGL.so + 0x39a31
18:02:13     INFO -       sp = 0xbec1577c    pc = 0x42124a33
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   2  libcutils.so + 0x87af
18:02:13     INFO -       sp = 0xbec15788    pc = 0x420be7b1
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   3  libEGL.so + 0x39a31
18:02:13     INFO -       sp = 0xbec15798    pc = 0x42124a33
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   4  libc.so + 0x1c4e6
18:02:13     INFO -       sp = 0xbec157a0    pc = 0x400354e8
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   5  libcutils.so + 0x8477
18:02:13     INFO -       sp = 0xbec157a4    pc = 0x420be479
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   6  libcutils.so + 0x888d
18:02:13     INFO -       sp = 0xbec157a8    pc = 0x420be88f
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   7  fennec-39.0a1.en-US.android-arm.apk + 0x20268fe
18:02:13     INFO -       sp = 0xbec157e0    pc = 0x47626900
18:02:13     INFO -      Found by: stack scanning
18:02:13     INFO -   8  libmozglue.so!arena_avail_comp [arena.c:e80c0fdd1ef6 : 70 + 0x5]
18:02:13     INFO -       sp = 0xbec15808    pc = 0x40207451
18:02:13     INFO -      Found by: stack scanning
Whiteboard: [test disabled on android 4.3]
I'm surprised that there is no change-set URL mentioned here or anything?
Is this actually failing on Android 4.3 (which would make it a concern) or just the emulator?
The test is disabled for all Android 4.3 platforms.
Flags: needinfo?(gbrown)
This is related to bug 1133833, where we are trying to start running all of our unit test suites in an Android emulator running Android 4.3; this environment would be very similar to the existing "Android 2.3 API9 opt" tests, but running Android 4.3.

As part of the effort to get these tests running and sheriffed on treeherder, failing tests have been disabled, typically with an annotation for "android_version == '18'", which affects all Android 4.3 platforms. I have only tested on the Android 4.3 emulator and have no idea how this test behaves on 4.3 devices.

I don't think we have a better way to annotate the test manifests; annotations are based on mozinfo.json, plus a select few run-time additions like "android_version".

I couldn't report a normal treeherder url in this bug since the 4.3 environment is not active yet, but with a little more progress in bug 1133833, you should be able to run 4.3 tests on try soon and verify the issue.
Flags: needinfo?(gbrown)
See Also: → 1136634
Tests re-enabled in...
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1136634
You need to log in before you can comment on or make changes to this bug.