[gonk-lmr1] Adapt to ConsumerListener interface changes in gonknativewindow/libdisplay

RESOLVED FIXED in Firefox 40, Firefox OS v2.2

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: m1, Assigned: m1)

Tracking

unspecified
2.2 S9 (3apr)
x86
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox38 wontfix, firefox39 wontfix, firefox40 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 810046])

Attachments

(1 attachment)

Comment 1

4 years ago
Hi Michael Wu & Shawn Ku,

Please help route this to the appropriate owner.

Thanks,
Mike
Flags: needinfo?(sku)
Flags: needinfo?(mwu)

Updated

4 years ago
Whiteboard: [CR 810046]

Updated

4 years ago
Whiteboard: [CR 810046] → [caf priority: p2][CR 810046]
(Assignee)

Comment 2

4 years ago
Created attachment 8581064 [details] [diff] [review]
0004-Bug-1144515-ConsumerListener-interface-changes.patch

Little ugly (#ifdefs, a gnarly cast, 'BufferItem' name conflict). But OTOH, this patch does seem work well on L MR1 so maybe that's something.  Please steal, I'm a PTO for next two weeks.

Note that these are minimal changes for L MR1, that is the addition BufferItem to 'onFrameAvailable' is ignored as is the new 'onFrameReplaced' method.  Not sure if Gecko might like to use this new facility in the future, I honestly haven't thought about it that much :)
(Assignee)

Comment 3

4 years ago
(goto v2.2+, as we do really need this)
blocking-b2g: --- → 2.2+

Comment 4

4 years ago
Comment on attachment 8581064 [details] [diff] [review]
0004-Bug-1144515-ConsumerListener-interface-changes.patch

Review of attachment 8581064 [details] [diff] [review]:
-----------------------------------------------------------------

mwu is the proper one to review this patch.

mwu, please help review this patch.
Attachment #8581064 - Flags: review?(mwu)

Updated

4 years ago
Flags: needinfo?(sku)

Updated

4 years ago
Assignee: nobody → mvines
I applied this patch locally and it does work properly.

Comment 6

4 years ago
Comment on attachment 8581064 [details] [diff] [review]
0004-Bug-1144515-ConsumerListener-interface-changes.patch

Review of attachment 8581064 [details] [diff] [review]:
-----------------------------------------------------------------

Touches nativewindow, so passing review to sotaro.
Attachment #8581064 - Flags: review?(sotaro.ikeda.g)
Attachment #8581064 - Flags: review?(mwu)
Attachment #8581064 - Flags: review+
Comment on attachment 8581064 [details] [diff] [review]
0004-Bug-1144515-ConsumerListener-interface-changes.patch

Review of attachment 8581064 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. If we need to use onFrameReplaced() in future b2g, we need additional change to GonkNativeWindow.
Attachment #8581064 - Flags: review?(sotaro.ikeda.g) → review+
https://hg.mozilla.org/mozilla-central/rev/7bd2bc8251bf
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S9 (3apr)
Comment on attachment 8581064 [details] [diff] [review]
0004-Bug-1144515-ConsumerListener-interface-changes.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Gonkintegration
User impact if declined: b2g build on L will not work properly.
Testing completed: verify on master
Risk to taking this patch (and alternatives if risky): low, update api to Lmr1 accordingly
String or UUID changes made by this patch: none
Attachment #8581064 - Flags: approval-mozilla-b2g37?

Updated

4 years ago
Attachment #8581064 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ee218cbd5dd1
status-b2g-v2.2: --- → affected
status-b2g-master: --- → fixed
status-firefox38: --- → wontfix
status-firefox39: --- → wontfix
Ryan, it seems be landed to b2g37_v2_2, so let's updated the status flag. Please correct it if I misunderstood.
status-b2g-v2.2: affected → fixed

Updated

4 years ago
Flags: needinfo?(mwu)
You need to log in before you can comment on or make changes to this bug.