Closed Bug 1144590 Opened 5 years ago Closed 4 years ago

[RTL][Rocketbar]The first character will not be indented when we input a long website.

Categories

(Firefox OS Graveyard :: Gaia::Search, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: lulu.tian, Unassigned)

References

Details

Attachments

(2 files)

Attached video video.MP4
[1.Description]:
[RTL][v3.0][Rocketbar]The first character will not be indented when we input a long website. This leads to that user can't see the latter characters.
See attachment:video.MP4

[2.Testing Steps]: 
1. Set system language as Arabic.
2. Launch Rocketbar.
3. Input a long website.(like: https://www.news.yahoo.com)

[3.Expected Result]: 
3. The first character should be indented when we input a long website.

[4.Actual Result]: 
3. The first character is not indented and user can't see the latter characters.

[5.Reproduction build]: 
Flame 2.2 build: unaffected
Build ID               20150317162504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/83251e534b33
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.195036
Firmware Date          Tue Mar 17 19:50:45 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: affected
Build ID               20150317160205
Gaia Revision          63d6639acd771f548a2613f07f3e335921e4ac87
Gaia Date              2015-03-17 16:53:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e965a1a534ec
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.195927
Firmware Date          Tue Mar 17 19:59:39 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
P2 but not nominating since from the video, we still get the view of the URL under the rocketbar
Not optimal though, so would be good to get a fix if we can
Priority: -- → P2
Since Bug 1145546 has been fixed, this issue has been verified pass on latest build of Flame 3.0 with the same steps in comment 0. But it still exists on Flame 2.2, I will verify it on Flame 2.2 once the pvt build has updated tomorrow.

Device: Flame 3.0 (pass)
Build ID               20150331160205
Gaia Revision          03164bd160809747e6a198e0dba1b7c3ee7789f5
Gaia Date              2015-03-31 14:48:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/18a8ea7c2c62
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150331.191641
Firmware Date          Tue Mar 31 19:16:50 EDT 2015
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Attached video verify_video.mp4
Since Bug 1145546 has been fixed, this issue has been verified passed on latest build of Flame 2.2 and Nexus 5 2.2/3.0 with the same steps in comment 0.
See attachment:verify_video.MP4
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.035717
Firmware Date          Wed Apr 29 03:57:29 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (pass)
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150429.040217
Firmware Date          Wed Apr 29 04:02:34 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (pass)
Build ID               20150429010205
Gaia Revision          6e35b0948c42a4398b8a5916015de167121683a1
Gaia Date              2015-04-28 16:06:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1ad65cbeb2f4
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150429.044325
Firmware Date          Wed Apr 29 04:43:46 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.