[SHB][Camera]You can switch device to landscape mode when you launch camera from lock screen with passcode on.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Lance(leave from Mozilla), Assigned: albertopq)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l][systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[Nexus 5 v2.2 & v3.0][Flame v2.2][Camera] Turn on passcode lock, then launch camera from lock screen page to take a photo. Device can be switched to landscape mode successfully when user view this newly taken photo.
Found time:11:07
See attachement:1107.mp4 and logcat_1107.txt

[2.Testing Steps]: 
1.Launch Settings.
2.Set the passcode lock.
3.Launch Camera, then lock screen, tap power key once to wake up screen.
4.Slide lock icon to camera.
5.Take a photo, tap the gallery icon to view the image.
6.Switch device to landscape.

Note: If you does not turn on the Flame SHB, device switch landscape successfully, if you turn on SHB, after switch to landscape, the SHB icon can't display.

[3.Expected Result]: 
6. The page should not switch to landscape mode.

[4.Actual Result]: 
6. Device switch to landscape successfully, and the SHB icon can't display.

[5.Reproduction build]: 
Nexus 5_2.2 version(Affected):
Build ID               20150317162504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/83251e534b33
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150317.195033
Firmware Date          Tue Mar 17 19:50:47 EDT 2015
Bootloader             HHZ12d

Nexus 5_3.0 version(Affected):

Build ID               20150317160205
Gaia Revision          63d6639acd771f548a2613f07f3e335921e4ac87
Gaia Date              2015-03-17 16:53:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e965a1a534ec
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150317.194723
Firmware Date          Tue Mar 17 19:47:37 EDT 2015
Bootloader             HHZ12d

Flame 2.2 version(Affected):
Build ID               20150317162504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/83251e534b33
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.195036
Firmware Date          Tue Mar 17 19:50:45 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]
The bug still exist in Flame 2.2.
(Reporter)

Comment 1

3 years ago
Created attachment 8579225 [details]
logcat_1107.txt
(Reporter)

Comment 2

3 years ago
Created attachment 8579227 [details]
1107.MP4
Flame-KK - not able to rotate.
Nexus-5-L - rotated but SHB missing.

Is that correct?
Flags: needinfo?(liuke)
(Reporter)

Comment 4

3 years ago
(In reply to Eric Chang [:ericcc] [:echang] from comment #3)
> Flame-KK - not able to rotate.
> Nexus-5-L - rotated but SHB missing.
> 
> Is that correct?

Hi Eric,

1. If you does not launch camera in setp 3.
Flame-KK & Nexus-5-L: not able to rotate, but when we switch from portrait to landscape mode, it has the switching animation.

2. If you launch camera in setp 3.
Flame-KK: rotated, if you turn on SHB, it will miss.
Nexus-5-L: rotated and SHB missing.
Flags: needinfo?(liuke) → needinfo?(echang)
I think it might be a window management bug.
Alive, could you take a look?
Flags: needinfo?(alive)
The problem is not rotate. It's reasonable because you are in activity mode. The real problem is the software home button does not show.

Michael, please put this one in backlog.. or you think it's severe enough?
Flags: needinfo?(alive) → needinfo?(mhenretty)
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l][systemsfe]
It looks pretty bad, let's triage.
blocking-b2g: --- → 2.2?
Flags: needinfo?(mhenretty)
Summary: [Camera]You can switch device to landscape mode when you launch camera from lock screen with passcode on. → [SHB][Camera]You can switch device to landscape mode when you launch camera from lock screen with passcode on.
Component: Gaia::Camera → Gaia::System
SHB bug.
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

3 years ago
Assignee: nobody → apastor
Created attachment 8585568 [details] [review]
[gaia] albertopq:1144591-landscape-lockscreen > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8585568 - Flags: review?(mhenretty)
Comment on attachment 8585568 [details] [review]
[gaia] albertopq:1144591-landscape-lockscreen > mozilla-b2g:master

Looks good!
Attachment #8585568 - Flags: review?(mhenretty) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
(Assignee)

Comment 12

3 years ago
master: https://github.com/mozilla-b2g/gaia/commit/791a47fdf58cf2f3a58d385b6f460d1e1a676240
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
(Assignee)

Comment 13

3 years ago
Comment on attachment 8585568 [details] [review]
[gaia] albertopq:1144591-landscape-lockscreen > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: When entering in the Camera app from the lockscreen, the SHB is mispositioned.
[Testing completed]: Manual tests
[Risk to taking this patch] (and alternatives if risky): CSS one liner. Low risk
[String changes made]: none
Attachment #8585568 - Flags: approval-gaia-v2.2?(bbajaj)
Flags: needinfo?(echang)

Updated

3 years ago
Attachment #8585568 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/51c988f9ab29256aea52575d3e5196bde3145155
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S9 (3apr)
Keywords: verifyme
This issue is verified fixed on Flame Master and 2.2.

Result: SHB is displayed properly when the device is set in landscape mode from lockscreen camera > preview mode.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150402063750
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: 35046df9df1f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150401162503
Gaia: 1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gecko: 427b4da96714
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.