Closed Bug 1144751 Opened 5 years ago Closed 2 years ago

[UX] Print Preview on about:newtab (XUL) shows a "Progress: Preparing" popup that stays forever and never closes itself until user does.

Categories

(Core :: Print Preview, defect, minor)

36 Branch
x86_64
Linux
defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Aleksej, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: regression)

Steps to reproduce:
1. Open a new tab (it should be about:newtab).
2. File -> Print Preview.
3. Close the error dialog if it appears (printing of XUL pages is not supported, but the dialog may just say there was an unexpected problem).


Actual results:

A popup with
----
Title: New Tab
Progress: Preparing…
----
stays forever until you close it.


Expected results:

No progress UI for a clearly impossible operation.


Regression window:
g 2014-10-28-03-02-04-mozilla-central-firefox-36.0a1.ru.linux-x86_64 a255a234946e
b 2014-10-29-03-02-07-mozilla-central-firefox-36.0a1.en-US.linux-x86_64 7e3c85754d32
Flags: needinfo?(mconley)
What we should really do here is make sure that the user can never get into this state.
Depends on: 1119563
Flags: needinfo?(mconley)
Summary: Print Preview on about:newtab (XUL) shows a "Progress: Preparing" popup that stays forever and never closes itself until user does. → [UX] Print Preview on about:newtab (XUL) shows a "Progress: Preparing" popup that stays forever and never closes itself until user does.
Mike, I guess this is now fixed for about:newtab because it no longer uses XUL, but is still an issue for other things like about:preferences ?
Flags: needinfo?(mconley)
(maybe a dupe of bug 565414?)
Yeah, this is fixed now. For other XUL pages like about:preferences and about:config, bug 565414 seems like the right one. Thanks, Gijs!
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mconley)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.