bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

White flash when zooming large image

VERIFIED FIXED in Firefox 39



3 years ago
3 years ago


(Reporter: stevee, Assigned: seth)



39 Branch
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(firefox38 unaffected, firefox39+ verified)




(2 attachments)



3 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150318055750 CSet: 41a61514461e

1. New profile, start firefox
2. Navigate to http://imgur.com/gallery/RaGvZ
3. Observe as the images are decoding, there are horizontal black lines across the image, which will disappear periodically and after decoding has completed
4. Click on one of the images to increase its size
5. Observe a white flash the screen as the image reaches its maximum size. The same effect occurs when you click on the image a second time to reduce its size back to what it was.

CTRL+F5 will show the issue again if you need to see it. I assume both these problems are related; maybe they should have been filed separately.

If I set gfx.vsync.compositor and gfx.vsync.hw-vsync.enabled to false, the problem still persists. If I disable hardware acceleration the problem still persists.

Comment 1

3 years ago
I just tried to reproduce and couldn't see the issue here on OS X. I'll try again on Windows later today.

Comment 2

3 years ago
Only one person on Mozillazine forum has seen it too, most others cannot reproduce. I include my graphics details:

Adapter Description	NVIDIA GeForce GTX 660 Ti
Adapter Drivers	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM	2048
Device ID	0x1183
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16571)
Driver Date	2-5-2015
Driver Version
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	36623842
Vendor ID	0x10de
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GTX 660 Ti Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0

If it's worth anything I'm on a 120Hz monitor; I have tried changing my refresh rate back to 60Hz but it didn't make a difference. Tested on rev 2e2222a40262 and still same problem.

Comment 3

3 years ago
[Tracking Requested - why for this release]:


Triggered by: Bug 1124084

image.downscale-during-decode.enabled = false helps
Blocks: 1124084
status-firefox39: --- → unaffected
tracking-firefox39: --- → ?
Severity: normal → major
status-firefox38: --- → unaffected
status-firefox39: unaffected → affected
Keywords: regressionwindow-wanted
Version: Trunk → 39 Branch

Comment 4

3 years ago
Steve, I can reproduce the white flash on Windows, but not the black lines. Could you take a screenshot of the black lines and attach it to the bug? Seeing exactly what they look like might give a clue about where the problem is.
Flags: needinfo?(steve.england)
tracking-firefox39: ? → +

Comment 5

3 years ago
So the white flash is caused by a bug in the patch for bug 1130802. We were supposed to always prefer decoded surfaces, but we don't check whether the "perfect match" check in LookupBestMatch resulted in a surface that was decoded. This means that if we want to draw at 1000x1000 and we have a partially decoded surface of size 1000x1000 and a fully decoded surface of size 900x900, we'll return the partially decoded 1000x1000 surface, which is clearly wrong.
Blocks: 1130802

Comment 6

3 years ago
Created attachment 8579797 [details] [diff] [review]
Make the perfect match check in LookupBestMatch skip undecoded surfaces

Here's the patch.
Attachment #8579797 - Flags: review?(dholbert)


3 years ago
Assignee: nobody → seth
Attachment #8579797 - Flags: review?(dholbert) → review+

Comment 7

3 years ago
Thanks for the quick review! Setting checkin-needed because I think fixing this is pretty urgent, but inbound is closed right now.


3 years ago
Keywords: checkin-needed

Comment 8

3 years ago
Here's a try job (Linux-only, since this has been tested locally at least to some degree on Windows and OS X already):


Comment 9

3 years ago
Created attachment 8579812 [details]
screenshot black line while loading image

Comment 11

3 years ago
The white flash problem is fixed  on latest m-i build(include 29a208a74d8f).
However, The black line problem is STILL reproducible on the build.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150319010140
I'm also seeing the black lines (Windows, latest nightly, e10s, NVIDIA Quadro 1000M):

They disappear once the image has completed loading.
And if it helps - the black lines occur at every point where you could see the progressive loading of the image pause for a second. eg: N more pixels vertically load <black line inserted> then next N pixels <another black line> etc.

Comment 14

3 years ago
Given that Alice has confirmed the white-flash problem is fixed in comment 11, do I need to refile the 'black lines problem' as another bug and adjust the title of this for the white-flash problem?

Clearing the needinfo flag as Alice has provided a screenshot in comment 9
Flags: needinfo?(steve.england)
Duplicate of this bug: 1145278
Last Resolved: 3 years ago
status-firefox39: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
(In reply to Steve England [:stevee] from comment #14)
> Given that Alice has confirmed the white-flash problem is fixed in comment
> 11, do I need to refile the 'black lines problem' as another bug and adjust
> the title of this for the white-flash problem?

The follow up is in bug #1145560.
status-firefox39: fixed → verified
Summary: Horizontal black lines when decoding large image / white flash when zooming large image → White flash when zooming large image
You need to log in before you can comment on or make changes to this bug.