Middle click on search suggestions in Search Bar does not switch to new tab

RESOLVED DUPLICATE of bug 1123442

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1123442
3 years ago
2 years ago

People

(Reporter: Peter Myers, Unassigned)

Tracking

(Depends on: 1 bug)

36 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

Set profile option "When I open a link in a new tab, switch to it immediately" = yes (check marked).

Middle click on a search suggestion in the Search Bar. 


Actual results:

A new tab is opened but Firefox does NOT switch to it.


Expected results:

A new tab should be opened AND Firefox should switch to it immediately.
Hi Peter,

I have tested your issue on  latest Firefox release (43.0.1) and latest Nightly (46.0a1) and I could not reproduce it. I set profile option “When I open a link in a new tab, switch to it immediately” and what I middle click on a search suggestion in the Search bar a new tab is opened and Firefox switch to it immediately.

Firefox: 46.0a1, Build ID: 20151221114259, User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
 Firefox: 43.0.1, Build ID: 20151216175450, User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

.
Can you please test this on the latest Firefox release (43.0.1) or latest Nightly (46.0a1, https://nightly.mozilla.org/) and tell me if this still reproduces for you ? When doing this please use a new fresh Firefox profile, maybe also in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems). Sometimes this kind of issues could appear when using custom settings, themes or some addons.

Thanks,
Cosmin.
Flags: needinfo?(pmyers389)
(Reporter)

Comment 2

2 years ago
Hello Cosmin,

Thank you for looking at this issue.

I have re-tested and find this function still does not work.

I tested with FF 43.0.1 on a Win7 machine, a Win8.1 machine and a Win10 machine. I even tested using a fresh copy of FF 43.0.1 Portable.

Each time I use a fresh, newly installed version of FF with no user installed extensions.

Each time I set the option “When I open a link in a new tab, switch to it immediately”.

When I middle click a search suggestion from the search box drop down, a new tab is opened, but FF does not switch to it. In effect the option “When I open a link in a new tab, switch to it immediately” is ignored.

I did notice that when middle clicking the right arrow in the search box a new tab is opened and FF switches to it, but this happens regardless whether “When I open a link in a new tab, switch to it immediately” is set or not set. 

I am sorry these are probably not the answers you are looking for, but these are my observations.

Regards,

Peter
Flags: needinfo?(pmyers389)
Hi Peter,
 
I tested again and I have managed to reproduce the issue using the latest Firefox release (43.0.1)and using the latest Nightly (46.0a1). First time I tested on URL address bar and home search, I omitted search box dropdown suggestion, sorry about that. 

Considering this, I will mark this issue as New and assign a component to it. If someone considers that the component is not the right one, please feel free to change it with a more appropriate one.

Thanks,
Cosmin.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Untriaged → Search
(Reporter)

Comment 4

2 years ago
Cosmin,

I'm glad you were able to reproduce the problem and I'll be glad to test the solution.

Regards,

Peter

Updated

2 years ago
Depends on: 1123442

Comment 5

2 years ago
Duplicate of 1123442.
Indeed
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123442
You need to log in before you can comment on or make changes to this bug.