Closed Bug 1144975 Opened 7 years ago Closed 7 years ago

Video dimensions for tab mirroring can be smaller than the devices display

Categories

(Firefox for Android Graveyard :: Screencasting, defect)

x86
macOS
defect
Not set
normal

Tracking

(firefox39 fixed)

RESOLVED FIXED
Firefox 39
Tracking Status
firefox39 --- fixed

People

(Reporter: rbarker, Assigned: rbarker)

Details

Attachments

(1 file, 3 obsolete files)

When generating a tab mirror video stream, the stream can be half the size of the target display (currently 720p for Roku). This appears to be caused by the fact that the device pixel ratio is not used in calculating the desired video dimensions.
Summary: Generated video dimensions for tab mirroring can be smaller than the devices display → Video dimensions for tab mirroring can be smaller than the devices display
Assignee: nobody → rbarker
Comment on attachment 8580285 [details] [diff] [review]
0001-Bug-1144975-Video-dimensions-for-tab-mirroring-can-be-smaller-than-the-devices-display-15031914-0c931d0.patch

I was told you looked over the original version. Could you take a look at this patch to see if there are any incorrect assumptions with regard to pixel conversions?
Attachment #8580285 - Flags: feedback?(bugmail.mozilla)
Comment on attachment 8580285 [details] [diff] [review]
0001-Bug-1144975-Video-dimensions-for-tab-mirroring-can-be-smaller-than-the-devices-display-15031914-0c931d0.patch

Review of attachment 8580285 [details] [diff] [review]:
-----------------------------------------------------------------

I'm lacking context to review this properly but the coordinate system stuff in the patch looks ok to me.
Attachment #8580285 - Flags: feedback?(bugmail.mozilla) → feedback+
Comment on attachment 8580285 [details] [diff] [review]
0001-Bug-1144975-Video-dimensions-for-tab-mirroring-can-be-smaller-than-the-devices-display-15031914-0c931d0.patch

Double checked values for both desktop and mobile with and with out patch applied.

Desktop without: Width: 1164 Height: 718
Desktop with:    Width: 1166 Height: 720

Mobile without:  Width: 384 Height: 566
Mobile with:     Width: 486 Height: 720

The difference in desktop is due to the original algorithm requiring the width be a multiple of 4 which appears to no longer be an issue. the difference in Mobile is due to the fact that the width and height were not scaled by the screen pixel ratio.
Attachment #8580285 - Flags: review?(snorp)
Attachment #8580285 - Flags: review?(snorp) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/b45c9c38c9dc
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 39
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.