Closed Bug 1145057 Opened 5 years ago Closed 5 years ago

[EME] Decrypted content needs to be inaccessible from JS on B2G

Categories

(Core :: Audio/Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox39 --- fixed

People

(Reporter: jwwang, Assigned: jwwang)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

test_eme_canvas_blocked.html failed when running EME tests on B2G.
Blocks: EME
Depends on: 1071482
Blocks: 1142899
Follow-up of bug 1071482 patch part 3. We also need to block drawImage() in the Skia code path.

Try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=66db21223ae2
I guess those oranges are not about EME.
Assignee: nobody → jwwang
Status: NEW → ASSIGNED
Attachment #8580445 - Flags: review?(roc)
Try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=66db21223ae2
I guess those oranges are not about EME.
Keywords: checkin-needed
sorry had to back this out for bustage / errors like https://treeherder.mozilla.org/logviewer.html#?job_id=7847858&repo=mozilla-inbound
Flags: needinfo?(jwwang)
This broke Flame L device image builds:
https://treeherder.mozilla.org/logviewer.html#?job_id=7847858&repo=mozilla-inbound

which build with EME disabled (I guess because their android version is 21).

The failure should be reproducable with --disable-eme.
Fix build break by checking if MOZ_EME is defined.
Attachment #8580445 - Attachment is obsolete: true
Flags: needinfo?(jwwang)
Attachment #8581381 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/56f07a799bd1
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.