[RTL][Dialer]The MIC button and hide keypad button are swapped.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Dialer
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Sue, Assigned: drs)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [planned-sprint c=1])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8579909 [details]
MIC_Dialer_button.png

[1.Description]:
[RTL][v2.2 & v3.0][Dialer]The MIC button and hide keypad button are swapped, with MIC icon shown at right of END button, and hide keypad button shown at left of END button.
See attachment:MIC_Dialer_button.png

[2.Testing Steps]: 
1. Set system language as Arabic.
2. Launch Dialer.
3. Call out to 911.
4. Tap dialer button to invoke the numeric keypad.
5. Observe the buttons at bottom of numeric keypad.

[3.Expected Result]: 
5. The MIC button and hide keypad button should remain same position as that in LTR language.

[4.Actual Result]: 
5. The MIC button and hide keypad button changed their position.

[5.Reproduction build]: 
Flame 2.2 build: affected
Build ID               20150318002504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a6f5f4035ea5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.040534
Firmware Date          Wed Mar 18 04:05:45 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: affected
Build ID               20150318055750
Gaia Revision          b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gaia Date              2015-03-18 07:48:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/41a61514461e
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.093634
Firmware Date          Wed Mar 18 09:36:44 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Buttons should not be swapped as per RTL specs. This is inconsistent with the rest of RTL behavior and an often used screen so nominating
blocking-b2g: --- → 2.2?
Priority: -- → P2
Comms triage: It's also inconsistent with the other panel of the call screen. Blocking.
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

3 years ago
Whiteboard: [planned-sprint c=?]
Target Milestone: --- → 2.2 S9 (3apr)
(Assignee)

Updated

3 years ago
Whiteboard: [planned-sprint c=?] → [planned-sprint c=1]
(Assignee)

Updated

3 years ago
Assignee: nobody → drs
Created attachment 8582413 [details] [review]
[gaia] DouglasSherk:1145059-callscreen-rtl-toolbar > mozilla-b2g:master
(Assignee)

Comment 4

3 years ago
Created attachment 8582416 [details] [diff] [review]
Set Callscreen keypad's toolbar to be always LTR.
Attachment #8582416 - Flags: review?(gsvelto)
Comment on attachment 8582416 [details] [diff] [review]
Set Callscreen keypad's toolbar to be always LTR.

I'm glad it was this easy :)
Attachment #8582416 - Flags: review?(gsvelto) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Updated

3 years ago
Attachment #8582413 - Flags: review+
(Assignee)

Comment 6

3 years ago
Needinfo for uplift request.
Flags: needinfo?(drs)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

3 years ago
Comment on attachment 8582416 [details] [diff] [review]
Set Callscreen keypad's toolbar to be always LTR.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): None.
[User impact] if declined: Keypad and mic buttons in the Callscreen keypad view will be swapped in RTL mode.
[Testing completed]: I tested this, it's been on master for a day.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: None.
Flags: needinfo?(drs)
Attachment #8582416 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8582416 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/f7b2676a3c3519d694ac9fdfac74276d1d8799e5
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
(Reporter)

Comment 10

3 years ago
Created attachment 8583629 [details]
MIC_Dialer_button.png

This issue has been verified successfully on latest build of Flame 2.2/3.0 with same steps in comment 0. The MIC button and hide keypad button remain same position as that in LTR language.
See attachment:MIC_Dialer_button.png
Rate:
Flame 2.2: 0/5
Flame 3.0: 0/5
Device: Flame 2.2 (pass)
Build ID               20150325162500
Gaia Revision          2d42a7c1d99472780e3aeb2e16d7cb0a4adbd222
Gaia Date              2015-03-25 20:46:52
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ebb742bfe1a4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.200218
Firmware Date          Wed Mar 25 20:02:30 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (pass)
Build ID               20150325160204
Gaia Revision          508b8d48fb5ecf08bf0e5b4fef42bc48b770e7f2
Gaia Date              2015-03-25 16:54:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f40ee067d081
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.191758
Firmware Date          Wed Mar 25 19:18:07 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.