Closed Bug 1145364 Opened 5 years ago Closed 5 years ago

ValueError: invalid literal for int() with base 10: 'ps:'

Categories

(Testing :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(firefox39 fixed)

RESOLVED FIXED
mozilla39
Tracking Status
firefox39 --- fixed

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

Attachments

(1 file)

The orphan process detection code introduced by bug 1084614 fails on OS X, thankfully in a non-harmful manner:

http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1426794938/mozilla-inbound_snowleopard_test-mochitest-1-bm106-tests1-macosx-build439.txt.gz

13:58:16     INFO -  Checking for orphan ssltunnel processes...
13:58:17     INFO -  Exception in thread ProcessReader:
13:58:17     INFO -  Traceback (most recent call last):
13:58:17     INFO -    File "/tools/python27/lib/python2.7/threading.py", line 551, in __bootstrap_inner
13:58:17     INFO -      self.run()
13:58:17     INFO -    File "/tools/python27/lib/python2.7/threading.py", line 504, in run
13:58:17     INFO -      self.__target(*self.__args, **self.__kwargs)
13:58:17     INFO -    File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/mozprocess/processhandler.py", line 894, in _read
13:58:17     INFO -      callback(line.rstrip())
13:58:17     INFO -    File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/mozprocess/processhandler.py", line 814, in __call__
13:58:17     INFO -      e(*args, **kwargs)
13:58:17     INFO -    File "/builds/slave/talos-slave/test/build/tests/mochitest/runtests.py", line 2045, in _psKill
13:58:17     INFO -      pid = int(parts[0])
13:58:17     INFO -  ValueError: invalid literal for int() with base 10: 'ps:'
13:58:17     INFO -  Checking for orphan xpcshell processes...
13:58:17     INFO -  Exception in thread ProcessReader:
13:58:17     INFO -  Traceback (most recent call last):
13:58:17     INFO -    File "/tools/python27/lib/python2.7/threading.py", line 551, in __bootstrap_inner
13:58:17     INFO -      self.run()
13:58:17     INFO -    File "/tools/python27/lib/python2.7/threading.py", line 504, in run
13:58:17     INFO -      self.__target(*self.__args, **self.__kwargs)
13:58:17     INFO -    File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/mozprocess/processhandler.py", line 894, in _read
13:58:17     INFO -      callback(line.rstrip())
13:58:17     INFO -    File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/mozprocess/processhandler.py", line 814, in __call__
13:58:17     INFO -      e(*args, **kwargs)
13:58:17     INFO -    File "/builds/slave/talos-slave/test/build/tests/mochitest/runtests.py", line 2045, in _psKill
13:58:17     INFO -      pid = int(parts[0])
13:58:17     INFO -  ValueError: invalid literal for int() with base 10: 'ps:'
OS X 10.6 complains:

15:31:19     INFO -  ps: illegal option -- -
15:31:19     INFO -  usage: ps [-AaCcEefhjlMmrSTvwXx] [-O fmt | -o fmt] [-G gid[,gid...]]
15:31:19     INFO -            [-g grp[,grp...]] [-u [uid,uid...]]
15:31:19     INFO -            [-p pid[,pid...]] [-t tty[,tty...]] [-U user[,user...]]
15:31:19     INFO -         ps [-L]

I think it doesn't like --no-headers.
Windows is no more amused by it than OS X is.
Holy spammy error batman.
Remove --no-headers and ignore lines that don't have a number (pid) in the first word (like the header!).

https://treeherder.mozilla.org/#/jobs?repo=try&revision=5ef6c6cf8076
Attachment #8580755 - Flags: review?(kmoir)
Attachment #8580755 - Flags: review?(kmoir) → review+
Duplicate of this bug: 1145906
https://hg.mozilla.org/mozilla-central/rev/bf9e8b4096cf
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.