YouTube HTML5 playback is janky and full of artifacts on OSX

RESOLVED FIXED

Status

()

P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mschifer, Unassigned)

Tracking

(Blocks: 1 bug)

39 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
OSX 10.8.5 
Macbook Pro - Retina display

Playing any HTML5 video on Youtube results in unwatchable playback
Video is full jank and artifacts 
Example: 
https://www.youtube.com/watch?v=gnnveIy78W8

Short capture of playback issue:
https://drive.google.com/file/d/0Byu0uOStN_ZcRTV3QlB0WUhiaWgtN2FYbHVEOUdjX3JTeFBr/view?usp=sharing
Is this a new issue?

Which version of Nightly are you using ?
Bug 1143339, would have caused such problems but this is now fixed
Flags: needinfo?(mschifer)
And can you please provide what is shown in Right Click -> Stats for Nerds.
(Reporter)

Comment 3

4 years ago
screen shot of Stats For Nerds
Flags: needinfo?(mschifer)
(Reporter)

Comment 4

4 years ago
This started a few days ago and it looks like it is profile dependent, (not related to addons though)  Which about:config options should I check?
(Reporter)

Comment 5

4 years ago
Toggling E10S Off and On again seems to have fixed it.
(Reporter)

Comment 6

4 years ago
actually it is sitll there, just more intermittent now.
Do you have the issue with E10S off ?
(Reporter)

Comment 8

4 years ago
Yes same problem with E10S on or off in my main profile.
Can not reproduce it in a clean profile currently

Updated

4 years ago
Priority: -- → P2
Can you please paste the 'Graphics' section of about:support on your machine, just so we're clear what GPU it's using. I've not seen anything like this on my macs.
(Reporter)

Comment 10

4 years ago
Graphics
Device ID	0x 166
GPU Accelerated Windows	1/1 OpenGL (OMTC)
Vendor ID	0x8086
WebGL Renderer	NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine
windowLayerManagerRemote	true
AzureCanvasBackend	quartz
AzureContentBackend	quartz
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
Component: Audio/Video → Audio/Video: Playback
(Reporter)

Comment 11

4 years ago
This is working now, unless there is some additional investigation that might be useful, it can be closed.
Got an external retina display by any chance ?

I see this when I move a window from one screen to the next.
I meant external retina display
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Summary: Youtube HTMl5 playback is janky and full of artifacts on OSX → YouTube HTML5 playback is janky and full of artifacts on OSX
You need to log in before you can comment on or make changes to this bug.