Closed Bug 1145402 Opened 5 years ago Closed 5 years ago

Tab content disappears, gets replaced by gray screen

Categories

(Firefox for iOS :: Browser, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fennec + ---

People

(Reporter: callahad, Assigned: bnicholson)

References

Details

(Keywords: reproducible)

Attachments

(1 file)

47 bytes, text/x-github-pull-request
st3fan
: review+
Details | Review
Occasionally my tabs will die and get replaced by a blank gray screen. I can scroll around in the gray screen, but that's all I can do. If I click the blank titlebar, I'm given a blank URL input box. If I click refresh, the original URL is restored and the content reloads.

I'm usually able to induce this by rotating the device a few times and going into and out of the tab overview, as in http://people.mozilla.org/~dcallahan/ios/build5/gray-tab-of-death.mp4

However, a tab also dies of its own accord between 0:18 and 0:23 in http://people.mozilla.org/~dcallahan/ios/build5/tab-switching.mp4

iOS 8.2 / Build 5 / 5th Generation iPod Touch
Still able to repro on build 6
tracking-fennec: --- → ?
Keywords: reproducible
Duplicate of this bug: 1147625
tracking-fennec: ? → +
Thanks for the helpful report/video!
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attached file Pull request
This was kind of a pain to debug since the STR seem to work only when the app is not attached to Xcode. I noticed the URL is nil when this happens, so hopefully that's a good enough test to trigger that reload.

With this fix plus bug 1147625, the user shouldn't see gray WebViews anymore. They could still cause us trouble with session restore, though, if there are zombified tabs when we try to serialize the app state (since the URLs will be nil).
Attachment #8598975 - Flags: review?(sarentz)
Comment on attachment 8598975 [details] [review]
Pull request

I don't think this is ideal and I think we need to better understand what is happening. But if this is a good workaround until we do then please include it.
Attachment #8598975 - Flags: review?(sarentz) → review+
(In reply to Stefan Arentz [:st3fan] from comment #5)
> I don't think this is ideal and I think we need to better understand what is
> happening. But if this is a good workaround until we do then please include
> it.

What do you mean? What don't we understand/what's not ideal?
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.