Closed Bug 1145424 Opened 6 years ago Closed 3 years ago

Removing PlacesCategoriesStarter from the observers category is not enough to stop receiving notifications

Categories

(Toolkit :: Places, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mak, Unassigned)

Details

PlacesCategoriesStarter removes itself from the bookmark-observers category, after receiving the first notification. This should be enough (and it is by checking with the debugger) to remove it from the nsCategoryCache and stop the notifications, but regardless it keeps receiving notifications.
We should figure out why. For now the problem is workarounded with a boolean flag.
Priority: -- → P3
Bug 1371677 stopped PlacesCategoriesStarter from listening & attempting to remove itself from bookmark-observers, so there's nothing to do here.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.