Right alligned imput fields show no cursor

RESOLVED DUPLICATE of bug 105397

Status

()

Core
DOM: CSS Object Model
RESOLVED DUPLICATE of bug 105397
16 years ago
9 years ago

People

(Reporter: Mark Derricutt, Assigned: jst)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6) Gecko/20011120
BuildID:    0.9.6

In my webapp, I have some <input type="text"> fields that are aligned right via
CSS, the text cursor is not visible when the field is empty.



Reproducible: Always
Steps to Reproduce:
1. HTML with <input class="editcell" type="text" NAME="anedit" VALUE="" SIZE=5
class="timput">
2. CSS with .editcell { text-align: right; font-family: Verdana, Arial,
Helvetica, sans-serif; font-size: 10px; text-decoration: none }
3. View page, click in cell.


Actual Results:  No cursor visible until text was entered.

Expected Results:  Displayed a blinking cursor on the right side of the edit box.
Duplicate of 'caret not displayed for text inputs using style="text-align:
right" on first click'

*** This bug has been marked as a duplicate of 105397 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: DOM: Views and Formatting → DOM: CSS Object Model
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.