Closed Bug 1145478 Opened 5 years ago Closed 11 months ago

mobiletv.rec.orange.fr serves mistakenly WAP content to Firefox OS/Firefox Android

Categories

(Web Compatibility :: Mobile, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: sync-1, Unassigned, NeedInfo)

References

()

Details

(Whiteboard: [country-tn] [serversniff] [contactready])

Attachments

(1 file)

223.00 KB, application/octet-stream
Details
Created an attachment (id=1202445)
 more details
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
  the link is: http://mobiletv.rec.orange.fr/MiTV_GDK/
  But it does not work currently if you are not using a Orange sim on a
  Orange network in France or Tunisia.
 
 After test, the behavior for Woodduck about the two type behavior which same with Android:
 When server feedback the content-type as application/vnd.wap.xhtml+xml, the device will download directly.   Downloading 
 When server feedback the content-type as application/xhtml+xml, the device will open is as web page normally.   Page display 
 
 If device cannot get the correct content-type as application/xhtml+xml, the page will not display as page but downloading..
 
 
 
  REPRODUCING PROCEDURES:
 
 user need to get the webpage rather than downloading page
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Attached file more details
Due to we have no Orange SIM card, we cannot open the http://mobiletv.rec.orange.fr/MiTV_GDK/ link with device inserted CU SIM card in China.
Hi reporter, application/vnd.wap.xhtml+xml is a wap MIME type. Is it possible to ask the server to serve non-wap page to firefox os UA?

We have follow bug to follow this up.
Bug 941241 - Reparsing application/vnd.wap.xhtml+xml content type as HTML for Firefox OS and Firefox Android
Flags: needinfo?(sync-1)
See Also: → 941241
Hi Karl,
This is also one of the issue we need to communicate with Orange for fixing it on server.
Thanks!
Flags: needinfo?(kdubost)
Component: Gaia → Mobile
Flags: needinfo?(kdubost)
Product: Firefox OS → Tech Evangelism
Moved to Tech Evangelism.  This is a Web Compatibility issue.
France Telecom has probably a framework sniffing the UA and sending the wrong Content-Type and probably the wrong content to users. 

Firefox OS/Firefox Android are (on) smartphones with modern rendering engines and need to receive HTML and/or XHTML content. They do not include a WAP rendering engine.

Note for testers:
To test, see Comment #2 (Orange SIM card requirement)

It would be cool to have the HTTP Request/Response in between the client and the server for Firefox OS, Firefox Android and Chrome Mobile Android.
Summary: [FFOS2.0][Woodduck][Browser]The website can't feedback correct webpage to Woodduck → mobiletv.rec.orange.fr serves mistakenly WAP content to Firefox OS/Firefox Android
Whiteboard: [country-tn] [serversniff] [contactready]
Server not reachable at all outside of Orange Network.

→ ping mobiletv.rec.orange.fr
PING mobiletv.rec.orange.fr (80.12.7.1): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
^C
--- mobiletv.rec.orange.fr ping statistics ---
5 packets transmitted, 0 packets received, 100.0% packet loss
Flags: needinfo?(oana.arbuzov)
Priority: P2 → P3
Guillaume do you happen to have an Orange sim card in order to check if this issue is still reproducible?  
Thanks.
Flags: needinfo?(oana.arbuzov) → needinfo?(guillaume.demesy)
Sorry Oana I haven't Orange sim card
Flags: needinfo?(guillaume.demesy)
Thanks Guillaume.

@sync-1 can you still reproduce the issue?
The Firefox OS project is not active anymore at Mozilla.
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.