[RTL][Calendar]The built-in domain name is shown as "yahoo.com@".

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Calendar
P2
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Sue, Assigned: millermedeiros)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master unaffected)

Details

Attachments

(1 attachment)

20.39 KB, image/png
Details
(Reporter)

Description

3 years ago
Created attachment 8580597 [details]
yahoo.png

[1.Description]:
[RTL][v2.2][Calendar] The built-in domain name is shown as "yahoo.com@" when you add a yahoo account.
See attachment:yahoo.png

[2.Testing Steps]: 
1. Set system language as Arabic.
2. Launch Calendar.
3. Tap Menu -> Settings -> Add Account.
4. Select "Yahoo!" and observe the view.

[3.Expected Result]: 
4. The built-in domain name should be right-aligned and shown as "@yahoo.com".

[4.Actual Result]: 
4. The built-in domain name is shown as "yahoo.com@".

[5.Reproduction build]: 
Flame 2.2 build: affected
Build ID               20150319002500
Gaia Revision          9043c11f699c15bb6072422d1dad6518d1b5ddda
Gaia Date              2015-03-19 01:40:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0442d170bec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.042028
Firmware Date          Thu Mar 19 04:20:38 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: unaffected
Build ID               20150319160212
Gaia Revision          c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gaia Date              2015-03-18 19:30:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cbd0efcd976c
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.193329
Firmware Date          Thu Mar 19 19:33:42 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → unaffected
Triage P2: nominating as this delivers a wrong information (as is really ugly)
blocking-b2g: --- → 2.2?
Priority: -- → P2
(Assignee)

Updated

3 years ago
Assignee: nobody → mmedeiros
Target Milestone: --- → 2.2 S9 (3apr)
(Assignee)

Comment 2

3 years ago
I was not able to reproduce this on latest v2.2 and I couldn't find any change on the calendar app that could have fixed this, so I'm assuming it was a gecko regression.

Gaia-Rev        44c62060581fde8de1e12e94cf55e9673b401a47
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0f1dbb995e1a
Build-ID        20150321002503
Version         37.0
Device-Name     flame
Status: NEW → RESOLVED
blocking-b2g: 2.2? → ---
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.