[RTL][Calendar]The ellipsis is displayed at left side of title and location of an event which has LTR characters in Day, Week and Month views.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: mmedeiros)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

Reporter

Description

4 years ago
Posted image Screenshot_event.png
[1.Description]:
[RTL][v2.2&v3.0][Calendar] If we create an event which has long LTR title and location, the ellipsis is displayed at left side of title and location in Day, Week and Month views.
See attachment:Screenshot_event.png

[2.Testing Steps]: 
1.Launch Calendar and create an event which has long LTR title and long LTR location.
2.Observe the event in Day, Week and Month views.

[3.Expected Result]: 
2.The ellipsis should be displayed at right side of title and location.

[4.Actual Result]: 
2.The ellipsis is displayed at left side of title and location.

[5.Reproduction build]: 
Flame 2.2 build (Affected):
Build ID               20150319002500
Gaia Revision          9043c11f699c15bb6072422d1dad6518d1b5ddda
Gaia Date              2015-03-19 01:40:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0442d170bec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.042028
Firmware Date          Thu Mar 19 04:20:38 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150319160212
Gaia Revision          c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gaia Date              2015-03-18 19:30:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cbd0efcd976c
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.193329
Firmware Date          Thu Mar 19 19:33:42 EDT 2015
Bootloader             L1TC000118D0
[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
QA Whiteboard: [rtl-impact]
Triage -- P2. Nominating since I can imagine that people would attend LTR-named events and this would be an issue (just an example)
blocking-b2g: --- → 2.2?
Priority: -- → P2
Assignee: nobody → mmedeiros
Target Milestone: --- → 2.2 S9 (3apr)
Potentially helpful PR for fixing this:  https://github.com/mozilla-b2g/gaia/pull/28976/files
Attachment #8581907 - Flags: review?(gaye)
Blocks: 1138016
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8581907 [details] [review]
[gaia] millermedeiros:1145542-rtl-event-ellipsis > mozilla-b2g:master

LGTM!
Attachment #8581907 - Flags: review?(gaye) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8581907 [details] [review]
[gaia] millermedeiros:1145542-rtl-event-ellipsis > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: ellipsis at the wrong side for bidi text and will also have overlaps with the alarm icon on day view
[Testing completed]: manual
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8581907 - Flags: approval-gaia-v2.2?
Attachment #8581907 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed in the latest Nightly Flame 2.2 build.

Actual Results: Event names and places correctly have the ellipsis on the right for LTR text when in an RTL language.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150325002503
Gaia: aeee2a54caa8ffb875b96264b61d742b70689f22
Gecko: 556aca3e50ac
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

This issue is NOT fixed in the latest Nightly Flame 3.0 build.

Actual Results: Event names and places incorrectly have the ellipsis on the left for LTR text when in an RTL language.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150325083046
Gaia: aebfbd998041e960cea0468533c0b5041b504850
Gecko: db0409de517a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [rtl-impact] → [QAnalyst-Triage?][rtl-impact][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact][failed-verification] → [QAnalyst-Triage+][rtl-impact][failed-verification]
Flags: needinfo?(ktucker)

Comment 9

4 years ago
Posted image correct_ellipsis.png
This issue is verified successfully on the latest build of Flame 3.0 with same steps in comment 0. When we create an event which has long LTR title and LTR location, the ellipsis is displayed at right side of LTR text in Day, Week and Month views.
See attachment:correct_ellipsis.png
Rate:0/5

Device: Flame 3.0(pass)
Build ID               20150325160204
Gaia Revision          508b8d48fb5ecf08bf0e5b4fef42bc48b770e7f2
Gaia Date              2015-03-25 16:54:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f40ee067d081
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.191758
Firmware Date          Wed Mar 25 19:18:07 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact][failed-verification] → [QAnalyst-Triage+][rtl-impact][failed-verification][MGSEI-Triage+]
QA Whiteboard: [QAnalyst-Triage+][rtl-impact][failed-verification][MGSEI-Triage+] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]

Comment 10

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/16229/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.