Closed Bug 1145570 Opened 5 years ago Closed 3 years ago

Volume control button no longer works as expected after right-click on Flash Youtube video

Categories

(Core :: Plug-ins, defect)

37 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
platform-rel --- ?

People

(Reporter: FlorinMezei, Unassigned)

Details

(Whiteboard: [platform-rel-Youtube])

Attachments

(1 file)

Reproducible with: 
- Firefox 37 Beta 7 - BuildID: 20150319212106
- latest Adobe Flash - 11.2.202.451

Reproducible on: Ubuntu 14.04 x64 

NOT reproducible on: Mac OS X 10.9.5

Steps to reproduce:
1. Open Firefox and go to https://www.youtube.com/.
2. Start a video.
3. Let the video start and hover the volume control button -> the volume slider will show on hover as expected.
4. Right click on the Video to bring up the Flash context menu, then click outside the video area to dismiss it.
5. Hover the volume control button.

Expected results:
Volume slider should show on hover.

Actual results:
Volume slider does not show on hover.

6. Click the volume control button to mute the audio, then click again to unmute, and then move away from the button to hide the volume slider.
7. Go back to the volume control button and click it again.

Expected results:
Clicking the button should mute/unmute the audio.

Actual results:
Clicking the button does nothing - volume does not mute/unmute and the slider does not show.


Notes:
- this is not a recent regression as it seems to also show the same way in Firefox 32.0.3
- video with the issue: http://www.screencast.com/t/yFL9PrQZ (also attached)
Component: Audio/Video → Audio/Video: Playback
Component: Audio/Video: Playback → Plug-ins
platform-rel: --- → ?
Whiteboard: [platform-rel-Youtube]
YouTube use HTML5 video on Linux
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.