Last Comment Bug 1146185 - Firefox Nightly and Aurora updates not publishing automatically
: Firefox Nightly and Aurora updates not publishing automatically
Status: RESOLVED FIXED
:
Product: Release Engineering
Classification: Other
Component: Releases (show other bugs)
: unspecified
: All All
-- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Rail Aliiev [:rail] ⌚️ET
:
Mentors:
: 1146155 (view as bug list)
Depends on: 1144985
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-22 14:14 PDT by Anthony Hughes (:ashughes) [GFX][QA][Mentor]
Modified: 2015-05-04 18:01 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
+
fixed


Attachments

Description User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2015-03-22 14:14:08 PDT
I've been seeing reports on nightly-testers@lists.mozilla.org that updates are not working for Firefox 39.0a1 since Friday. I did some checking on my Mac and confirmed that my Nightly build (2015-03-20) is not finding any updates despite there being a newer build (2015-03-22) on the ftp server. I turned on logging and AUS:SVC reports "number of updates available: 0".

Here is the URL:
https://aus4.mozilla.org/update/3/Firefox/39.0a1/20150320030211/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/nightly/Darwin%2014.1.0/default/default/update.xml?force=1
Comment 1 User image Rail Aliiev [:rail] ⌚️ET 2015-03-22 14:22:24 PDT
This is blocked by bug 1144985
Comment 2 User image Gabriela [:gaby2300] 2015-03-22 14:29:26 PDT
I can confirm this bug using Windows 7 64-bit: my Nightly build (2015-03-20) doesn't find new updates.
Comment 3 User image Johannes Pfrang [:johnp] 2015-03-22 15:04:25 PDT
*** Bug 1146155 has been marked as a duplicate of this bug. ***
Comment 4 User image Yohann Jardin 2015-03-22 21:13:17 PDT
Just got the update window. New build: 20150322030216.
Comment 5 User image Bryan Price 2015-03-22 23:59:02 PDT
Looks like things are set for at least the next month.  Somebody has set Aurora and Nightly back to the ftp.mozilla.org location instead of the CDN, which is why we weren't getting updates before.

https://bugzilla.mozilla.org/show_bug.cgi?id=1144985#c14

One has to wonder, if the Nightly and Aurora updates are fubar, can we really expect the release and beta updates to be smooth?  I guess we will be finding out, one way or another.
Comment 6 User image Ben Hearsum (:bhearsum) 2015-03-23 06:04:15 PDT
(In reply to Bryan Price from comment #5)
> Looks like things are set for at least the next month.  Somebody has set
> Aurora and Nightly back to the ftp.mozilla.org location instead of the CDN,
> which is why we weren't getting updates before.
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=1144985#c14
> 
> One has to wonder, if the Nightly and Aurora updates are fubar,

Fubar is too strong a word. They're not totally broken, they just require manual work every morning to get them served (because they publish automatically pointing at ftp, not at the CDN).

> can we
> really expect the release and beta updates to be smooth?  I guess we will be
> finding out, one way or another.

Beta and Release are always served from the CDN. I would be shocked if they weren't served quickly and effectively.
Comment 7 User image Bryan Price 2015-03-23 07:41:18 PDT
(In reply to Ben Hearsum [:bhearsum] from comment #6)
> (In reply to Bryan Price from comment #5)
> > One has to wonder, if the Nightly and Aurora updates are fubar,
> 
> Fubar is too strong a word. They're not totally broken, they just require
> manual work every morning to get them served (because they publish
> automatically pointing at ftp, not at the CDN).

Thanks, Ben.  Yeah, it probably is too strong.  Still, I would have to download the .mar file myself, and figure out how to apply it.  Opening a .mar file (I assume that's the file we download for just the changes) on my computer starts Access, which wouldn't be conducive to patching Nightly.  So I would be forced to download the 43MB or so install every day that I wanted to keep updated.  (does a bit of Googling)  It looks like there are ways to manually patch, I'll read more when I have a chance.

> 
> > can we
> > really expect the release and beta updates to be smooth?  I guess we will be
> > finding out, one way or another.
> 
> Beta and Release are always served from the CDN. I would be shocked if they
> weren't served quickly and effectively.

I'll believe that.  

My thought is, the same day the original bug was filed, somebody filed a patch, and without much thought about what things need to be in shape to actually make the process anything close to being somewhat of a smooth one, the trigger was pulled (on a Friday!), and people are wondering what's going on.

I think that us Nightly users, programmers or no, are used to bustage.  It just gets weird when the bustage is more about the delivery system for updates than it is for the program itself.

It has been a bad week (indeed, a bad month and a half), and I'm probably acting out way more here than I should have.

My apologies.
Comment 8 User image Liz Henry (:lizzard) (needinfo? me) 2015-05-04 10:40:21 PDT
Ben, do you think we need to be tracking this or do you have it in hand?  Comment 5 mentions this was set for the next month, and that was a month ago.
Comment 9 User image Ben Hearsum (:bhearsum) 2015-05-04 11:59:11 PDT
Deferingto Rail on this, but I'm pretty sure it's fixed already...
Comment 10 User image Rail Aliiev [:rail] ⌚️ET 2015-05-04 12:01:46 PDT
Yeah, this is fixed by bug 1144985

Note You need to log in before you can comment on or make changes to this bug.