Closed Bug 1146220 Opened 5 years ago Closed 5 years ago

[NFC] BT did not back to the default setting after sender which initial BT disabled try to send files to receiver which is receiving files

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S10 (17apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: ashiue, Assigned: arno)

Details

Attachments

(4 files)

Gaia-Rev        44c62060581fde8de1e12e94cf55e9673b401a47
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6140a32902a
Build-ID        20150322162502
Version         37.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150322.200808
FW-Date         Sun Mar 22 20:08:19 EDT 2015
Bootloader      L1TC100118D0


STR:
1. Enable NFC on both phone
2. Enable BT only on device A
3. Device B try to share a file when device A is receiving files from others 
4. Device B show "Cannot send file right now...."
5. Check BT status on device B

Expected result:
BT disabled

Actual result:
BT enabled
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=NFC]
Hi Arno,
Could you please check this issue? Thank you.
Flags: needinfo?(arno)
Assignee: nobody → arno
Flags: needinfo?(arno)
(In reply to Alison Shiue from comment #1)
> Hi Arno,
> Could you please check this issue? Thank you.

Alison: you are right, as always! The fix should be a one-liner, however, I am traveling and cannot test on a device right now. I will be back at the office on Friday when I can test and request review. If Wesley thinks this is wasting too much time, I would like to ask Yoshi to prepare a build for you so you can test:
https://github.com/svic/gaia/tree/Bug_1146220

Note that this also needs to be fixed in master.
triage: i'm pretty sure this is regression
blocking-b2g: 2.2? → 2.2+
Forgot to turn off BT after failed transfer. Changed unit test accordingly.
Attachment #8584865 - Flags: review?(alive)
Patch for master
Attachment #8584897 - Flags: review?(alive)
Comment on attachment 8584897 [details] [review]
Turn off BT at sender when denying concurrent file transfers (master)

LGTM
Attachment #8584897 - Flags: review?(alive) → review+
Attachment #8584865 - Flags: review?(alive) → review+
Comment on attachment 8584865 [details] [review]
Turn off BT at sender when denying concurrent file transfers (v2.2)

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Undesirable UX since BT won't be turned off
[Testing completed]: added unit test case
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8584865 - Flags: approval-gaia-v2.2?
waiting for master landing before uplifting on the branch.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
alive/arno, Ni as this needs to land on master.
Group: kddi-confidential
Flags: needinfo?(arno)
Flags: needinfo?(alive)
Group: kddi-confidential
Alive r+ed both patches and Vincent set the CI flag. I don't understand the autolander's comments 11 and 12. I'll set the CI flags again for both patches.
Flags: needinfo?(arno)
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Vincent, Wesley: what needs to be done here? Autolander keeps on rejecting the CI flag.
Flags: needinfo?(whuang)
Flags: needinfo?(vchang)
Kevin, looks like we need to update the reviewer list or force something there.
Flags: needinfo?(kgrandon)
(In reply to Fabrice Desré [:fabrice] from comment #18)
> Kevin, looks like we need to update the reviewer list or force something
> there.

If this is truly NFC code, then it should be done by a suggested reviewer, which I think are correct? If it's a sub-component of the system app, then it should be moved, or we should create a new component.

For now, it looks like the code is in the system app, so changing the component should be a quick fix for this bug.
Component: NFC → Gaia::System
Flags: needinfo?(whuang)
Flags: needinfo?(vchang)
Flags: needinfo?(kgrandon)
Flags: needinfo?(alive)
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
(In reply to Autolander from comment #20)
> Pull request has landed in v2.2:
> https://github.com/mozilla-b2g/gaia/commit/
> 41a4e59d6670de93385d67d9fd61f6fa77c3c478

Oh, I didn't see that there was another PR for 2.2 here. We're fixing this workflow problem in bug 1150080.

Reverted for now until we get approval: https://github.com/mozilla-b2g/gaia/commit/485322797a069e5b185931e87d15d4e921e25b64
Attachment #8584865 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Verified on:
[2.2]
Build ID               20150412162502
Gaia Revision          cec00d643f517ffd96cde559cd3bbd43ab85816c
Gaia Date              2015-04-10 21:41:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5005522fd68e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.200029
Firmware Date          Sun Apr 12 20:00:40 EDT 2015
Bootloader             L1TC000118D0

[3.0]
Build ID               20150412160203
Gaia Revision          3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gaia Date              2015-04-10 14:38:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a46652bd992
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.192808
Firmware Date          Sun Apr 12 19:28:21 EDT 2015
Bootloader             L1TC100118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.