[RTL][Dialer]The ellipsis is shown at left side of the long LTR contact name in suggestion bar.

RESOLVED DUPLICATE of bug 1134961

Status

defect
P1
normal
RESOLVED DUPLICATE of bug 1134961
4 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: drs)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [planned-sprint c=1])

Attachments

(1 attachment)

Reporter

Description

4 years ago
[1.Description]:
[RTL][v2.2&v3.0][Dialer]Create a contact with long LTR name and search the contact in dial view, the ellipsis is shown at left side of the long LTR contact name in suggestion bar.
See attachment:Screenshot_Long LTR name.png

[2.Testing Steps]: 
1.Create a contact with long LTR name and set your phone language to Arabic.
2.Launch Dialer.
3.Input more than three digits included in the created contact.

[3.Expected Result]: 
3.The ellipsis should be shown at right side of the name.

[4.Actual Result]: 
3.The ellipsis is shown at left side of the name.

[5.Reproduction build]: 
Flame 2.2 build (Affected): 
Build ID               20150322002503
Gaia Revision          44c62060581fde8de1e12e94cf55e9673b401a47
Gaia Date              2015-03-20 19:05:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6140a32902a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.043216
Firmware Date          Sun Mar 22 04:32:27 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150322160204
Gaia Revision          9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gaia Date              2015-03-22 10:09:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e730012260a4
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.192413
Firmware Date          Sun Mar 22 19:24:22 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
QA Whiteboard: [rtl-impact]
Assignee

Updated

4 years ago
blocking-b2g: --- → 2.2?
Whiteboard: [planned-sprint c=1]
Target Milestone: --- → 2.2 S9 (3apr)
Assignee

Updated

4 years ago
Assignee: nobody → thills
triage: major issue on RTL
blocking-b2g: 2.2? → 2.2+
Priority: -- → P1
Status: NEW → ASSIGNED
Reporter

Comment 2

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/16005/
Flags: in-moztrap+
Reporter

Comment 3

4 years ago
Ignore comment 2.

Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/16006/
Assignee

Updated

4 years ago
See Also: → 1134961
Assignee

Updated

4 years ago
Assignee: thills → drs
See Also: → 1146241
Assignee

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134961
You need to log in before you can comment on or make changes to this bug.