[Message]The Statusbar appears and overlaps with the title on select attachment view.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yue.xia, Assigned: apastor)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Posted file logcat_0819.txt
[1.Description]:
[Flame][v2.2&v3.0][Message] New a message and add Video/Gallery/Camera attachment. Press Home button on select attachment view, and relaunch Message app, then the Notification appears and overlap with the title.
See attachment: logcat_0819.txt & Video1.MP4
Found time: 08:19

[2.Testing Steps]: 
1. Launch Message app.
2. New create a message and attachment icon.
3. Select Video/Gallery/Camera on action menu.
4. Press Home button.
5. Relaunch Message app.

[3.Expected Result]: 
5. The Notification shouldn't appear on select attachment view.

[4.Actual Result]: 
5. The Notification appears and overlaps with the title on select attachment view.

[5.Reproduction build]: 
Flame 2.2 build: (affected)
Build ID               20150322002503
Gaia Revision          44c62060581fde8de1e12e94cf55e9673b401a47
Gaia Date              2015-03-20 19:05:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6140a32902a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.043216
Firmware Date          Sun Mar 22 04:32:27 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: (affected)
Build ID               20150322160204
Gaia Revision          9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gaia Date              2015-03-22 10:09:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e730012260a4
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.192413
Firmware Date          Sun Mar 22 19:24:22 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Posted video Video1.MP4
This is an issue with the new statusbar related to how windows are managed => moving to System::Window Mgmt and NI alive.
blocking-b2g: --- → 2.2?
Component: Gaia::SMS → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
How about 2.1?
Keywords: qawanted
QA Contact: jmercado
In 2.1 the status bar is always shown when selecting attachments so this issue cannot occur.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150323065323
Gaia: 13c85d57f49b4bfd657ff674f2b530c141c94803
Gecko: acfc2a472b6f
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
Whiteboard: [systemsfe]
blocking-b2g: 2.2? → 2.2+
SysFE will take care, lemme know if anyone who takes this needs my opinion.

My only problem is this seems to be fixed by certain bug once.. could we get regression window?
Flags: needinfo?(alive)
Bug 1088723 may have caused this.  
Note: This issue has occurred since the status bar got removed from full screen apps opened by share activities.  However, this issue was semi fixed leading to the current results where it is only viewable after returning to the app from the homescreen sometime around the 27th of February.  I can find the window for that change if desired as well.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150129053233
Gaia: 945776c62eee22a5541ea8d36ac916d12a42b216
Gecko: 46f2ab85ed4e
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150129153131
Gaia: 9534a664e50fefe5c7a9face4de61a2e11b95e8e
Gecko: 791f9d870733
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working gaia / First Broken gecko - 
Gaia: 945776c62eee22a5541ea8d36ac916d12a42b216
Gecko: 791f9d870733

First Broken gaia / Last Working gecko - 
Gaia: 9534a664e50fefe5c7a9face4de61a2e11b95e8e
Gecko: 46f2ab85ed4e

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/945776c62eee22a5541ea8d36ac916d12a42b216...9534a664e50fefe5c7a9face4de61a2e11b95e8e
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Manuel, can you take a look at this please? This might have been caused by the work done on bug 1088723.
Blocks: 1088723
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(b.mcb)
Assigning to Manuel for now.
Assignee: nobody → b.mcb
Marce, can we get some help from tef here?
Flags: needinfo?(marce)
Alberto, any chance you'd want to steal this one?
Flags: needinfo?(apastor)
Summary: [Message]The Notification appears and overlaps with the title on select attachment view. → [Message]The Statusbar appears and overlaps with the title on select attachment view.
(Assignee)

Comment 11

4 years ago
Sure thing!
Assignee: b.mcb → apastor
Flags: needinfo?(apastor)
(Assignee)

Comment 13

4 years ago
Comment on attachment 8587217 [details] [review]
[gaia] albertopq:1146256-statusbar-fullscreen-act > mozilla-b2g:master

Worse case, getTopMostWindow will return 'this' (the current app_window) if there is no other screen in the stack, so I think is saver to use always that method. Can you r? Guillaume? Thanks!
Attachment #8587217 - Flags: review?(gmarty)
Comment on attachment 8587217 [details] [review]
[gaia] albertopq:1146256-statusbar-fullscreen-act > mozilla-b2g:master

LGTM. Thanks!
Attachment #8587217 - Flags: review?(gmarty) → review+
(Assignee)

Comment 15

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/ea53b71b751987fc07d2fc11935362c2b8ccb4b6
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(marce)
Flags: needinfo?(b.mcb)
Resolution: --- → FIXED
(Assignee)

Comment 16

4 years ago
Comment on attachment 8587217 [details] [review]
[gaia] albertopq:1146256-statusbar-fullscreen-act > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: Statusbar is visible when going home and going back to an app with a fullscreen activity.
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): One liner that removes unnecessary checks. Low risk.
[String changes made]: none
Attachment #8587217 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8587217 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
(Reporter)

Comment 17

4 years ago
Posted video verifyvideo.MP4
Hi Alberto,
I have tried to verify this issue on Flame 3.0. When we relaunch Message app, the behaviour happens after attaching video and attaching Gallery/Camera will differ.
The behaviours are as follow:
1. Select Video to add as attachment, after step5, it enters “Select a video” screen and the Notification is not displayed.
2. Select Gallery/Video to add as attachment, after step5, sometimes it enters "New message" screen, it does not enter gallery select screen/ camera view finder screen.
See attachment: verifyvideo.MP4
I think the behaviour happens after attaching video and attaching Gallery/Camera should be consistent, is that right?
Thanks!
(Reporter)

Updated

4 years ago
Flags: needinfo?(apastor)
Shine, could you please file a separate bug? It's definitely not related to this issue.
Flags: needinfo?(apastor)
Flags: needinfo?(yue.xia)
Target Milestone: --- → 2.2 S9 (3apr)
(In reply to Gregor Wagner [:gwagner] from comment #9)
> Marce, can we get some help from tef here?

Sorry, I was on Holidays last week, fortunately Alberto took the bug :-)
(Reporter)

Comment 21

4 years ago
This problem is verified pass on latest build of Flame 2.2 via the STR in comment 0.
Actual result: Relaunch Message app, it enters video、gallery select screen/ camera view finder screen and the Notification doesn't appear on select attachment view.
See attachment: Flame2.2_verify_video.MP4
Rate:0/10
Device: Flame 2.2 (Pass)
Build ID               20150406002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(yue.xia)
(Reporter)

Comment 22

4 years ago
(In reply to Julien Wajsberg [:julienw] (PTO April 6th) from comment #18)
> Shine, could you please file a separate bug? It's definitely not related to
> this issue.

Thanks Julien.
I will file the new bug soon.
(Reporter)

Updated

4 years ago
See Also: → 1151748
This issue is verified fixed on Flame Master.

Result: Status bar does not appear when returning to the Message app with a fullscreen app share activity.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150408010203
Gaia: 84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gecko: 078128c2600a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][MGSEI-Triage+] → [QAnalyst-Triage?][MGSEI-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.