(bookmark keywords are broken!) v27 migration is using a bookmark description instead of POST data

RESOLVED FIXED in Firefox 39

Status

()

Toolkit
Places
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

({dataloss, regression})

unspecified
mozilla39
dataloss, regression
Points:
3
Bug Flags:
firefox-backlog +
in-testsuite +
qe-verify -

Firefox Tracking Flags

(firefox38 unaffected, firefox39- fixed)

Details

Attachments

(1 attachment)

[Tracking Requested - why for this release]:

Looks like the migration query is using the wrong item annotations when migrating postData, thus using for example page description instead of POST data.

This is pretty bad, we need a new migration step to fix it.
Points: --- → 3
Flags: qe-verify-
Flags: in-testsuite?
Flags: firefox-backlog+
Keywords: dataloss
Summary: we are using the wrong postData → v27 migration is using a bookmark description instead of POST data

Updated

3 years ago
Iteration: --- → 39.2 - 23 Mar
Summary: v27 migration is using a bookmark description instead of POST data → (bookmark keywords are broken!) v27 migration is using a bookmark description instead of POST data
Created attachment 8582074 [details] [diff] [review]
patch v1

Luckily, I kept around the data to rebuild keywords.
Attachment #8582074 - Flags: review?(ttaubert)
Comment on attachment 8582074 [details] [diff] [review]
patch v1

Review of attachment 8582074 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8582074 - Flags: review?(ttaubert) → review+

Updated

3 years ago
Iteration: 39.2 - 23 Mar → 39.3 - 30 Mar
https://hg.mozilla.org/integration/fx-team/rev/191f0b9b6a65
Flags: in-testsuite? → in-testsuite+
Target Milestone: --- → mozilla39
Marco, when did this break? Do we need to test or uplift this?  Thanks!
status-firefox38: --- → ?
status-firefox39: --- → affected
tracking-firefox39: ? → +
No, this was Nightly only, luckily.
status-firefox38: ? → unaffected
https://hg.mozilla.org/mozilla-central/rev/191f0b9b6a65
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox39: affected → fixed
Resolution: --- → FIXED

Comment 7

3 years ago
Is this the reason for the following? When I entered the keyword for a bookmarklet ("javascript:…"), it would only show the "javascript:" URL without executing it. I had to press Enter again to actually execute the code.

I deleted the bookmarklets, re-imported a backup of my bookmarks.html, and then the keywords started working again.

If this is an unreleated issue, I'll file a new bug.
(In reply to Jan Moesen from comment #7)
> Is this the reason for the following? When I entered the keyword for a
> bookmarklet ("javascript:…"), it would only show the "javascript:" URL
> without executing it. I had to press Enter again to actually execute the
> code.

it's due to this bug, yes.
tracking-firefox39: + → -
You need to log in before you can comment on or make changes to this bug.