4k videos are extremely scrambled on Windows Vista

RESOLVED WONTFIX

Status

()

Core
Audio/Video
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: cornel_ionce, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
x86
Windows Vista
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox37- wontfix, firefox38-, firefox39- affected)

Details

Attachments

(1 attachment)

Mozilla/5.0 (Windows NT 6.0; rv:39.0) Gecko/20100101 Firefox/39.0
Mozilla/5.0 (Windows NT 6.0; rv:37.0) Gecko/20100101 Firefox/37.0

STR:
1. Open Firefox.
2. Go to youtube.com and open a 4k video (eg. https://www.youtube.com/watch?v=iNJdPyoqt8U)
3. Switch the quality to 4k.

Expected Results:
The video renders correctly at 4k resolution.

Actual Results:
The 4k video is extremely scrambled: http://i.imgur.com/F3Xt7lD.jpg


Notes:
1. Reproducing on:
- latest Nightly, build ID: 20150322030216
- Firefox 37 beta 7 - build ID: Mozilla/5.0 (Windows NT 6.0; rv:37.0) Gecko/20100101 Firefox/37.0
2. This issue reproduces only on Windows Vista 32-bit.
3. Tried to reproduce with a different machine running the same OS and instead of the scrambled video, the loading spinner is displayed after switching to 4k, and the video is stuck there.


I've tried to search for a regression range but I've ran into the same "spinner" issue mentioned above on older Nightly builds.
I was able to find that the spinner issue started with the 2015-01-01 builds.

Last good Nightly: 20141231030205
First bad Nightly: 20150101030214

Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=88037f94b7d7&tochange=3c296aa11c51
[Tracking Requested - why for this release]: Issue is Vista only, but is a regression and bad user experience for higher resolution YouTube videos.
status-firefox37: --- → affected
status-firefox39: --- → affected
tracking-firefox37: --- → ?
tracking-firefox38: --- → ?
tracking-firefox39: --- → ?
Vista being a much older OS, I don't think playing videos at 4K resolution is going to be a big issue. We're not going to fix this in 37. It's unclear to me whether we should do any work to try and fix this at all. ni Anthony for input.
status-firefox37: affected → wontfix
tracking-firefox37: ? → -
Flags: needinfo?(ajones)
Blocks: 778617
Flags: needinfo?(ajones)
What video card are you using?
I'm using nVIDIA GeForce 620 graphic card.
The other machine where we've experienced only the spinner issue (even though the video is buffered) has an AMD Radeon HD 3000 card.
Cornel - can you install https://github.com/doublec/aboutmedia/raw/master/aboutmedia.xpi and paste the contents of about:media for the spinner issue?
Created attachment 8582985 [details]
about_media.txt

I've attached the about:media content.
I'll track this for 39 for now since it's a fairly recent regression affecting MSE.
tracking-firefox39: ? → +
Anthony is this kind of bug something we should be tracking? I can see this may not be a priority for now. What do you think?
Flags: needinfo?(ajones)
Disabling 4k on Vista in bug 1154536.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ajones)
Resolution: --- → DUPLICATE
Duplicate of bug: 1154536
OK, not tracking them. We will track bug 1154536 instead.
Blocks: 1154536
tracking-firefox38: ? → -
Resolution: DUPLICATE → WONTFIX
tracking-firefox39: + → -
You need to log in before you can comment on or make changes to this bug.