[Messages] "New message" drafts do not have the right style

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: julienw, Assigned: julienw)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

Assignee

Description

4 years ago
[Blocking Requested - why for this release]:

STR:
1. launch the SMS app.
2. tap on the "new message" button.
3. enter some text, enter a recipient.
4. press back, choose "save draft"

Expected:
* The draft has a specific style to distinguish from other threads. It should be italic, and (I think) greyer.

Actual:
* The draft has the same style as other threads.


QA: please do branch checks and help us finding a regression window.

Thanks !
QA Contact: bzumwalt
B2G-Inbound Regression Window:

Working build shows all draft info on thread list page as grey and italicized, broken build shows all but recipient name/number grey and not italicized.

Last working B2G-Inbound build:
Device: Flame 2.2
Build ID: 20141106003822
Gaia: 2f077d05105f227839dbecb22cb5324f1321b934
Gecko: a4b93cd87739
Version: 36.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken B2G-Inbound build:
Device: Flame 2.2
Build ID: 20141106010822
Gaia: 0f93196939e02a559ed23ca4ade6301d3bc9a7de
Gecko: d0177443f822
Version: 36.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Working Gaia with Broken Gecko issue does NOT reproduce:
Gaia: 2f077d05105f227839dbecb22cb5324f1321b934
Gecko: d0177443f822

Working Gecko with Broken Gaia issue DOES reproduce:
Gaia: 0f93196939e02a559ed23ca4ade6301d3bc9a7de
Gecko: a4b93cd87739


B2G-Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/2f077d05105f227839dbecb22cb5324f1321b934...0f93196939e02a559ed23ca4ade6301d3bc9a7de


Issue appears to have been caused by changes made in bug 1080828
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Oleg, can you take a look at this please? Looks like this was caused by the landing for bug 1080828.
Blocks: 1080828
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(aleh.zasypkin)
Assignee

Comment 3

4 years ago
Taking as Oleg is in holidays.
Assignee: nobody → felash
blocking-b2g: 3.0? → 2.2?
Flags: needinfo?(aleh.zasypkin)
triage: regression
blocking-b2g: 2.2? → 2.2+
Assignee

Comment 6

4 years ago
Comment on attachment 8582437 [details] [review]
[gaia] julienw:1146446-fix-draft-style > mozilla-b2g:master

Hey Steve,

here is a very simple patch coming from an oversight in bug 1080828: we changed the class "name" to "threadlist-item-title" (because it's more semantic and more BEM-like) and we forgot to change it in CSS.

I checked that this does not seem to be present elsewhere in CSS.
Attachment #8582437 - Flags: review?(schung)
Comment on attachment 8582437 [details] [review]
[gaia] julienw:1146446-fix-draft-style > mozilla-b2g:master

Looks good, thanks for finding out this regression!
Attachment #8582437 - Flags: review?(schung) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Assignee

Comment 8

4 years ago
Comment on attachment 8582437 [details] [review]
[gaia] julienw:1146446-fix-draft-style > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1080828
[User impact] if declined: bad styling of drafts - they just look like normal threads.
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8582437 - Flags: approval-gaia-v2.2?
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Attachment #8582437 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Posted image Verified screenshot
This issue is verified fixed on Flame 3.0 master and on Flame 2.2. See attached screenshot for verified behavior. The time and message body snippet are not italicized, but I've checked 2.0 and 2.0 shows the same style so I assume that's the expected.

Device: Flame 3.0 Master (KK full flash 319MB)
BuildID: 20150327010205
Gaia: 249b8c08c1d57961ef6c905f3498fa62b032bf24
Gecko: e046475a75cb
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK full flash 319MB)
BuildID: 20150327002500
Gaia: f9f62d7b69c9d46a28b5ca4f18993c90b5a2b26a
Gecko: 17079fdf6c6f
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.