[Bluetooth][System] headphone status icon not shown properly when device reconnected in APIv2

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Bluetooth
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: gasolin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
-- clone from bug 1142371 comment 26 from Ian --

While turning the connected headset on/off, then it will re-connect with 'hfp' profile only. We have to file a bug for tracking why the 'a2dp' profile won't be re-connected as v1 Gaia/Gecko code base.

Comment 1

2 years ago
I cannot reproduce the inconsistency between v1 and v2 codebases with two SONY bluetooth headsets (HBH-DS220 & HBH-DS970). However there's inconsistent behaviour between the two headsets: DS220 always restores HFP and A2DP connections while DS970 restores HFP connection only, no matter whether v1 or v2 codebase. I'll try with other headsets to confirm whether reconnection behaviour depends on respective bluetooth headset.

Ian/Fred, can you specify which SONY headset you used to reproduce the bug?
Flags: needinfo?(iliu)
Flags: needinfo?(gasolin)
(Reporter)

Comment 2

2 years ago
We tested with SONY MBH10 http://24h.pchome.com.tw/prod/DGBT30-A79337061
Flags: needinfo?(iliu)
Flags: needinfo?(gasolin)

Comment 3

2 years ago
I cannot reproduce the bug on v2 codebase with MBH10 in 10 trials. Both HFP and A2DP connections are always restored after headset restarts. Resolve this bug as WORKSFORME now. Please reopen it for any concern.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.