[save and close] in event-edit-dialog remains disabled when are reminder is added

RESOLVED INVALID

Status

Calendar
Dialogs
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Markus Huelsekopf, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150306140125

Steps to reproduce:

edited an existing event
added a reminder


Actual results:

could save only via closing the dialog [top right corner, e.g. cancel]


Expected results:

[save and close] should be enabled

Updated

3 years ago
Component: Untriaged → Dialogs
Product: Thunderbird → Calendar
Version: 31 → unspecified

Comment 1

3 years ago
What Lightning version are you on?

Do you have any error messages in the error console (ctrl+shift+j) when expiriencing this?

What type of calendar is affected (local, caldav, Google via provider, ...)?
Flags: needinfo?(mh)
(Reporter)

Comment 2

3 years ago
a) Lightning version: 3.3.5

b) I have no error (or any other) messages in the error console

c) local (haven't used any other type of calendar yet)
Flags: needinfo?(mh)

Comment 3

3 years ago
3.3.5? Latest version on AMO is 3.3.3 (where I cannot reproduce the issue). From which source did you get Lightning?

Can you enable debugging by setting calendar.debug.log, calendar.debug.log.verbose and javascript.options.showInConsole in the config editor and check the log again after seeing this?

Eventually, you can also elaborate the STR a little bit to make it possible to reproduce the issue.
(Reporter)

Comment 4

3 years ago
a) I got lightning from the xubuntu repository (12.04), version was determined by [extras][add-ons]

b) I enabled all of the three settings you recommended (calendar.debug.log, calendar.debug.log.verbose and javascript.options.showInConsole). restarted thunderbird. I then reproduced the issue and got no messages at all in the console.

c) therefore no elaboration is possible

Comment 5

3 years ago
All in all, this reads like bug 844747, alltough the fix for that is already part of Ltn 3.3.

Is this a single or a recurring event where you're suffering from that issue?
(Reporter)

Comment 6

3 years ago
It's quite near to bug 844747.

It's a single event.

Idea: Are there different versioning-schemes for users and developers regarding lightning? Probably I am using a too old version...

Comment 7

3 years ago
Can you download TB 31.and Lightning 3.3.3 from the Mozilla/AMO page, install it and test, whether this is still an issue for you with that? Don't mix Ubuntu and Mozilla builds, that may cause different issues.
(Reporter)

Comment 8

3 years ago
I will download and install TB31 and Lightning 3.3.3 in a virtual host and have a look at the issue. But it will take several days, sorry for this delay.
(Reporter)

Comment 9

3 years ago
I installed TB31.0 and Lightning 3.3.3. 

The issue is not present, for the [save and close]-button is enabled even without any changes to the event. Looks like a work-around to me. But it's ok -IMHO-.

Installing lightning was quit heavy for the add-ons-manager did only the download, I somehow managed to install lightning via [install from file] but don't know how anymore. 

So: Bug does not exist in official version, [save and close] is enabled even without any changes made to an event (Is this what you want, e.g. fills the requirements? Idea: button text could be 'close' initially and 'save and close' if event becomes dirty, e.g. modified) 

Sorry for taking your time. TB is wonderful.

Comment 10

3 years ago
Thank you for testing. So, I'm resolving this to invalid as per comment #9. Maybe you want to file a bug with Ubuntu.

To change the button behaviour, feel free to file a bug for an enhancement here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.