Closed Bug 1146882 Opened 5 years ago Closed 3 years ago

Starting tab sharing before the call will not show the tab when someone joins conversation

Categories

(Hello (Loop) :: Client, defect, P3)

defect

Tracking

(firefox41- affected, firefox42- affected, firefox43 affected)

RESOLVED WONTFIX
Tracking Status
firefox41 - affected
firefox42 - affected
firefox43 --- affected

People

(Reporter: bogdan_maris, Unassigned)

Details

Attachments

(1 file)

Affected builds:
- latest Nightly 39.0a1
- latest Aurora 38.0a2

Affected OS`s:
- All platforms

STR:
1. Start Firefox
2. Click Hello icon
3. Click 'Get Started'
4. Click 'Start a Conversation
5. Click 'Share your screen' button
6. Select 'Share your tabs'
7. Copy the link in a new tab
8. Click Join the conversation
9. Select your webcam and mic and click 'Share selected devices'

Expected results: Tab is shared when someone joins the conversation.

Actual results: Tab is not shared.

Notes:
1. I was not able to reproduce it every time.
2. Also this reproduces if I use two computers.
Bogdan, I can't reproduce this easily.

Could you turn on logging for the standalone UI and get a grab of the logs when this happens?

To turn on logging:

1) Visit the link page
2) Open the Web Console (Tools -> Web Developer -> Web Console)
3) Enter the following:

localStorage.setItem("debug.dispatcher", true);

4) Reload the page and try to reproduce the issue.
Flags: needinfo?(bogdan.maris)
(In reply to Mark Banner (:standard8) from comment #2)
> Bogdan, I can't reproduce this easily.
> 
> Could you turn on logging for the standalone UI and get a grab of the logs
> when this happens?
> 
> To turn on logging:
> 
> 1) Visit the link page
> 2) Open the Web Console (Tools -> Web Developer -> Web Console)
> 3) Enter the following:
> 
> localStorage.setItem("debug.dispatcher", true);
> 
> 4) Reload the page and try to reproduce the issue.

Here is the console output: https://pastebin.mozilla.org/8827063
Flags: needinfo?(bogdan.maris)
Flags: needinfo?(standard8)
Mark, I am reviewing this bug to see if this can be fixed in time for FF40 release. 

Tracked for 41 and 42.
Bogdan, I am setting the status for 41 and 42 as affected. Please let me know if that is incorrect. Thanks.
Flags: needinfo?(bogdan.maris)
(In reply to Ritu Kothari (:ritu) from comment #5)
> Bogdan, I am setting the status for 41 and 42 as affected. Please let me
> know if that is incorrect. Thanks.

I can`t seem to reproduce this issue anymore using latest Nightly 42.0a1 or latest Aurora 41.0a2 (across platforms Windows, Ubuntu, Mac), so I think we can mark this as worksforme for now reopen it if this returns. Also I think we can drop tracking flags as well for now, just did that :)
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(bogdan.maris)
Resolution: --- → WORKSFORME
Untrack based on the previous comment.
Flags: needinfo?(standard8)
I was able to reproduce this issue on Firefox 41 beta 9 under Windows 7 64-bit. Bogdan, would you be able to investigate further this bug?
Flags: needinfo?(bogdan.maris)
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #8)
> I was able to reproduce this issue on Firefox 41 beta 9 under Windows 7
> 64-bit. Bogdan, would you be able to investigate further this bug?

I managed to reproduce as well, using latest Nightly and Firefox 41 beta 9 on Mac OS X 10.10.5 and Ubuntu 14.04 32-bit.
Status: RESOLVED → REOPENED
Flags: needinfo?(bogdan.maris)
Resolution: WORKSFORME → ---
Flags: needinfo?(standard8)
Ok, I can't reproduce this at all. Bogdan, can you try:

- Creating a room, reproducing just this, and let me have the room token.
- Getting the browser logs for the failure having enabled loop.debug.dispatcher and loop.debug.sdk prefs
- Getting the standalone logs for the failure having entered `localStorage.setItem("debug.dispatcher", true);` and `localStorage.setItem("debug.sdk", true);` in the web console.
Flags: needinfo?(standard8)
Rank: 35
Priority: -- → P3
(In reply to Mark Banner (:standard8) from comment #10)
> Ok, I can't reproduce this at all. Bogdan, can you try:
> 
> - Creating a room, reproducing just this, and let me have the room token.
> - Getting the browser logs for the failure having enabled
> loop.debug.dispatcher and loop.debug.sdk prefs
> - Getting the standalone logs for the failure having entered
> `localStorage.setItem("debug.dispatcher", true);` and
> `localStorage.setItem("debug.sdk", true);` in the web console.
Flags: needinfo?(bogdan.maris)
(In reply to Mark Banner (:standard8) from comment #11)
> (In reply to Mark Banner (:standard8) from comment #10)
> > Ok, I can't reproduce this at all. Bogdan, can you try:
> > 
> > - Creating a room, reproducing just this, and let me have the room token.
> > - Getting the browser logs for the failure having enabled
> > loop.debug.dispatcher and loop.debug.sdk prefs
> > - Getting the standalone logs for the failure having entered
> > `localStorage.setItem("debug.dispatcher", true);` and
> > `localStorage.setItem("debug.sdk", true);` in the web console.

Sorry, I missed this... Please needinfo me from the start so I can see it right away.

I tested using latest Nightly 45.0a1 with a call between Windows 7 64-bit and Windows 10 64-bit.

- Here is the room link:
https://loop-webapp-dev.stage.mozaws.net/gBznzpY4Y5Y#BdrNtPBuhmFQCTXI7MuDGQ

- Here is the browser console output
-- From the person who makes the call with those prefs enabled:
http://pastebin.com/cqgYA15L
I used this link room to generate the output: https://loop-webapp-dev.stage.mozaws.net/IwFYQzjODTg#sEzHZsFAcYt6FqC_G4mTHw
-- From the person that joins the call with those prefs enabled:
http://pastebin.com/qtB9KRLE
I used the same link from above.

- Having entered `localStorage.setItem("debug.dispatcher", true);` and `localStorage.setItem("debug.sdk", true);` in Web console I am prompted with a undefined reply from console (nothing appears in web console during the call). I opened a room and this is the browser console output:
-- From the person who makes the call: 
http://pastebin.com/qKTsMJ3d
I used link https://loop-webapp-dev.stage.mozaws.net/6A-t_ytLyjI#eqDjD8CVM5UpWMlYNlJprA
-- From the person that joins the call:
http://pastebin.com/K7xnZixt
I used the same link from above.
Flags: needinfo?(bogdan.maris) → needinfo?(standard8)
To make it clear, I was able to reproduce this with calls between Windows 7 machine and Windows 10 Dell Ultrabook.
Since we changed how tab sharing is setup, this is no longer applicable.
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Flags: needinfo?(standard8)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.