Share screen info bar remains visible in fullscreen

RESOLVED INVALID

Status

Hello (Loop)
Client
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: adalucinet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Reproducible on Aurora 38.0a2 (Build ID: 20150318004012) and Nightly 39.0a1 (Build ID: 20150318055750) with e10s disabled
Affected platforms: Mac OS X 10.9.5, Windows 7 x64, Ubuntu 14.04 x32

Steps to reproduce:

1. Open Aurora/Nightly.
2. Click Hello icon.
3. Click 'Share your screen' icon.
4. Select 'Share my Tabs'.
5. Enter fullscreen.

Since the expected result is not quite sure here, e.g.: e10s, EME and 'Please rate Firefox' infobars are not displayed in fullscreen, I tend to say that the info bar shouldn't be visible in fullscreen.
Can you attach a screenshot of what you are seeing? I went through the steps on OSX 10.10.3 and it seems fine to me that a bar appears (it's basically the entire browser without the Menubar and Dock.
Flags: needinfo?(alexandra.lucinet)
Apparently EME`s infobar has the same behavior as tab sharing infobar which I think is not the right one. All similar infobars should behave the same when switching Firefox in fullscreen.

Eg:
Tab sharing infobar gif - https://db.tt/y14Haxci
e10s infobar gif - https://db.tt/lw8eZ5lZ
Flags: needinfo?(alexandra.lucinet)
I'd argue that for Tab Sharing, it's important to keep it visible on the screen until the user acknowledges it as a reminder that what they are doing is visible to other parties.

Phlsa, what is your opinion?
Flags: needinfo?(philipp)
Hm, I agree on the tab sharing info bar (especially since it is user-initiated and not just something that Firefox throws at you).

Do all other info bars share that behavior or are those special cases?
Flags: needinfo?(philipp)
Oh, and I just realize that you answered that question in comment 0 :)

Is there a case for the EME bar to remain visible in case the user has full screened a video that can't be played because EME is disabled?
Yes, I would say the EME bar should be displayed as well.
(In reply to Sevaan Franks [:sevaan] from comment #6)
> Yes, I would say the EME bar should be displayed as well.

Sevaan could you file a bug for that to be implemented then? I'm off closing this bug as INVALID, because this is working as intended.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Flags: needinfo?(sfranks)
Filed Bug 1152833
Flags: needinfo?(sfranks)
You need to log in before you can comment on or make changes to this bug.