[CDMA] Cannot merge 3-way call

RESOLVED FIXED in 2.2 S9 (3apr)

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mschwart, Assigned: gsvelto)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 810202])

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

4 years ago
STR:
# Initiate a MO CDMA call
# Add a new call

Expected: Merge button should be available
Observed: No merge or swap button is available

This is a regression from https://bugzilla.mozilla.org/show_bug.cgi?id=977588#c112

Updated

4 years ago
blocking-b2g: --- → 2.2?
Whiteboard: [CR 810202]
Whiteboard: [CR 810202] → [caf priority: p2][CR 810202]
Comms triage: Regression from 2.1 on a use case which will impact CDMA phones
blocking-b2g: 2.2? → 2.2+
Assignee

Comment 2

4 years ago
Taking this since I'm familiar with the topic.
Assignee: nobody → gsvelto
Target Milestone: --- → 2.2 S9 (3apr)
Reporter

Comment 3

4 years ago
According to https://bugzilla.mozilla.org/show_bug.cgi?id=977588#c118 the mergeable/switchable flags from TelephonyCall should be used instead and these checks removed.
Assignee

Comment 4

4 years ago
Working on this.
Status: NEW → ASSIGNED
Assignee

Comment 6

4 years ago
Comment on attachment 8585765 [details] [review]
[gaia] gabrielesvelto:bug-1147123-cdma-3way-merge > mozilla-b2g:master

I can't test this patch since I don't have a CDMA device available and the emulator doesn't support it yet; but if the telephony code is doing its job properly on real devices this should work.

I've removed tests that didn't make sense anymore and updated the remaining ones.
Attachment #8585765 - Flags: review?(drs)

Comment 7

4 years ago
M4, could you please test the patch provided by Gabriele.
Flags: needinfo?(mschwart)
Comment on attachment 8585765 [details] [review]
[gaia] gabrielesvelto:bug-1147123-cdma-3way-merge > mozilla-b2g:master

See my comments on the PR. Would also like to get the results of partner testing before we land this.
Attachment #8585765 - Flags: review?(drs) → review-
Assignee

Comment 9

4 years ago
Comment on attachment 8585765 [details] [review]
[gaia] gabrielesvelto:bug-1147123-cdma-3way-merge > mozilla-b2g:master

Addressed the review comments. I've moved around some tests and added more to better capture the changes I made. I hope this is good enough; I have to ask you to land this for me once it's r+'d and handle the upflit too.
Attachment #8585765 - Flags: review- → review?(drs)
Attachment #8585765 - Flags: review?(drs) → review+
Needinfo to request uplift. We should wait for M4's test results first, though.
Flags: needinfo?(drs)
Attachment #8586407 - Attachment is obsolete: true
Reporter

Comment 13

4 years ago
I can merge calls with this patch.  I can't add another call once I'm in the conference state (someone has dropped off and I want to call them back) but that's another issue...
Flags: needinfo?(mschwart)

Comment 14

4 years ago
Doug, please uplift this patch to 2.2.
Comment on attachment 8585765 [details] [review]
[gaia] gabrielesvelto:bug-1147123-cdma-3way-merge > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Incomplete functionality from bug 977588.
[User impact] if declined: CDMA users will be unable to merge conference calls into 3-way calls.
[Testing completed]: m4 tried this. See comment 13.
[Risk to taking this patch] (and alternatives if risky): Medium as we can't test this ourselves since it's CDMA-only, and it's a fairly big patch, but there's no real alternative.
[String changes made]: None.
Flags: needinfo?(drs)
Attachment #8585765 - Flags: approval-gaia-v2.2?(bbajaj)

Comment 16

4 years ago
Bhavana, please get this uplifted to 2.2.
Flags: needinfo?(bbajaj)
Flags: needinfo?(bbajaj)
Attachment #8585765 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.