multiple DNS entries not used when sending mails

VERIFIED DUPLICATE of bug 86917

Status

MailNews Core
Networking
--
minor
VERIFIED DUPLICATE of bug 86917
16 years ago
10 years ago

People

(Reporter: Lionel Bouton, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011010
Netscape6/6.1b1
BuildID:    20011208

When sending a mail through a FQDN which maps to multiple IP addresses, only the
first one is used even if it fails.
One needs to close Mozilla and restart it several times in order to catch the
"good" IP.

Reproducible: Always
Steps to Reproduce:
1. Use an fqdn which maps to several IP for your smtp server with one IP down.
2. Try sending one mail, quiting mozilla, launching mozilla, sending, quiting,
... several times


Actual Results:  Sooner or later sending fail.
when failing a tcpdump shows that the smtp connection is tried on the same IP at
every try.

Expected Results:  Send the message through one of the available IPs.

Most probably Mozilla uses only the first IP returned by the resolver. The order
of IP adresses is roughly random, so the problem might be difficult to catch.

Workaround : for experimented users, entering a known good IP address.
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 86917 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.