[EME] non MSE video errors out when media.eme.mse-only is true

RESOLVED FIXED in Firefox 39

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: cpearce, Assigned: cpearce)

Tracking

(Blocks: 1 bug)

unspecified
mozilla39
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox38 unaffected, firefox39 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Regression from  Bug 1134434. If we load an EME video and media.eme.mse-only is true, we still error out.

EME in non-MSE video is officially unsupported, but since all Adobe's tests rely on it and the fix is simple and we're hustling to ship EME we don't want to add work on Adobe at this stage so we'll fix this issue.
(Assignee)

Comment 1

3 years ago
Created attachment 8582779 [details] [diff] [review]
Patch
Attachment #8582779 - Flags: review?(edwin)
(Assignee)

Comment 2

3 years ago
Needs uplift.
Flags: needinfo?(cpearce)
https://hg.mozilla.org/mozilla-central/rev/3779bb7888d3
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
(Assignee)

Comment 5

3 years ago
Comment on attachment 8582779 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: EME
[User impact if declined]: We only support EME inside MSE video, but Adobe's unit tests still use EME in non-MSE video. I don't want to disrupt Adobe's dev cycle, so we provide a pref for Adobe to use that makes EME work in non-MSE video so that their tests work. This broke (because our tests don't cover this case). I don't want to delay Adobe by breaking their tests, and without this uplifted, Adobe's unit tests (which use EME in non-MSE video) won't work in Firefox 38. 
[Describe test coverage new/current, TreeHerder]: Adobe's unit tests cover this. We deliberately don't cover this code path in our own code; it's for our partner's convenience.
[Risks and why]: Low; this code path is preffed off by default.
[String/UUID change made/needed]: None.
Attachment #8582779 - Flags: approval-mozilla-aurora?
Attachment #8582779 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Bug 1134434 hasn't landed on Aurora.
Comment on attachment 8582779 [details] [diff] [review]
Patch

This missed the uplift to Aurora. It'll need to go through the Beta approval process.
Attachment #8582779 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 8

3 years ago
As Ryan says, the regressor isn't in Firefox 38. So nothing more to do here.
status-firefox38: --- → unaffected
(Assignee)

Updated

3 years ago
Flags: needinfo?(cpearce)
You need to log in before you can comment on or make changes to this bug.