[Flame][Video]User can't scroll the video list after rotating the screen 180° on video list view and then long press home button .

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System::Task Manager
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Norry.L.F(Leave from Mozilla), Assigned: sfoster)

Tracking

({regression})

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l][systemsfe])

Attachments

(6 attachments)

(Reporter)

Description

3 years ago
Created attachment 8582976 [details]
video_1503.mp4

[1.Description]:
[Flame v2.2 & v3.0][Video]User can't interact with the application via screen touch after user rotate screen 180° and then long press home button.
Found time:15:03
Attachment:logcat_1503.txt & video_1503.mp4

[2.Testing Steps]: 
Prerequisites:There are more than 6 videos.
1.Open video app.
2.Rotate screen 180°.
3.Long press homebutton.
4.Slide screen.

[3.Expected Result]: 
4.User can't scroll the video list.
or
4.Device open card view.

[4.Actual Result]: 
4.Device device will rotate screen and user can't scroll the video list.

[5.Reproduction build]: 
Flame 2.2:(Affected)
Build ID               20150324002504
Gaia Revision          014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gaia Date              2015-03-23 23:27:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7a9f2a248e57
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.041652
Firmware Date          Tue Mar 24 04:17:03 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0:(Affected)
Build ID               20150324160206
Gaia Revision          aebfbd998041e960cea0468533c0b5041b504850
Gaia Date              2015-03-24 17:08:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/264387e7e453
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.193523
Firmware Date          Tue Mar 24 19:35:34 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
This issue also exist on other apps (gallery,browser...)
(Reporter)

Comment 1

3 years ago
Created attachment 8582977 [details]
logcat_1503.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
This issue can repro on latest Flame 2.2 3.0 , Nexus5 2.2 3.0 build,The STR is same as Comment 0.
Reproduce rate:5/5
See attachment:logcat_1744.txt

Build version:
Flame 2.2 (affected)
Build ID               20150428002500
Gaia Revision          9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gaia Date              2015-04-27 20:41:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e79c19bf19bf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150428.042318
Firmware Date          Tue Apr 28 04:23:30 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (affected)
Build ID               20150428010206
Gaia Revision          0636405f0844bf32451a375b2d61a2b16fe33348
Gaia Date              2015-04-27 16:42:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/caf25344f73e
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150428.043926
Firmware Date          Tue Apr 28 04:39:37 EDT 2015
Bootloader             L1TC000118D0


Nexus5 2.2 (affected)
Build ID               20150428002500
Gaia Revision          9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gaia Date              2015-04-27 20:41:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e79c19bf19bf
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150428.041949
Firmware Date          Tue Apr 28 04:20:07 EDT 2015
Bootloader             HHZ12f

Nexus5 3.0 (affected)
Build ID               20150428010206
Gaia Revision          0636405f0844bf32451a375b2d61a2b16fe33348
Gaia Date              2015-04-27 16:42:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/caf25344f73e
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150428.043749
Firmware Date          Tue Apr 28 04:38:06 EDT 2015
Bootloader             HHZ12f
Whiteboard: [2.2-nexus-5-l]
Flags: needinfo?(gchang)
Hi David,
This might need your help to dispatch to right owner.
Flags: needinfo?(gchang) → needinfo?(dflanagan)
I can reproduce this in the gallery app, too, and I see another weird behavior as well.

1) launch gallery

2) rotate 180 degrees

3) long press the home button. This is when the bug first appears. The screen rotates back to its normal orientation in preparation for displaying the task manager. But the task manager never appears and the app gets stuck and is unresponsive.

4) rotate the phone back to normal orientation

5) press the home button to return to the homescreen, and then tap the gallery icon to go back to the gallery

6) gallery can now scroll up and down, so but seems to be resolved... BUT:

7) rotate the phone 90 degrees and see that the task manager comes up!

This is clearly a bug in the window management (or maybe task manager) code. Changing the component and asking Alive to take a look.
Component: Gaia::Video → Gaia::System::Window Mgmt
Flags: needinfo?(dflanagan) → needinfo?(alive)
Looks like task manager failed to close the active app but succeeded to put a screenshot overlay on the app window?

Sam or Michael, could you track this bug?
Flags: needinfo?(sfoster)
Flags: needinfo?(mhenretty)
Flags: needinfo?(alive)
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l][systemsfe]
Trying the new components :)
Component: Gaia::System::Window Mgmt → Gaia::System::Task Manager
blocking-b2g: --- → 2.2?
Flags: needinfo?(mhenretty)
(Assignee)

Comment 8

3 years ago
Yeah I'll take a look
Assignee: nobody → sfoster
Flags: needinfo?(sfoster)
(Assignee)

Comment 9

3 years ago
I'm not currently able to reproduce this, either with the original STR, or from Comment #5. Is this still occuring for you :djf?

(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #6)
> Looks like task manager failed to close the active app but succeeded to put
> a screenshot overlay on the app window?

We could make showing the task manager contingent on the active app becoming hidden, but I'm not quire sure how we would get into this state. My only idea is that AppWindow's enterTaskManager method calls this.close only if the transitionController and element exist. Is it possible the app got killed already - sometime during the holdhome and animation to show task manager? if requireClose doesnt get called, we would not trigger the visibility change on the active app and maybe that would result in these symptoms? Until I can repro I can't really test this or any other hypothesis however.
Flags: needinfo?(dflanagan)
Sam,

I just flashed today's nightly mc engineering build to my Flame and the STR in comment 5 still reproduce the bug for me. I have only 319mb of memory, which might be relevant, I suppose.
Flags: needinfo?(dflanagan)
It also reproduces easily for me on todays 2.2 build on flame-kk, so this is not a nexus5-l specific bug.

And it is memory-independent. It just happened with 1024mb as well.
(Assignee)

Comment 12

3 years ago
Ah ha! Rotating 180 degrees is the key to this bug. If you just rotate between portrait and landscape all is well. Ok, I can track this down now.
Created attachment 8602379 [details] [review]
[gaia] sfoster:task-manager-flip-bug-1147315 > mozilla-b2g:master
(Assignee)

Comment 14

3 years ago
Comment on attachment 8602379 [details] [review]
[gaia] sfoster:task-manager-flip-bug-1147315 > mozilla-b2g:master

We don't get a resize event for 180 degree orientation changes, so bad things were happening. Not sure this is the best fix, but its a start.
Attachment #8602379 - Flags: review?(etienne)
Comment on attachment 8602379 [details] [review]
[gaia] sfoster:task-manager-flip-bug-1147315 > mozilla-b2g:master

Didn't find any magical event sequence to help us out without a timeout :/

But, since the screenshot stays the same in the 180deg rotation case, I'm really tempted to just go ahead with the task manager launch without waiting.
ie. Keeping only the part of the patch fixing shouldResize.

I tried locally and it looks really solid :)
Attachment #8602379 - Flags: review?(etienne)
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 16

3 years ago
Comment on attachment 8602379 [details] [review]
[gaia] sfoster:task-manager-flip-bug-1147315 > mozilla-b2g:master

Yeah, just skipping the timeout entirely for the 180 degree case seems to work out just fine.
Attachment #8602379 - Flags: review?(etienne)
Comment on attachment 8602379 [details] [review]
[gaia] sfoster:task-manager-flip-bug-1147315 > mozilla-b2g:master

Thanks!
Attachment #8602379 - Flags: review?(etienne) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Target Milestone: --- → 2.2 S12 (15may)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

3 years ago
Comment on attachment 8602379 [details] [review]
[gaia] sfoster:task-manager-flip-bug-1147315 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Task Manager
[User impact] if declined: Entering task manager with device flipped 180 degree rotations can cause some apps to appear unresponsive
[Testing completed]: Tested on device, new unit test
[Risk to taking this patch] (and alternatives if risky): Low risk, refines existing logic in task manager
[String changes made]: None
Attachment #8602379 - Flags: approval-gaia-v2.2?

Comment 20

3 years ago
Comment on attachment 8602379 [details] [review]
[gaia] sfoster:task-manager-flip-bug-1147315 > mozilla-b2g:master

Approving the patch for 2.2 and request for QA verify after patch landed there.
Attachment #8602379 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Updated

3 years ago
status-b2g-v2.1S: --- → unaffected
status-b2g-master: affected → fixed
Keywords: regression, verifyme
This issue is verified fixed on latest build of Flame 3.0 & Nexus5 3.0,the STR is same as Comment 0.
Reproduce rate:0/5
See verify3.0.mp4
Flame 3.0(Fixed):
Build ID               20150510010201
Gaia Revision          5b2a150f6f5d29bddfaac13fcbbf099376f2f275
Gaia Date              2015-05-09 12:34:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/77d92f6d7679
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.045933
Firmware Date          Sun May 10 04:59:44 EDT 2015
Bootloader             L1TC000118D0

Nexus_5 3.0(Fixed):
Build ID               20150510010201
Gaia Revision          5b2a150f6f5d29bddfaac13fcbbf099376f2f275
Gaia Date              2015-05-09 12:34:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/77d92f6d7679
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150510.044405
Firmware Date          Sun May 10 04:44:24 EDT 2015
Bootloader             HHZ12f
QA Whiteboard: [MGSEI-Triage+]
status-b2g-master: fixed → verified
Keywords: verifyme
Verson, could you help verify 2.2?
Flags: needinfo?(xiongfuchao)
Keywords: verifyme
This issue is verified fixed on latest build of Flame 2.2 & Nexus5 2.2,the STR is same as Comment 0.
Actually Result:Device will open task manager.
Reproduce rate:0/5
See verify2.2.mp4
Flame 2.2(Fixed):
Build ID               20150512162502
Gaia Revision          e048df68f6f4853b5826a8816e143d95258149de
Gaia Date              2015-05-12 19:10:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9edadb35caca
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150512.202452
Firmware Date          Tue May 12 20:25:03 EDT 2015
Bootloader             L1TC000118D0

Nexus_5 2.2(Fixed):
Build ID               20150512162502
Gaia Revision          e048df68f6f4853b5826a8816e143d95258149de
Gaia Date              2015-05-12 19:10:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9edadb35caca
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150512.202258
Firmware Date          Tue May 12 20:23:14 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
Flags: needinfo?(xiongfuchao)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.